Fallout 2 mod Megamod version 2.47 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Mar 20, 2017.

  1. obimark

    obimark First time out of the vault

    Aug 1, 2012
    Unfortunately I did not have enough time to test as I would have liked. I have not yet managed to level Sulik via normal means. However I did manage to level both Sulik and Klint via exploit.
    If combat control for party members is turned on and combat ends while you are controlling one of the party members that party member will gain experience and, since party members are all level 0, immediately level up. This is... somewhat exploitable and not really in the spirit of the game, but it gives nice party members pretty fast.
    I do lose on the experience since it goes to the party member.
    EDIT: I managed to level up Sulik & Klint the regular way. It seems with that level-up the exploit level was overwritten. I will continue to play and report when I have more data.
    Good news is that party members retain their levels.
    I think Hubal has same issue.
    I do love enhancements to mod, especially highlighting items, corpses, shelves...
    Thank you for that.
    Last edited: Dec 15, 2018
  2. Voiddweller

    Voiddweller First time out of the vault

    Nov 2, 2008
    Thanks! Will be useful for adding more visual armor archetypes from Olympus.
  3. Muttie

    Muttie It Wandered In From the Wastes

    Oct 9, 2017
    In addition to the dcBilly.int script (which, btw, changes the payment if replacing the one in MM), RP mod has another script (dcjoey.int) which features an improvement compared to its MM counterpart (i.e. Joey walks back after sex, as long as you don't leave the map before he's done walking, then he gets stuck and always returns to that spot from then on). Not a big deal, but as there is a working fix (in both cases) I guess MM can simply copy & paste that part in without too much difficulty.
  4. Voiddweller

    Voiddweller First time out of the vault

    Nov 2, 2008
    Got a CTD in Broken Hills when aim at Chad's house door. Doesn't matter if i have quest or not. Shooting it or trying to blow it up also causes a crash.

    Guess it's not related to a specific script, but to some variable or condition, because drawer inside also causes a CTD
    Last edited: Dec 22, 2018
  5. _Pyran_

    _Pyran_ Still Mildly Glowing

    Jan 31, 2017
    Reseting levels from party member - error in the script gl_party_combat script (Mr.Stalin fixed this bug).

    MM bugs - when you look at a scorpion & smalt scorpions in BH there is a crash. Need corect proto files, from old version mm or RP. They are not in the new version (2.47.x)
  6. Dretnoth

    Dretnoth First time out of the vault

    Dec 9, 2015
    Hi fellows... do you know Fallout 2 mod (conversion) called Nevada?
    There food actually gives a Healing Rate for several hours for resting purpose, and few HP right when eaten. Some fight whit irradiation, some increase carry weight. So how it sound?
    There is crafting system that can produce stuff by using special camp-fire and some engineer tables. You can prepare foods there like noodles for +25HP, or produce ammunition, preparing medications or drugs (chemical lab table).
    So on the question of food how it will sound this. How hard it will be implied or is even possible for MM? Will be authors of Nevada angry if it will be used?

    fruits and veggie = +1-10HP, +1-10(Based on Endurance?) Healing Rate, +1 Irradiation point
    any meats = +1-10HP, +1-10(Based on Endurance?) Healing Rate, +1-10(Based on Strength?) carry weight, Chance to get poisoned
    Nuke-Cola and Fizzy Drinks = +1-5HP, -1-10(Based on Endurance?) Irradiation [decrease], Chance to get poisoned and if drink to much strength/ resistance decrease
    Healing Powder = no weight, +5+Endurance+Luck+1(for every 10 points in doctor)HP, Chance to -1 Perception, -5 on end use of all Skills (Because hallucinogen), increased shop cost
    Stim-pack = +5-10+2*Endurance+2*Luck+1(for every 10 points in first aid)HP
    All Alcohols: -5 on end use of all Skills (Because drunk), Chance to get poisoned and if drink to much Perception/ Intelligence decrease (maibe for frst -1 one, but for -2 two others)
    Beer = +1-4 Healing Rate, -2-8 poison,
    Booze = +1-3 Armor class, + 5-10% poison resistance, -1 sequence
    RootGun = +1-5 Irradiation, + 5-10% Irradiation resistance, -1 Healing Rate
    Jet = shall not have permanent -1 strength but long duration -5-1(based on Luck) on end use of all Skills

    buying/ paying for rest room = 10-20 Healing Rate and process actual resting or half
    • [Rad] [Rad] x 1
  7. obimark

    obimark First time out of the vault

    Aug 1, 2012
    All right, I did some further testing, up to Navarro.
    The party bug still haunts me, but I read about solution, so no biggie.
    In abbey I can't escort unhappy brother to Gecko. He doesn't want to go, his loss.
    I can't get location of EPA, Myron won't drop it even if I do drop him.
    BOS bunker and research facility are still bugged. Can't get to enter either of them without editing gvars.
    Can't get to Carson or broken reactor.
    In Navarro there are no longer quests to visit Toxic caves or retrieve black box.
    In Primitive tribe I didn't get the quest to deliver knives and spears. I am playing with female character, maybe that's why.
    In San Francisco I can't get quest to find missing corpse.

    I did get the kevlar armor for Dogmeat. That looks great.
    All in all, game is quite playable.
  8. chieftain486

    chieftain486 War. War never changes...

    Apr 9, 2017
    You didn't get the quest with knives and spears probably because it was replaced with the "expose the dishonest trader" quest. )
  9. pidzi

    pidzi First time out of the vault

    Jan 12, 2019
    I just ran into bug where in Toxic Cave map there is not exit grid, playing in 1024x768 resolution, latest version of the mod. Until now i have not come across any other bug but this one.

  10. Nirran

    Nirran Vault Senior Citizen

    Apr 15, 2007
    try a higher resolu

    edit : also if using f2 reso mod,check this setting in f2_res.ini

    ; if IGNORE_MAP_EDGES=0 - Hi-Res map scroll edges are enabled.
    ; if IGNORE_MAP_EDGES=1 - Hi-Res map scroll edges are ignored.
    ; if IGNORE_PLAYER_SCROLL_LIMITS=0 - scroll limits from player are controlled by the variables SCROLL_DIST_X and SCROLL_DIST_Y found below.
    ; if IGNORE_PLAYER_SCROLL_LIMITS=1 - scroll limits from the player are ignored.
    Last edited: Jan 20, 2019
  11. pidzi

    pidzi First time out of the vault

    Jan 12, 2019
    Thanks for tips but neither higher resolutions (actually i tried every single resolution) nor the edit in f2 ini helped.

    Any other suggestions ?

    thanks in advance.
  12. Nirran

    Nirran Vault Senior Citizen

    Apr 15, 2007
    what version of megamod u have installed?

    i remember this from an older version,try a save from before u entered caves and dl this into ur data/maps/ folder


    Attached Files:

    Last edited: Jan 23, 2019
  13. Nirran

    Nirran Vault Senior Citizen

    Apr 15, 2007
    maybe it is the hires file that contains the edge info,try this file,dl this into ur data/maps/ folder

    Attached Files:

  14. Drask

    Drask First time out of the vault

    Feb 6, 2019
    I'm still getting most of these issues, as well. With a few exceptions:

    Myron DID give me the EPA location, only after I actually dug up the Mordino stash.
    Dobbs seemed to "un-recruit" himself shortly after I got the combat implants. Maybe, because of the charisma drop? He simply disappeared. However, I do see him leveling in the text window now and then.

    I did manage to finish the EPA groundskeeper quest after killing the plants first. However, the reward, of letting you access the shacks on the surface; didn't seem to work. The doors are all locked. I didn't get a new keycard or anything either.
    Game didn't crash when killing creatures through the forcefields for me.
    I picked up an item that came up as "Matron" in the description it was a person.

    In addition, the door to the EPA research computer was inaccessible after I cancelled the password attempt before I found the "Flowerpot" password. Now that I have the password and click on the door, it just comes up as "continue" and wont open.

    When travelling from the EPA, I'm moved to a part of the world map that is about 7 tiles below Vault 13, rather than the EPA itself.

    Also, when wearing power armor and I try to loot something, I'm getting the remove helmet animation for some reason.

    Still getting the rest of the issues posted above using MM posted by Pyran on the previous page.
    Last edited: Feb 6, 2019
  15. Audicted

    Audicted Fallout Addict

    Nov 30, 2018
    Hi guys, I'm having trouble using Alt + Tab with this mod. ( Already searched the thread but couldn't find anything so i'm sorry if it's been asked before.

    I'm using 1280 x 720 resolution with Fullscreen option, tried all of the Directx settings to no avail. The outcome is always the same, I can alt tab to desktop, but when i try to switch back to the game, all i see is a black screen. Tried to switch to the game from the task manager, that didn't help either. When i hit ESC while i'm looking at the black screen, the menu appears, but as soon as i hit any button, menu stays there frozen, nothing changes. Tried to quit the game to the main menu while on the black screen, and when i load any saved game from the main menu, black screen returns. The only thing to do is to shut down the .exe completely and then relaunch the game.

    I'm using win 7 x64 bit with intel hd 3000 graphics. Is there any parameter to change to correct this from .ddraw or f2_res.ini ?

    This is so crucial for me, and i don't wanna play this with a windowed mode :(

    note: I haven't encounter such thing while playing the Restoration Project, Fallout Resurrection, Fallout 1 FixT, Nevada, or any of the vanilla games.

    note2: running fallout2.exe on compatibility mode doesn't solve the issue either.

    **SOLVED** Copying Fallout 2 High Res Patch 4.1.8 files
    to the game folder and overwrite the files seems to solve the problem. I don't know if this has any side effects but Alt + Tabbing back and forth seems to work now.
    Last edited: Feb 7, 2019
  16. MrWeedster

    MrWeedster First time out of the vault

    Oct 1, 2016
    Hey guys.

    I want to give this a try.
    I'm starting a new game with this mod, but i'm unable to get past the second door in the temple. In vanilla you're supposed to blow the door up, but here it seems like a normal door (Also there aren't explosives in the pot near the door). I can't open it, it just says 'error'. I tried lock picking it, same message: 'error'.

    What i'm doing wrong?
  17. chieftain486

    chieftain486 War. War never changes...

    Apr 9, 2017
    If it says "error" you probably installed it wrong. Also, in MM you shouldn't blow the door - just use the heavy metal pole on it.
  18. MrWeedster

    MrWeedster First time out of the vault

    Oct 1, 2016
    Ok, after some new installations i got it working now.

    I'm pretty far into the game right now, really great new fallout experience.

    But i have a serious bug: I can't enter the military base, it's always crashing.
    I tried going with fellows and alone, it doesn't seem to make a difference.
  19. Muttie

    Muttie It Wandered In From the Wastes

    Oct 9, 2017
    Sounds very much like a crash that occurs when your version is censored. Try to reduce violence setting to None before entering the base. If that fixes it, your version is missing death animations and corpses. (the crash occurs as the game tries to spawn corpses it can't find). If that is the case you may want to look for a blood patch or replace your critter.dat. (your critter.dat is probably 128.842 KB and the one you want should be 163.039 KB. You may try Fallout Nevada.)
    • [Rad] [Rad] x 1
  20. MrWeedster

    MrWeedster First time out of the vault

    Oct 1, 2016
    Ah ok, that did the trick, thanks a lot.

    Now i have the next two issues: The tanker crew and the emperor both mention the submarine, and i also got the password to go there. But there is no boat on the docks. If i just go with the tanker i can get without issue to the enclave.

    I also can't get to the EPA. Myron doesn't mention it when i try to leave him, he only tells about golgotha over and over again.
    In a guide i found that you can also get the location from dr. Sheng. I found the personal note of him in the biology workstation, but i don't get the dialog option from Dr. Wong to ask him about Sheng.
    I watched some youtube videos with some walkthroughs for the restauration project, and it looks completely different to mine. There are enhanced graphics/tilesets which i don't have.
    My Frisco looks completely like vanilla. Is it supposed to be like that or is my installation missing something?

    Also in the abbey i can't get the quest(s) to retrieve data from the different computers. Is it supposed to be there or is the megamod missing some missions from the restauration project?