Fallout 2 mod Megamod version 2.47 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Mar 20, 2017.

  1. Muttie

    Muttie Still Mildly Glowing

    Oct 9, 2017
    Bugs/Problems (version

    I've been wandering around aimlessly and:
    • In this save I have no quest from the Cold Heart faction. (Slot39Noquest) which is at the NCR.

    • But I do in this one “escort Jimmy” (Slot40Quest) which is at Vault 23. So there appears to be a false trigger/flag between NCR to Vault 23. I shouldn't have done more than travelling, perhaps entering a shop in NCR, but that's it.

    • However, as travelling is a bitch I created this save from slot39 (slot30Questbug). It's shortly before Vault 23, and upon entering, the Cold Heart quest appears. This bug is consistent.
    (all three save slots mentioned above: http://www.filedropper.com/savesmmbugs)

    Other stuff:

    - When I use speech to get the flint from Aunt Morlis I get no 50 XP, as I do when trading the pot for it. May be on purpose? Or an oversight.

    - When I have to prove that I've past the trial, the only option to do so is to name the culprit to Aunt Morlis and get confirmation. As far as I know, one has only one shot at this. If this is the case it may need a failsave. Like, more than one guess, or the option to confront Jordan (or anyone?) openly (i.e. Morlis is only conformation, not trigger), and have a fight (only 80 XP similar to attacking Jordan straight up). Or someone intervenes (Elder) to stop the infighting but it gives no XP as one's name hasn't been fully cleared (like: “You stopped the rumour from being uttered publicly, but your name hasn't been cleared. Doubts remain among your tribesfolk.”). I mean it's better to end the quest with a bad taste, than not ending it at all. Unless I'm missing something.

    - Around Arroyo & Klamath I have too many Kaga encounters. Feels like 1 out of every 4. I think Kaga should be more special, as, first, he is very deadly and second, well, it is supposed to be special. Right now it seems that dude is everywhere around Arroyo. You may have a look at how RP handled this. There it seems as if the player always gets a single Kaga encounter early (on the way to Klamath), but then it slows down and becomes more rare. (I think...although memory is a traitor ;).)

    - Ghost Town has no city label (in the menu on the right side when on the world map).

    - Lucas (Arroyo) says I have 12 days to bring him three pelts (in dialogue and quest entry). I tested it and it seems to be 14. So the dialogue/pip-boy entry has a typo/not been adjusted. Anyway 14 is good, as the quest may involve a travel to the Toxic Caves on top of travelling to Klamath, so the time may be needed. Wouldn't even mind 16 days, to allow to heal for a day, or dally a little (training, reading books, using first aid etc.).

    - The taxi in New Reno, puts the Stables and Golgotha on the world map, but not the SAD. Is that correct? I mean putting the SAD permanently on the worldmap for a 1000, seems OK, especially, when Sam Pritchard's Map is in the game (Golgotha).

    - This is from memory (earlier version): When I want to become a shaman I must avoid to kill the spore plants through force. The issue is that when I'm accompanied by Nagor or Klint, I can end up in combat with the plants and because I'm having a party I can't end combat other than by leaving the map. Should it happen that Nagor or Klint kill a spore plant, the shaman quest is over. At least that happened to me once. This is not really a bug, but more a beginners trap. But perhaps it's possible to reduce the aggressiveness of the plants somehow, perhaps by reducing their PE or a line of sight blocker? Not sure if that can work. Anyway, the aggressiveness of the plants was not an issue, until the player could end up not having to kill them. That redesign requires a redesign of the plants, too.

    - This is from Memory, too (earlier version): When I decide to help Smiley I can travel to the toxic caves and wipe all geckos on the ground level. Then I can change my mind and accept Sajag's offer. When I then return to the Toxic Caves the hunting party scenario plays out (kill all geckos), but it's impossible to do so as they are all gone. Perhaps the “hunting party of Sajag” could reset the map (remove all geckos, and add a few new ones)?
  2. Muttie

    Muttie Still Mildly Glowing

    Oct 9, 2017
    I did test this with a shaman and the geckos respawn whenever I leave and re-enter the Toxic Caves (Slot24ShamanGeckoHunt, this save is before accepting the quest from Sajag, you can now travel up there kill some (they respawn) or take the quest, kill some (they respawn)). So that shouldn't be an issue.
    After experiencing this I thought this was fixed now, or that I remembered it wrong. So I did a test with a Hunter, and it did bug out as described. Here is what I did: Slot12GeckoStart (I know of the toxics cave), Slot15GeckoDead (I just travelled to the cave and killed the ground floor Geckos), Slot16SamThief (I do the Sam quest by paying 200), Slot17KeyQuest (I take the key quest from Sajag), Slot18NoGeckos (and there are no Geckos at the Toxic Caves and it is impossible to finish the quest. I even tried to kill other geckos (Klamath) and get other skins. But it didn't work. Apparently the trigger is to kill 5 geckos (at the toxic cave) and deliver 4 pelts. The problem is that there are no 5 geckos left to kill). (Note: it may not to matter which geckos at the cave are killed, at least the Shaman can respawn geckos, kill those and it counts).
    I tried it in another combination: Slot13learnedskinning (I learned to skin geckos from Hughes, travelled to the cave. The hunting party was already there, just wouldn't talk. I killed and skinned all 5 Geckos, returned to Klamath got the “key quest”, back to the cave and it worked fine).
    So it seems the problem is: killing Toxic Cave Geckos as a Hunter before “betraying Smiley” as apparently the respawn of geckos is disabled for the Hunter. Something the Shaman isn't bothered with as the Geckos seem to constantly respawn. Which may be an economy exploit actually.

    Part of this problem may be that strangling the info out of Morlis is too difficult (apparently ST+EN needs to be 14 or more). Perhaps a more realistic requirement like ST6 or EN6 instead, or something like Unarmed 60% to 70%. Or a speech option. It is also possible to just kill Jordan (without any confirmation (i.e. talking to anyone, just attack and kill him)), but that feels weird. And on a side note Shania even tells me that Jordan fancies the chosen one (if female), which makes it even weirder when talking to people for clues. She literally says (underlined part):
    As this is a stark contradiction to what Jordan is doing (spreading ill rumours) perhaps that needs to change to:
    Here is a save to test it: Slot9Shania (go 2-2-4).

    Quest: “Rescue Smiley the trapper.”
    - When I use the reward from Ardin Buckner to free Sulik I get the 500 XP twice, once when talking to Ardin, and again when talking to Maida.
    - When Sulik is already free, the “nothing” option with Ardin Buckner does not give +75 karma.
    Save to test: Slot14SmileyReward

    - I don't know if the items are in the game, but their attacks are mixed up: Dart (thrust has a range of 15, and throw a range of 1) and Rusty Chain (swing has a range of 1 & 4 AP, and Punch a range of 2 & 5 AP) probably needs to be the other way round. And a minor point: the Envenomed Throwing Knife has a ST req. of 2, while the normal Throwing Knife has one of 3.

    Package of all saves mentioned: http://www.filedropper.com/mmsaveslots
    Last edited: Mar 9, 2019
  3. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Found some bad code in the map script. This problem has been fixed.

    It sounds like an oversight to me. If I can get that script apart without too much trouble (the TeamX files have proven difficult in the past, causing near-complete reconstruction many times), then I'll add the XP.

    That's a good idea. If the player botches it, then I'll have it somewhat resolved by the Elder stepping in.

    I remember thinking that once too.
    I have gone through the worldmap file and lowered the percentages somewhat. However, this is completely subjective. There may be people out there who will say now the chances are too low. Or, they may disagree with this entirely and believe he should pop up at every turn. Oh, well.

    I have no artistic ability. Others have always made the town labels in the past for this mod. That may not be one I ever requested.

    I have adjusted the quest log and dialog to say 14 days.

    Hmm. Maybe. I'll think about it. Honestly, I don't even remember this aspect of the mod. I thought he only took the player to the odd, random, easter-egg locations.

    Yeah, I always end up recruiting Klint after I complete that quest in order to avoid him taking out the spore plants. And how to fix it, since there is the possibility that the player has no interest in becoming a shaman and will attack the plants. I'd hate to limit the spore plants if that is the case.

    Perhaps. That will take a bit to try to work that out. Or, the other option could be to change their dialog (and quest requirements) depending on the number of geckos remaining.

    Keep those reports coming. I'll get all those bugs... eventually. And, thanks.
    Last edited: Mar 10, 2019
  4. DPoiman

    DPoiman First time out of the vault

    Mar 13, 2019
    Fallout : box version with 1.02 US patch
    Megamod : version

    i encounter bug with companions lvling, Easy to notice on Miria, she join on lvl 0 with 35 base heath )and 100 carry weight, so around meybe 3 str?) , on 1st lvl she ding up to 70 hp, but after some time i notice her stats return to basic 35 hp ... also similar problem i notice on Sulik, but i dont check other companions yet. (i build up a 10 char + cult of personality)

    also do their armor works? Sulik with hammer hits for around 5-10 hp, and single bandit with knife can swing him for 10-15 all time, and he run with metal armor :P or meybe their baypass armor? sometimes Miria is 1hit mob :|

    *EDIT: save/load after companion gain lvl, reset their stats to basic
    *EDIT2: save/load also remove power armor str bonus, so i think also any dr/ac bonus
    *EDIT3 : seems that i f*cked up on beginning - i dont run processdat2, after that, problems with lvl seems to stabilize, will report back soon if so.

    Skeeter on Gecko can upgrade your weapon for part + 0$ - its a bug, or should it be like that?

    Cassidy got a talking - Talking Head / Metzger mute - talking head, same like Lenny and Vic, like upper - its a bug, or should it be like that?
    EDIT* Answered : its should be like that - thx @naossano for answer

    also can i suggest to change Klint appearance to be different with Sulik? Meybe Generic male? or Long Hair Dude from appearance mod? (as we already got "bald dude" Cassidy :)

    also, there is option to change ammo packs back to that from original f2? new 10bullets with 2p weight overweights me in seconds!
    Last edited: Mar 14, 2019
  5. naossano

    naossano So Old I'm Losing Radiation Signs

    Oct 19, 2006
    Cassidy is the only characters who get a voice in the mods.
    Others either already had a voice in the main game or didn't and stayed mute.
    • [Rad] [Rad] x 1
  6. almostdead

    almostdead First time out of the vault

    Nov 6, 2014
    Thanks for the mod!
    But the dialogues of Cameron at the end of trails are still bugged. It shows error and incorrect sentences.
    Exactly the same thing as a post in 2015 said.

    Did I miss any steps while installing?
    1. download fallout 2 english version from steam
    2. unzip all megamod 2.47.1 files to fallout 2 folder
    3. run ProcessDat2
    4. play the game
    Last edited: Mar 14, 2019
  7. Muttie

    Muttie Still Mildly Glowing

    Oct 9, 2017
    I think the case of a player failing to use Hakunin's powder before Klint kills a plant is rare.

    The problem is rather that a player may kill the plants before learning of the possibility to become a shaman. And most likely as a consequence of the Spore Plants opening combat (i.e. they attack and the player fights back, kills them, and then Hakunin is upset for “some reason”). And if the player is with a companion, it is not even possible to end combat other than by leaving the map or killing the plants.

    That's the scenario that is concerning (i.e. it is too easy to end up in combat with the plants. Plus there is no incentive to avoid combat, at least initially). That said, isn't it an option to move the outside Spore Plant to the inside of the garden? This way the plants may not trigger combat whenever the player walks past. Or if all fails even moving the whole garden out of the way (to the east among the other fields, or to the left of Hakunin's tent)?
    And if the player then kills the plants on his own volition, good riddance (aka player choice).
    I'm saying this because it is usually the outside plant that starts combat. If you could get rid of that (i.e. the outside (or any) plant dragging the player into combat), it may be fine.
    If that's easier. Although that would mean the requirement (for the bug) would change to kill no geckos and bring 4 (or 0?) golden gecko hides, no matter how and where they've been killed.

    As I understood it, the problem of the bug is that the Arroyo Warrior has the “respawning” of Geckos disabled, which then in turn disables the quest's ability to spawn the 5 geckos the player is supposed to kill for Sajag's hunting party.
    So whenever an Arroyo Warrior kills a single Gecko at the Toxic Cave before “betraying Smiley”, then there will be zero geckos when joining the hunting party. Because the quest wipes all the remaining ones, and can't spawn 5 new ones, because it's disabled. So the quest would only consist of showing up at the caves (with snacks from Sajag).

    The only way to get any geckos at the Toxic Cave is to “betray Smiley” (either by “asking for the key” or by “asking to learn Gecko skinning”) before traveling to the Caves.

    Or by playing a Shaman who can spawn geckos by leaving/entering the caves indefinitely.

    Anyway, this is not even a major bug. It's only a weird scenario that plays out when an Arroyo Warrior decides to hunt the geckos at the cave without any intention of rescuing Smiley.

    Alternatively, you could allow the Warrior to respawn Geckos, just as the Shaman can. And somehow limit the purchase ability of Slim Picket. Like he needs to restock on money.

    Or, Slim Picket may reduce his pay. Perhaps to $150 for 3 golden and $75 for 6 silver. That's half of what Sajag and Maida pay, but his “shtick” may be that he doesn't run out of money (“I pay less, but what are your options, traveller?”), in opposite to Sajag/Maida who have only $150 to $250 every other week. This way farming Golden Geckos would be less of an issue. (I think there are about 10 at the caves which would be $450 per run, instead of $1125.) Besides, the player can also farm Gecko encounters (just takes longer). I mean there is no “strong” reason why the respawn is disabled for the Arroyo Warrior. The best reason is that it's odd that the cave repopulates just by leaving/entering it, but otherwise...

    Does your Fo2 installation include a file called “patch000”? Because that would mess up your game and may explain it. I think the MM readme says to rename or remove it.

    I did not test it but patch000 has a ACTEMVIL.msg which is Cameron. So if your Fo2 has that patch000, and the cfg is set to using it, then you should get a mess when talking to Cameron.
  8. almostdead

    almostdead First time out of the vault

    Nov 6, 2014
    That's exactly the problem! Thanks and sorry I didn't read the Readme thoroughly.
  9. Muttie

    Muttie Still Mildly Glowing

    Oct 9, 2017
    It's OK. I just been through all this problems over the past year, and FO is not particularly complicated but still, it takes hours over hours to figure it all out and get used it. The amount of time I spent on getting stuff to run is insane. (fix, test, fix, test, delete all, reinstall, test...)

    Anyway, I think we could run a better problem/solution system. One that consists of “symptom - cause - solution”. That would simplify realizing the problem and fixing it.

    For example:
    Cameron has a messed up dialogue - patch000 – remove/rename it.
    Crash at Military base (or places that spawn mutilated corpses, like Broken Hill underground) - censored critter.dat – replace (with one that has 163.039 KB), bloodpatch or reduce violence setting to none.
    All dialogue are Error messages – wrong language – set cfg and all “english” folders to the language of master.dat.
    I think especially keeping track of symptoms would be helpful.

    Update to my last post: This struck me as weird first (hunting zero Geckos), but thinking about it for another day, this actually may be a good solution if it's easy to implement and explained by a new dialogue line.

    Bug: A warrior kills all Geckos (or some) at the caves
    - Then betrays Smiley
    - Send to the cave by Sajag
    - The hunters kill Smiley & all Geckos but 5
    - The Warrior is asked to kill the rest Geckos (5) and bring their hides (4)
    OR: if the Warrior killed all or some Geckos previously (first point) (and there are no remaining as the spawn is disabled) Sajag's hunter says: “Thanks, but we took care of everything - already. [He looks at his mates.] Report back to Sajag.”

    That would be another perfectly fine solution, especially if it's easy to implement and working.

    EDIT (Kind of): Actually, in hindsight, I assume this is probably exactly what you meant and I just didn't get it. Especially as it (literally) said „to change their dialog (and quest requirements)“ I completely read over that part (shame on me).
  10. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    I have a tendency to abbreviate my intentions. But yes, you did interpret my intentions correctly in your edit. ;)

    I think it's not unreasonable to add more checks for Morlis. I never even paid attention to the endurance requirement. I'll need to consider this one a little more. Unarmed does seem like a good choice, though, as an additional check.
    And I like the proposal for Shania. I'll make that change.

    I'll add a check to their scripts so you can only get experience once. Regarding the karma issue: should the player really receive positive karma in the situation you describe? Has the player character already been given positive karma by freeing Sulik?

    The darts and chain aren't in the game yet. However, I have made the fixes. I have also fixed the envenomed knife to require the same strength as the regular throwing knife.

    Maybe I could just add a fence around the garden? And make it so the plants can't see or shoot through it. Make it locked unless the player has the quest to deal with the plants. Neither Klint nor Smoke will enter then. Also, if the player then chooses to pick the lock (very high chance of success) then they can deal with the consequences of their actions. What do you think?

    Both of the options you presented - limit Slim's purchase amount or purchase frequency - are good. Hmmm... Changing the price of the pelts is definitely the easier option. And it makes sense. Maybe I'll go with that option. I need to change the respawning rate of the toxic caves, though. There is a good reason for the respawning, though. Well, kind of. And it's tied to the Toxic Caves mod that I haven't implemented yet! I really need to add that. It was mostly finished, if I remember correctly. But, even then the respawning should occur on a timer, and not be the result of a simple exit and return.

    If I remember correctly, Skeeter offers the free upgrade if you complete a quest for him. Otherwise, you should have to pay. Did you encounter something different?

    I would like to have a different sprite for Klint. But, I have to be careful. Using the long hair dude, for example, would allow Klint to use all weapons. I don't want that. Plus, I still want him to look like a 'tribal'.

    You could go through the list of items and find the ammo you want to go back to the original version. Look inside the data/text/English/game folder and open the pro_item.txt file. Find the number of the item of the ammo you want to go back to the original version. Make a note of that number. For example: {36300}{}{7.62mm}. This ammunition is represented by the file 00000363.pro found inside the data/proto/items folder. If you delete that file, the game will revert to using the original default 00000363.pro inside the master.dat file (the original).
    Last edited: Mar 16, 2019
  11. Muttie

    Muttie Still Mildly Glowing

    Oct 9, 2017
    I think this has always been the case. I checked Jorner's guide but it makes no comments on karma. I need to check this. But anyway the amount of karma is too high either way. :)

    That would work. It may not even necessary to lock the door. As long as the player does not end up in combat, other than on his own volition (i.e. walking inside) it should be fine. Although the locked door would make sure that the player doesn't wander into it. On the other hand it would mean that a Warrior would have to start Hakunin's quest to kill the plants (and actually before agreeing to become a Warrior, as that cancels Hakunin's quest).

    There are some tribal options:
    There's NMPRMB(...).(...) in the RP Mod (Cat/African) but he can only use spears.
    HMR00S01 _hmwarr(...).(...) from Appearance mod (long hair) (hammer, spear, SMG)
    HMR00S02 _hmwarr(...).(...) from Appearance mod (bald) (hammer, spear, SMG)
    HMWAR2(...).(...) from FoRes (bald) (uses spear)
    HMR001S00 _hmwarr(...).(...) (Dreadlocks/African) (all animations, but you can always simply delete those you don't like)

    Sorry, but this is going to be long (I hoard too much)
    Take your time! It took a week to test, compile and write it. So you can take a week to read it ;)


    Rustle the brahmin
    -This quest does not appear in the pip-boy (which may or may not be an oversight).
    -The 250 XP for solving the quest (i.e. when reporting back to Sajag) are not displayed in the text window, only the karma loss is (if enabled).

    Umbra Tribe: treaty negotiations
    - It is possible to repeat the “treaty negotiations” with the Umbra Tribe indefinitely (just hold down 1) and each and every time it gives 1500 XP. http://www.filedropper.com/slot23negobug (you need to set up the agreement once, then you can repeat it over and over by holding down 1).

    Car breakdown
    - There is a minor bug when the car breaks down: upon leaving the encounter the player continues to travel with car speed until entering a settlement, however, this is kind of convenient when running to a mechanic :)), and second, a bit more serious bug, I managed to have the car break down on the Den circle, which makes the “broken down car” inaccessible. http://www.filedropper.com/slot45carbug. I had this a couple of times when driving from the Den (Smitty's place) straight to New Reno, however, for some daft reason (tired probably) I saved the “broken down car” over that save. However, it should be easy to reproduce anyway, just take the car from Smitty and go south-east, when the car breaks down quickly it should be on the Den circle (as in the save I submitted).

    pro_item.msg has two typos (in bold are the fixes):
    {31500}{}{Condom (Green package)}
    {31501}{}{This is a Jimmy Hats brand condom, a very reliable brand. This one contains phosphorous green dye.}
    {31600}{}{Condom (Red Package)}
    {31601}{}{This is a Jimmy Hats brand condom, a very reliable brand. This one contains phosphorous red dye.}

    Has a typo, the word nephew needs to be cousin (fixed below). Btw, this is actually a vanilla error that's still in the RP Mod.
    {203}{}{I'm still looking, cousin.}

    When having Sulik translate Torr's grunts & hollering (aka the sound and fury of the human soul trying to break free from its earthly prison), and ask about more details on rats. The following plays, but the part (in bold) is cut off as it goes beyond the number of characters allowed (that's 899).
    Either you need to add another line (255?) or shorten it to (changes in bold):
    I tested it and it's exactly on point (899 characters) (in fact, I had to remove a space and minus sign to fit it all in, but that's OK as the commas made it superfluous anyway). However, it removes the “China” and “conquer” reference but it may be self-explanatory. And it cuts down the joke a bit as its now an explaining metaphor, rather than an afterthought.
    And another option, more matter-of-fact would be:
    ...in South-East Asia. It was in the 18th century, when they started their conquest of the world.)}

    You may consider to use this rewrite, as it makes the riddle a bit clearer. At least to me. The first time I failed because I didn't understand what I was supposed to do (i.e. chose a number of coins from each bag, and then weigh them together).
    Suggestion (changes are in bold):
    Sexpert (SP)/Gigolo (G) seem to be messed up. My guess is is that some of the new content triggers SP, while old one still triggers G. And while I was at it (no pun intended), I also assigned Virgin of the Wastes (VW) to all saves and tested that (same thing: new content that triggers SP, removes VW, old content that triggers G (doesn't). There is only one exception; the Rave (oddly enough). Anyway, it may not take much to fix this (and include VW if wanted). For example, I run the scripts dcbilly & dcjoey from RP, and that alone switches it from “G” to “SP & VW removed”, so all it may need is to copy that section of the script and paste it in the old ones (right...?). Anyway, here is a list of all encounters I'm aware of (VW is only mentioned when removed): Shania/Arroyo (SP & VW removed). Trapper encounter (female on a specific male (one bald in leather armour, who appears to use EcTrapr2) is SP & VW removed, but any other case (i.e. male, or female on other males/females) is G as they appear to use EcTrappr) (note: that EcTrapr2 appears not to work properly, especially with males, see the open office document in the save folder). Bathhouse/Klamath (full body wash & Jenny (or Emily if enabled) are all G) (hand-wipe is G, but should probably not count as sex, see Cat's Paw BJ option), Emily as lover (G), work at bathhouse (doesn't count, which is OK as it's probably a hand-wipe job only), replace Jenny and work properly at bathhouse (triggers both SP & G, which is appropriate. However, they need to be switched around, i.e. G is guaranteed and SP only if scoring a rating of 9+). Krom (SP & VW removed). Den: Joey (G), Billy (G), Metzger (SP & VW removed), Sheila at the Hole (G), Karl (nothing, but should count as sex, you may check RP mod, which should have this fixed). Rave Party encounter (G & VW removed (oddly enough)). Leyla/Colly (nothing, but should count as sex). Miria (G), Davin (G). Amanda/VC (G), Phyllis (does not count, which is correct). Francis (SP & VW removed). Fannie Mae (SP & VW removed). Cat's Paw (Oral (does not count, which is correct), sex (SP & VW removed), talk (does not count, which is correct), special (SP & VW removed)), Little Jesus (G), Porn Star (G) (audition-failed counts but can't assign G because (scoring a 9+) is the requirement to pass the screen test (although it may be possible to fudge this: KSM, SA, CH8, ST10 and either EN or AG of 8+ while the other is below 8, should fail but trigger G (tested and it's correct))), Fluffer (does not count, which is correct), Mrs. Bishop (G), Angela (G), T-Ray (G), Myron (SP & VW removed). And that's all I've tested. I think each G should trigger SP instead (just as RP Mod did, otherwise marrying Miria/Davin may trigger Gigolo which feels wrong: “Monogamy Gigolo”)).
    Other stuff (repetition for convenience): replacing Jenny needs to switch G & SP around, the hand-wipe/Klamath needs to be set to no-sex (not as important yet, but may when including Virgin of the Wastes), EcTrapr2 may need fixing (see document), and Karl/Den and Leyla/Colly need to count as sex.
    Btw, you can check gvar 358 for “how many times” and gvar 194 for “how much it got rated” (194 is the total but I've set all saves to 0).
    Adjusting the old scripts shouldn't cause any problems (after all both G & SP have no effect in-game, as they are only representatives of an effect (scoring a 9+ on the sex-rating) or behaviour (having repeatedly sex). At least I'm not aware that they are used for anything else.
    Encounters that may/should exist but that I haven't tested are: Miss Kitty (I tried but couldn't shoehorn my way into the end-game, but it may trigger SP anyway, as the whole “Cat's Paw” seems adjusted), Robert Baron (from RP (Vault Village), the text is there but appears not be included?), Dex (EPA, from RP (EpaC10), appears not be included?) and Lao Chou (from RP (info on submarine), the text is there but appears not be included?). However all those are from the RP Mod anyway and should already be set to trigger SP.
    I think this should finalize the switch from G to SP (as RP did) unless I missed new stuff particular to MM. And once done it would also allow to implement VW, if wanted.
    Here are the saves (bigger package, VW is assigned to all cases and all saves are “edited” to trigger SP/G (rating of 9+) so you can test if changes trigger properly etc. You have to go through the dialogues though, hope you know your way around, it's not always obvious and guides often pass over it): http://www.filedropper.com/sex-test

    Losing to Francis should add +1 EN (it says so in the text window), but it actually reduces 1 point of EN (bug). You can test in the saves above but you'll need to reduce EN first (F12se). I tested it and it reduces EN once, and then not again. If I have EN 10 it gets skipped, which is correct, as 10 is maximum. I like this as this +1 EN may actually help to win the next time (if the req. are still the same as in vanilla) so this feature is kind of cool.

    During the marriage ceremony (Modoc), Davin & Jo keep looking in the wrong direction (there is always one when taking a picture, isn't there).

    Looking at Sheila (Den) with the binocular triggers an error message. I checked it and it's because her new msg changed that line to 110 (I think), while in the original it was 150 and the script still seems to look for that removed line. When I switched 110 to 150 the message would play. However, I don't know what the best method is, as Sheila has currently not implemented content. However, you may simply paste the original 150 line into her msg for now (perhaps with a comment that it's just a placeholder). I did that and it works. Here is how the top of my DcSheila.msg looks like:
    I believe Miria should use the 500 line in DcBilly after being pimped, but the Miria mod (?) seems to prevent that, and plays a standard conversation piece, which is a bit unfortunate as it takes the edge off the situation. If possible try to restore that as she should be revolted. I think it's important that actions have consequences, and she shouldn't just gloss over it with casual conversation.
    The same applies to the Fluffer option. It should play the 1200 line in NcCorBro.msg (for Davin & Miria) but doesn't, it again plays a casual response that disappears within a second.
    Perhaps it is possible to shoehorn the trigger from the original scripts (DcBilly & NcCorBro) into the new Davin & Miria ones?

    Miria & Davin do not switch back to “naked” (i.e. their original state) when taking their armour off. However, this may be considered an improvement as they switch to a hero model and look less goofy. However, not sure how I feel about this, as looking like the PC-Dude makes them look less unique. Then again, it's more of a hot-fix anyway, until they get their own armour models eventually (...in a galaxy far, far away).

    Sulik' dialogue screen (face animation) goes to a black screen when wearing leather jacket.

    The Gecko pelts at the Dunton's place, and the pelts found in Trapper Town (locked room) don't stack (different script?). However, Slim has no problem to accept 3 of each, so nvm.

    And you may want to add the new appearance mod options: http://www.filedropper.com/appearancenew
    And Foxx made a few fixes to the existing ones: https://drive.google.com/open?id=1yJbymGlqbIZPlJw7i4qODxgA5sA-KtL7 (but, see also below, where I put together a download with only the adjusted frms which should make inclusion easier)
    Here is a list of frms errors I'm aware of (I tried to test most but I may have made a few mistakes, especially regarding Lightsabers, and I may make an update, but I post this for now, as it's getting too long again):
    - HaEnroAN.(...) & HaEnroAO.(...) “may” need to switch their ending (i.e. AN is AO and vice versa). Although I'm not really sure. AN looks like getting hit, and AO like a dodge. However I can't tell what AP is (getting hit or dodge?). Normally, AN is dodge & AO & AP are getting hit (front & back), but perhaps it got switched around in FoTactics? Note: It's the same with MaArde(...).(...). So apparently FoT did this differently. Does this translate to Fo2? In my experience it shouldn't, as the game should use AN for dodge and AO & AP for getting hit (front & back). Same with HaFoTP(...).(...). Also with MaBot2, MaKomo, MaRat4, MaRch1 and MaRch2, but it's less obvious with monsters. If this is an issue, perhaps use AN for both AO & AP and use either (AO or AP, whatever looks better) for AN in all cases listed? I tested it in game and cockroaches play the dodge animation when hit (duck; AO/AP) and not the hit animation (jerk up and back; AN).
    - HaEnro(...).(...) is also missing placeholders (sword & saber, i.e. it needs a renamed set of D (Knife) for both). When I tested the Environment Armour with sword & saber it bugged out (btw, looks like walking around in an old, heavy diver-suit, weird at first but then kind of appropriate).
    - HaFoTP(...).(...) is missing placeholders (sword & saber, i.e. a renamed set of D (Knife)).
    - HaPow2(...).(...) P (rifle) is a placeholder. And placeholders for O & S (Saber) & Q (Sword) are missing. However, this model fights with „Helmet On“, so I think you may take all those frms (scoped rifle, saber, sword) from (HaPowr(...).(...)) and combine them with HaPow2PC.(...) & ...PD, ...VC & ...VD (for O, saber) & ...WC & ...WD (for sword Q). Only saber (red) isn't covered (has no “put helmet” on animation) & may need to use HaPow2D...).(...) (aka Knife) as placeholder, although those doesn't have the “helmet” animation either. So you may also use (the green saber (O) instead?), whatever is considered the lesser evil).
    - HfMetlQA.(...) This one wears Combat instead Metal armour. However, fixing this one may be more tricky. A temporary fix may be to use HfMetlDA.(...) (aka Knife), but it may look weird.
    - HfJmps(...).(...) has no placeholder for S. However, as O is just a placeholder, too you may simply copy those and adjust their endings (from O to S). Actually, when I tested this the green lightsaber (O) bugged out while the red one (S) worked (knife animation). Not sure if that is missing animations or the settings of MM (note: according to the pro files the weapon animation settings are switched, i.e. the green one is set to S and the red one to O).
    - HmBMetlLA.(...) should be HmBMetlIA.(...), typo (i.e. replace the ending LA with IA).
    - HmLthrOC.(...) is incomplete (no putting on of headband). However, you may use HmLthrVC.(...) (Unless the omission is on purpose to speed up the weapon drawing animation. Although QC (sword) plays out the complete animation).
    - HmMaxxOC.(...) may use HmMaxxVC.(...) same as before.
    - HmMetlOC.(...) may use HmMetlVC.(...) again
    - HmJmps(...).(...) has no placeholder for S. However, as O is just a placeholder, too you may simply copy those and adjust their endings (from O to S). Actually, when I tested this the green lightsaber (O) bugged out while the red one (S) worked (knife animation). Not sure if that is missing animations or the settings of MM (note: according to the pro files the weapon animation settings are switched, i.e. the green one is set to S and the red one to O).
    - NAVGULQB.(...) may be replaced by NAVGULDB.(...) so both move faster.
    - NMBONCPB.(...) may be replaced by NMBONCJB.(...) so both move faster.
    - NMBRSRPB.(...) may be replaced by NMBRSRJB.(...) so both move faster.
    - NMCACA(...).(...) misses RA, RB & RO, perhaps he needs placeholders from HmCmbt to avoid issues? And it misses G (spear), which is not a big problem, but probably a big problem to fix (lol).
    - NMCALJ(...).(...) may lose I (SMG, 10 frms), K (Large Rifle, 10 frms), L (Minigun, 8 frms) and M (Rocket Launcher, 8 frms) as Cassidy isn't supposed to use those types of weapons. You can simply remove these. Should you ever want them back you can plunder the Appearance mod frms, they are exactly the same.
    - NMCANA(...).(...) is using I (SMG) instead J (Rifle) & P (Scoped Rifle). However, NmCana is oddly unique (naked with black pants) and I would not simply delete the frms, but save them (i.e. instead removing, rename them to “old etc.”. At least I'm not aware of another mod that included these. Or keep them for the time being as this version of Cassidy can't use a rifle, so the SMG is a substitute of some sort.
    - NMCOPPPB.(...) may be replaced by NMCOPPJB.(...) so both move faster.
    - NMFATTPB.(...) & NMFATTQB.(...) may be replaced by NMFATTJB.(...) & NMFATTDB.(...) so both move faster.
    - NMGANGPB.(...) & NMGANGQB.(...) may be replaced by NMGANGJB.(...) & NMGANGDB.(...) so both move faster.
    - NMMEXIPB.(...) & NMMEXIQB.(...) may be replaced by NMMEXIJB.(...) & NMMEXIDB.(...) so both move faster.
    - NMMYCA(...).(...) is missing the Q (sword) placeholder (i.e. you need to rename copies of D (knife) to Q, otherwise he won't use the Wakizashi. At least that's my experience in RP. I tested it in MM and he won't use the Wakizashi, but equip a Combat Knife). (same applies to MYRNCA(...).(...) but that one may not be used anymore).
    - NMMYPA(...).(...) is also missing the Q placeholder and he has too many animations (E (Club, 7 frms), F (Hammer, 7 frms), G (spear, 7 frms), I (SMG, 9 frms), J (Rifle, 9 frms), K (large Rifle, 10 frms), L (minigun, 8 frms), M (Rocket launcher, 8 frms) can be removed). However, this is a bit debatable as putting Myron into Power Armour enabling him to use Energy Weapons (Plasma Rifle etc.) is an interesting upgrade for the character. However, the others may be removed, as they are all default power armour, so no particular reason to preserve them.
    - NMMYRNQB.(...) may be replaced by NMMYRNDB.(...) so both move faster.
    - NMOLDDPB.(...) may be replaced by NMOLDDJB.(...) so both move faster.
    - NMRGNGPB.(...) & NMRGNGQB.(...) may be replaced by NMRGNGJB.(...) & NMRGNGDB.(...) so both move faster.
    - NmSulaAO.(...) is missing, it seems. You may use AP as a place holder, even though he should jerk in the other direction when hit. And NmSulaBP.fr0, NmSulaBP.fr1 & NmSulaBP.fr2 may be the wrong frms (note: as the others (fr3 to fr5) are the correct ones this may not take that much to fix?). And NMmSulaBO.fr4 & NmSulaBO.fr5 may be shifty (check out RP mod, for the last two those may fix it if there is an issue).
    - NMVIPA(...).(...) has too many animations (E (Club, 7 frms), F (Hammer, 7 frms), G (spear, 7 frms), I (SMG, 9 frms), K (large Rifle, 10 frms), L (minigun, 8 frms), M (Rocket launcher, 8 frms) can be removed). However, this is a bit debatable as putting Vic into Power Armour enabling him to use Energy Weapons (Plasma Rifle etc.) is an interesting upgrade for the character. However, the others may be removed, as they are all default power armour, so no particular reason to preserve them.
    - HFR00S01 Foxx switched BA & BB, BD to BN and BO & BP from 1 frm to 6, as otherwise the default will be used apparently. (Fixes by Foxx: http://www.filedropper.com/hfr00s01fixes)
    - HFR00S01 has three misnames: 3 cases in _hfmetl(...).(...) are missing an „l“ and it needs to be added to _hfmet(...)Qg, _hfmet(...)Qm and _hfmet(...)Se, although the last should be superfluous.
    - HFR00S02 Foxx switched BA & BB, BD to BN and BO & BP from 1 frm to 6, as otherwise the default will be used apparently. (Fixes by Foxx: http://www.filedropper.com/hfr00s02fixes)
    - HMR00S01: _hmlthrOC.(...) is incomplete (no putting on of headband). However, you may use HmLthrVC.(...) (Unless the omission is on purpose to speed up the weapon drawing animation. Although QC is complete). And _hmmaxxOC.(...) may use HmMaxxVC.(...) same as before. And _hmmetlOC.(...) may use HmMetlVC.(...) again.
    - Of the New Appearance models HFR00S03 (punk girl): _hfjmps(...).(...) has problems using the green light saber, but the red one works (knife animation). Not sure if that is missing animations or the settings of MM (note: according to the pro files the weapon animation settings are switched, i.e. the green one is set to S and the red one to O). And at this point it seems as if MM can't play the special saber animations (SH, SI & SJ), only the knife swings (OG) and throwing attacks (AS) work.
    - And you actually may have to add the respective DM animation (throwing a knife) as a placeholder to all Saber animations (S & O) or the option to throw the Lightsaber may not be available, I think (and I thought wrong, see update). That's: HAENRO(...).(...), HAFOTP(...).(...), HANPWR(...).(...), HAPOW2(...).(...), HAPOWR(...).(...), HAROBE(...).(...), HFCMBT(...).(...), HFJMPS(...).(...), HFLTHR(...).(...), HFMAXX(...).(...), HFMETL(...).(...), HMCMBT(...).(...), HMJMPS(...).(...), HMLTHR(...).(...), HMMAXX(...).(...), HMMETL(...).(...) UPDATE: Actually I've tested it and it is possible to throw the weapon (apparently the model uses AS), so that means the weapon is thrown, but not lost (as DM probably would). So this is not an error but a design decision. However, I tested the Lightsaber with HmMaxx and it should have all frms needed but I can't attack (swing, aka OJ or SJ) with either version and only throwing & knife placeholder work. So there must be something wrong here. For starters it seems that weapon animation of the green saber (Obi-Wan) is set to S, and of the red saber (empress) to O, which needs to be switched, as the frms are O (green) & S (red).
    - Last there are a few old ones I think (HmPowr, HmRobe, MyrnCa & MyrnPa) and they may be renamed to “old HmPowr” etc. to clean it up a little.
  12. DPoiman

    DPoiman First time out of the vault

    Mar 13, 2019
    thx for answers fellas!
    also i notice another bug/problem

    dogmeat with k9 suit lose his all sounds on attack/reciving dmg
    i check everyone proto file is on "red only" i also run "processdat2" and problem still ocure

    Also a question: i cant find a classic sniper rifle anymore, its still ingame? Meybe im Just unlucky, if its not buyable where i can find IT?
    Last edited: Mar 17, 2019
  13. almostdead

    almostdead First time out of the vault

    Nov 6, 2014
    Damn...I encountered another problem.
    All weapons and armors were missing from dead enemies...
    I didn't notice that until the fight in the farm. After the battle, the only thing I could loot from corpses were ammo, even they clearly possessed weapons and armors in battle.
    And there is no sign of loot in other NPC's inventory.
    Then I realize I didn't get anything from enemies of Kaga encounters either.
    I suppose this is not a intended feature. Please tell me how to fix this...
  14. Muttie

    Muttie Still Mildly Glowing

    Oct 9, 2017
    I had time to check my notes and in the RP Mod this seems to be the case when “Rescuing Torr”. In that case the reward by Ardin Buckner is to free Sulik (75 karma) or $100 (called the “and substantially less karma” in Jorner's guide, so it's probably in Fo2, too.)
    And apparently the player can then ask Maida to free Sulik.
    So in the original it was: free Sulik (always, when talking to Maida after rescuing Torr) and either $100 (reward) or 75 karma (when the chosen reward is to free Sulik) from Mrs. Ardin.
    MegaMod moved all this to Ardin & rescuing Smiley, but Maida still triggers.
    This is probably were the bug with the double XP is from as MM/TeamX merged it all together (rescue Smiley/Torr, $100 or free Sulik). But note that in MM the player gets 75 karma for rescuing Smiley (triggers when leaving the caves) and 75 karma when using the reward to free Sulik. When telling Ardin to keep the reward (and Sulik is free) it gives nothing (0 karma and no cash). In the original this situation would have defaulted to $100, I believe.
    If you want to reduce the amount of karma, I would suggest a minimum of 10, although it's time-wise unlikely a Shaman will ever manage this before the 5th of August. However, perhaps something like: rescue Smiley (+10), use it to free Sulik (+5), refuse reward (+2). Or use the original: an option between $100 and a “no reward” that defaults to (free Sulik & +5 karma), and should Sulik be already free the only option is ($100).
    And the XP for freeing Sulik could trigger when talking to Maida about it.
    For reference: Help the wizard with his dog (+10 karma), Steal from Hakunin's chest (-3), become a Warrior (+10), Rescue Smiley (+75), Use the reward to free Sulik (+75), get Torr a job (+2), smear the Buckner's name (-2), talk Emily to work at the bathhouse (-5), buy Sullivan a drink (+10, don't change this!), betray Smiley (-5), tell Ardin Smiley is dead/walk about (roughly -5), scare/hit Torr (-5), finish rustling (-5), kill the Rat God (+50).

    It occurred to me that the original FoXP mod by (?), may had the idea that the dodge animations may be used as hit animations. And I think this may work in some cases (for example the ducking roach may be perceived as it having been hit, while the jerking back may be understood as a dodge), but in some cases that shouldn't work so well, especially using the hit animation of humans for dodging. However, I have not tested this in-game! And some dodges do look like being hit. It just occurred to me while going to sleep that the “false” animations could be interpreted creatively, and it's not automatically necessary to switch anything around. It all depends how it looks in-game. There may be room for freedom. For example, the Environment armour could perhaps use AN for hit (front) (rename AO), AO for hit (back) (rename AP, although this does not look optimal) and AP for dodge (rename AN).

    Extended Flamer animation:
    There are a couple of “extended flamer” animations not include in MM.
    Hapow2kl may be upgraded with HAPOWRKL.(...) (rename)
    And update MALIEUKL.(...) with the one from FO Fixt.
    And Appearance Mod:
    HFR00S03: _hfmaxxKL.(...) may be updated with HFKATJKL.(...) from Fixt (rename)
    @Foxx this one (upgrade HFR00S03:_hfmaxxKL.(...) with HFKATJKL.(...) from Fixt) also applies to your assembly of the Appearance Mod. Also note that HFR00S03: _hfJmpsO... has the wrong attacks (OG) but needs OH, OI & OJ, just as HFR00S03: _hfJmpsS... has them.

    It seems as if the lightsaber attack in MegaMod is set to ...G and not ...J. At least that would explain why the saber animations fail to trigger (OJ & SJ), while the knife one's do (DG).
    Perhaps rename all OJ & SJ to OG & SG?
    Or the other way round, set the saber to use OJ & SJ and adjust the placeholders to DJ (apparently that's what RP & the appearance mod did).
    I tested this with HmMaxxOJ and HmMaxxSJ in MegaMod, changing those to HmMaxxOG and HmMaxxSG and the PC-Dude attacks. However, it looks abrupt, probably as OH/OI & SH/SI don't play out first.
    I also tested it in RP and the saber substitutes of HfJmps & HmJmps that are set to DG, don't work. I adjust it to DJ, but the dude still wouldn't attack. Probably missing (DH & DI). When I added random placeholders for DH & DI the attack would play out.
    So you may need to adjust the weapons (green/obi wan to O) & (red/empress to S), then adjust the game so that the saber animations are used (SH/OH, SI/OI, SJ/OJ) and then adjust the placeholders (knife) from DG to DJ. Or alternatively, set all saber animations from OJ & SJ to OD & SD.
    Not sure how this will work with throwing, i.e. if AS is still used or if it needs DM (renamed SM or OM).

    And Clean-up
    After HmLthrOC.frm has been replaced with HmLthrVC.frm (then the v... can be removed) (they are the same as o...). However, you may keep a copy of HmLthrOC.frm in case you want to switch back.
    After HmMaxxOC.frm has been replaced with HmMaxxVC.frm (then the v... can be removed) (they are the same as o...). However, you may keep a copy of HmMaxxOC.frm in case you want to switch back.
    After HmMetlOC.frm has been replaced with HmMetlVC.frm (then the v... can be removed) (they are the same as o...). However, you may keep a copy of HmMetlOC.frm in case you want to switch back.
    HaNPwr: the w... can be removed (they are the same as q...).
    HmCmbt the v... can be removed (they are the same as o...).
  15. Muttie

    Muttie Still Mildly Glowing

    Oct 9, 2017
    I haven't explored MM that deeply yet, but I do know that the stats for the Sniper Rifle have been changed. So the "classic Sniper Rifle" shouldn't exist as such anymore.

    Enemies drop their weapons on the ground when killed. They never appear on their bodies. Perhaps this is why you didin't find any weapons (only ammo). You can highlight items on the ground by pressing shift. However, other NPCs will try to collect those dropped weapons before you.
  16. almostdead

    almostdead First time out of the vault

    Nov 6, 2014
    No... I double checked. There was nothing on the ground. Nothing in NPC's inventory either (checked with pick pocket).


  17. DPoiman

    DPoiman First time out of the vault

    Mar 13, 2019
    indeed, but its retardly f*cked up! i check and *new* sniper rifle, with fast shoot + faster shoot menage to take 6AP!! so that mean *basic* have 8AP to shot! incredible! 9ap to aim shoot? wtf!?!? that should be changed back to old 7!/6/5/4 cose new 9!/8/7/6 make it almost unusable on low ap champs ... low ap? lol even high ap champs have problems, who play 10agi+10per to be "such" sniper?

    also i want to ask about EPA - on "VIOLET" section i can revive one of three speciment, but she always die, on other EPA guide, there is information about revive one of three speciment on "BLUE" -and one of them can join your team, i have no idea what to do.
    Last edited: Mar 19, 2019
  18. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Holy moly! That's gonna take me a while to get through! Thanks, though. :cool:

    That is something from TeamX's New Vision mod. It's not a bug at the Jennings Farm. The scripts on those critters call for those weapons to be destroyed upon their deaths. Maybe it was their intention to keep you from getting those weapons early on. I don't know. I just never bothered to change it from the original.

    The Kaga encounters, however, should give you weapons (if they have weapons). I don't think all of the tribal enemies with him have weapons though.

    I don't know about this issue with the sniper rifle you're talking about. Never looked into it. Maybe be part of the Weapons Rebalanced mod. Or another weapon mod. Or New Vision. I honestly don't know. But, I'd have to wonder what the tradeoff is for having such high AP use. Maybe it comes with some overpowered damage? Or maybe you are looking at a different gun? Either way, I don't usually mess with weapon balance stuff. I leave that to others.
  19. AffectedSkills

    AffectedSkills First time out of the vault

    Mar 20, 2019
    Fallout : Steam version with 1.02 US patch
    Megamod : version 2.47.1

    When I try to leave the Vault 13 caves I cant interact with my vertibird because I cant walk on the ground tiles.
  20. Muttie

    Muttie Still Mildly Glowing

    Oct 9, 2017
    Take your time. I'm off MM for now. I'll go back to it and finish the rest (everything after Klamath) but I don't know when. So much to do, so little time.

    Anyway, I found another small upgrade option:
    The animations of HFR00S03: _hfmaxxQ..).(...) (8 in total) can be used to update the 8 animations of NfMaxxQ..).(...).

    And regarding the Saber, although I may repeat stuff that is already known:
    Simply adding DM (and naming it OM/SM) doesn't work. Apparently, it needs more than that.
    And switching from a vertical-swing (OJ/SJ, once renamed to OG/SG) to a throw (AS) is possible, but switching back causes a hiccup. And it needs to toggle the hand-slots (like a reset of the saber) before OG/SG can be used again. It works, but it's clunky.
    The placeholders using the knife swing (“DG”, renamed OG/SG) and which are currently the only “dudes” that are working, have the same issue, i.e. to attack normally again it needs to reset the hand-slot after each time the saber has been thrown.
    Perhaps a consequence of combining AS with a weapon set?

    The damage & ammo have been improved. Making this version of the Sniper Rifle a top three Small Gun in the game (damage wise) and much more deadly than the classic version. It's on par with the .223 Pistol. However, it looses out again when a 5 AP weapon can attack twice, compared to a single 8 AP shot, but I'm not sure if there is so much difference between 6 AP & 8 AP other than cancelling some Fast Shot usage with the Sniper Rifle.
    However, I do agree that weapons should be capped at 7 AP (8 AP with aimed shot), otherwise it excludes too many builds from using them.

    The EPA in MM is a different version. I'm not sure if you can get any companions in this one. At least Dex shouldn't exist, as I couldn't find his text file.