Troubleshooting FAQ, for technical help

Discussion in 'Fallout RPG Gameplay & Tech' started by Odin, Feb 24, 2004.

  1. mon5ter

    mon5ter First time out of the vault

    Mar 22, 2011
    Hi there

    I am having the same problem as the above two users.

    when I try to play the game I get a message telling me that Fallout 2 needs 20mb disk space to run.

    I have read the messages above and I have turned off the error reporting in the the services.msc menu which had not effect.

    my fallout.cfg file looks like this:

    critter_dat=C:\Program Files\BlackIsle\Fallout2\critter.dat
    critter_patches=C:\Program Files\BlackIsle\Fallout2\data
    master_dat=C:\Program Files\BlackIsle\Fallout2\master.dat
    master_patches=C:\Program Files\BlackIsle\Fallout2\data

    Can anyone help me?
  2. Per

    Per Vault Consort Staff Member Admin

    Apr 1, 2004
    Did you read the first post in the thread which says to set free_space to 0?
  3. Vinideel

    Vinideel First time out of the vault

    Jul 31, 2011
    I can't hear you.

    Ok so I think I'm having a unique problem because I can't find a solution anywhere on the net or this site. Most recruit able npcs in fallout 1 will not speak to me at all and even some quest related npcs will not talk to me. An example is crazed raider in the hotel in junktown. I walk in and talk to him and nothing happens, no text, no dialogue, he just stands there. But I can talk to the girl right outside the room or any of the guards that are around Ian, but not Ian himself.
  4. Wa5t3L4nDtRiPp3r

    Wa5t3L4nDtRiPp3r First time out of the vault

    Jan 23, 2012
    I'm getting a bug where the game crashes periodically and gives me error message 0000006d 0047b6ac. Then it started happening all the time. Then it happened right as I hit save and I got an error saving game bs message.
    Now I cant load the save.
    I go back to an old save and go from there but can no longer save in the 3rd save slot. That's the crash spot now.
    Then it spread. Now almost all of the save slots are crash spots where you can't save to them or load them. And I cant travel to the other areas in the sewers in the necropolis because the game crashes.
    IDK wtf to do. Somebody help! The game was working perfectly until now.
  5. aboniks

    aboniks Still Mildly Glowing

    Jan 17, 2012
    um...which fallout game was it?
  6. Wa5t3L4nDtRiPp3r

    Wa5t3L4nDtRiPp3r First time out of the vault

    Jan 23, 2012
    its fallout 1.
    the exact error message is

    The instruction at 0047b6ac referenced memory at 0000006d
    The memory could not be read from
    click ok to terminate the application

    I'm running vista and my graphics card is a nvidia gforce 8600M GT
    pretty sure my card was recalled and doesn't work. But the game was working until now so idk
  7. Wa5t3L4nDtRiPp3r

    Wa5t3L4nDtRiPp3r First time out of the vault

    Jan 23, 2012
    halp guise!
    I dont wanna lose my char or game!!!
  8. InsidiousStealth

    InsidiousStealth First time out of the vault

    Jan 31, 2012
    Thanks for this post. I have the GOG version though and there is no fallout.cfg anywhere I can find in the installation directory. I would love to change it to 0 if it was there.

    Also I am on vista [which I hate but it came with my laptop so i'm stuck] so i cannot even chose a "run" option because its not available in the start menu...Any tips available?

    I also tried a "search" and typed in services.msc and there was a "services" program which I ran and that "find error reporting service" was nowhere to be found in the list maybe its different on vista?

    Edit: UPDATE/SOLVED...for now...I ran it from the launcher after installing and it ran...After the 3rd or 4th time of running it did that again...

    My solution for now was I ran it under properties in windows 95 compatibility mode and it worked no problem
  9. Tiger Snarl

    Tiger Snarl First time out of the vault

    Mar 5, 2012
    Playing Fallout 2 on Windows 7 Starter

    Hey all,

    I have just registered to post my solution for getting Fallout 2 to run on Windows 7 Starter, 32-bit.

    I was having the following problems before:

    - "error initializing video mode 640x480"
    - "Fallout 2 appears to be running in compatibility mode"

    and have now managed to overcome them. I will try keep this as simple as possible. My solution is from a collection of threads mainly ones on this site, and here (


    1. Install Fallout 2 (For me this was US Version)

    2 Install Unofficial Fallout 2 Patch (

    3. Download sfall ( and ONLY extract (using 7-zip or Winzip)
    ddraw.dll into your Fallout 2 directory (overwrite if necessary). DO NOT EXTRACT ddraw.ini

    4. Installed High Res Patch v2.2b(

    Now alter the following files (found in Fallout 2 Directory). If your OS doesn't let you save after altering the file, then copy/paste the file onto your desktop, alter it there, then copy/paste back into your F2 Directory, thus overwriting it.

    5. In f2_res.ini locate the code below and change the resolution to your desired values. I went for 1024 x 600 as this is my Desktop resolution.

    6. Then change the colour value (also in F2_res.ini) . I went for 32-bit as this is also my default laptop Colour Settings.

    7. In ddraw.ini change the mode from =0 to =4.

    8. Below (7.) in ddraw.ini, also change resolution to what you did previously:

    9. OK. Now go to your Fallout 2 shortcut, right click/properties.

    - Go to Compatability tab
    - Go to 'Change Settings for all users' button at the bottom.
    - Check box to Run in Windows NT 4.0 (Service Pack 5)
    - Uncheck ALL OTHER BOXES.
    - Apply

    10. Launch Fallout 2!


    I really hope this helps at least one other person on getting Fallout 2 to run on Windows 7 / Starter. It took me a while to sift through various threads, mix and match the solutions, and eventually come through with something that worked.

    So happy though, Fallout is an absolute classic and I well truly shed a tear if there comes a day that none of us can launch and appreciate our old faves!

    [/quote]Happy Gaming
  10. Zantezuken

    Zantezuken First time out of the vault

    Apr 10, 2012
    I honestly simply don't have the time to browse all 78 pages, and search didn't really help me with the question: what big patch makes sense install now? I decided to buy GoG version since I lost my old box with F2 and now I'm a bit confused. The Download Section for Fallout 2 offers few patches that seems to be doing the same things, what is the difference? Also, I remember there was some big restoration project that was supposed to compile/unit all the community fixes into one. Blargh. In short - what kind of community path project makes sense to install on GoG version and where can I get it?
  11. Per

    Per Vault Consort Staff Member Admin

    Apr 1, 2004
    The modding forum has a sticky on patches and threads on the RP at the top of the first page. They shouldn't have been too hard to find.
  12. Zantezuken

    Zantezuken First time out of the vault

    Apr 10, 2012
    Oh, thanks Per, for some reason the description of the modding section of a forum gave me the feeling it is about the modding itself, while mods and their issues being discussed here, so I didn't search there.
  13. UndeadNecro

    UndeadNecro First time out of the vault

    May 15, 2012
    I'm having trouble with Fallout 2, it seems my computer/game freezes when I try to save. Tried installing the Unofficial patch, didn't work. Not sure what else to do now.
  14. Prometuis

    Prometuis First time out of the vault

    Aug 14, 2012
    Game freezes periodically

    Using windows 7

    While playing Killaps Restoration-Project 2.1.2b the Mouse cursor goes nuts and starts moving the in a certain direction leaving the character unable to move. More or less freezing the game
  15. elus89

    elus89 First time out of the vault

    Feb 5, 2013
    Known Bugs

    Where is there an exhaustive list of known bugs? One that we can contribute to, if possible.
  16. Per

    Per Vault Consort Staff Member Admin

    Apr 1, 2004
    Which bugs are the most common change over time with new releases and new platforms. The troubleshooting post is a bit more out of date than it could be, but it's not easy to decide exactly what should be in there, as the pace has been comparatively slow on the Fo1-2 tech forum in recent years. For a while people were having lots of Vista problems, now they're all but history.

    I don't think anyone has ever thought of making a comprehensive list of reported issues and prospective solutions, as it would be kind of a nebulous project, but if you want to lay the groundwork, you're welcome. It could perhaps be mirrored here and on some appropriate Fallout wiki.
  17. Odious

    Odious First time out of the vault

    Apr 20, 2013
    I encounter the "unable to load" problem quite a bit. from what I've learned, overwriting saved games a lot and in quick succession seems to cause this problem.

    What I mean is, when you keep dying in the same place but keep saving and loading at the same place the save files seems to become corrupt.

    I don't encounter this problem when I create separate saves.
  18. hedron

    hedron First time out of the vault

    Jul 1, 2013
    I have tried this solution and it does not work. I have discovered that this error can also occur for other reasons than misplaced paths. It seems that the files critter.dat and master.dat can become corrupted and simply pointing to the corrupted file in fallout2.cfg will not help. The only solution that I have found is to uninstall fallout. It will be obvious that you have a corrupt install when it takes unusually short period to install/uninstall, as if it is not copying or deleting any files. Anyway, the solution I have found is download a program call "Crap Cleaner" and use the drive wiper tool to "wipe" all the free space on the drive you installed Fallout on.

    If someone has a more elegant solution please post. Thanks.
  19. PDV

    PDV First time out of the vault

    Aug 13, 2013
    Guys, is there some mod or way to change ingame text color from green? This color is very tiring for my eyes.
  20. foidis

    foidis First time out of the vault

    Dec 19, 2013
    FO1 doesn't work.

    Well, I have sucessfully installed Fallout 1, but when I tried running the game, it told "failure initializaing video mode 640x480" or something like that. I renamed the ddraw.dll file to f1ddraw.dll as suggested by some guy, and also followed these steps: Now I can run the game, but now I'm getting another problem.

    I can't get past the intro. Before launching, the game says I can't run it because I don't have d3dx9_31.dll on my computer, then it runs anyway. Then the intro starts. And when I try to skip the intro, or when it ends, the game just freezes.

    Funny thing is, I tried putting the d3dx9_31.dll file in the folder to see if it works and then the "failure initializing video mode 636x454" error appeared. Yeah, I mean 636x454, not 640x480. WTF?

    So either way I get an error. If it doesn't fail initializing video mode it freezes after the intro.

    I had the exact same problem with Fallout 2 before (the freeze after intro problem, not the video mode problem), but the Restoration Project fixed it and now I can play FO2 with no problems. I tried installing different patches for FO1 and none of them made it work, not even Fixt didn't seem to do anything.

    Messing with compatibility on Falloutw.exe also doesn't work.

    This game is driving me insane, I really don't know what to do anymore. It ALWAYS freezes after the intro ends.

    Also I'm sorry if this problem was addressed before, but I really could'nt find it. If anyone could send me a thread in which this problem was solved I'd appreciate it.

    Oh and also, for some weird reason, I don't have the ddraw.ini file in my FO1 folder, so I can't do that change to Mode=0 some people suggest.

    btw, this is the version (acquired before they removed it) and win7 64bit.
    Last edited: Jun 8, 2014