Fallout 2 mod Unofficial Fo2 patch thread - problems, reports, suggestions

Discussion in 'Fallout General Modding' started by Per, Aug 15, 2007.

  1. Gorgragar

    Gorgragar First time out of the vault

    11
    Feb 8, 2019
    FALLOUT 2 crash help

    I have run into a map problem specifically Vault city When I go to enter it game crashes.. error is :
    The instructions at 1000431c referenced memory at 00000000 The memory could not be read from
    From what I gather it is a map error/savegame corruption?
    Had it happen a couple times before in Modoc but reinstall RP and got through it. not working this time.
    I have it on steam and saw if I had cloud enabled with the RP patch it could corrupt the Save game?
    SO i plan to reinstall to a differant folder... turn off the cloud saves and turn off keep up to date. Anyone know if I am on the right track?
    also anyway to save my save game data? I just fount the Federation crashed ship special event and that phaser looks nice.
    Thank you in advanced for any helpful comments

    Well I deleted everything fallout 2 wise reinstalled with GoG... changed folders, no auto update.. no cloud saves... reinstalled Resto patch.. everything seemed fine.. from den went to vault city and.. crassh again. anyone have any Idea.. Is there a bug in the resto patch?

    Tried saved game editor to delete maps.. tried a map fix utility I found. game crashes give me error and if I go to task manager I can see fallout 2 still running. and "not responding"
    doubt anyone looks at this part of the board anymore so not getting my hopes up.. scrapping the resto patch and just useing the update without the new content pitty too the resto so far was excellent.. I couldnt be the only person for it to mess up the game to.
     
    Last edited: Feb 9, 2019
  2. burn

    burn A Smooth-Skin
    Modder

    645
    Apr 22, 2012
    you have some antivirus, maybe try adding f2 to exceptions?
     
  3. Gorgragar

    Gorgragar First time out of the vault

    11
    Feb 8, 2019
    Thank you for the suggestion. I tried putting exception in windows defender (only antivirus I have) and it still crashed out when trying to enter Vault city.
    even just the regular unofficial patch it crashes when entering the southern part of NCR where the mayor is every time... looks like I cant replay Fallout 2 again. :(
    Ive tried everything I can think of and everything Ive seen posted about it.
     
  4. naossano

    naossano So Old I'm Losing Radiation Signs

    Oct 19, 2006
    You should not cumulate the rp and the patch.
     
  5. Gorgragar

    Gorgragar First time out of the vault

    11
    Feb 8, 2019
    yeah I only Installed the RP. But once the RP kept failing I tried just the unofficial patch only. That was the other crashing.
    Window 10 system. I'm at my wits end I am pretty good with computers and everything so far it keeps crashing...
     
  6. BreakinBenny

    BreakinBenny First time out of the vault

    75
    Jun 18, 2015
    Am I late? Also, I'm bumping because three weeks earlier and another from just five hours before I received e-mails from a Korean player mentioning crashing bugs. I'll provide Pastebins and mention @Sduibek as well as whoever is helping out with the FO2 Unofficial Patch (and Restoration Project. Fallout FIXT included).

    Pictures for the latter e-mail are provided, too.



    I guess it's nice that we have even Asian people who are interested!… I hope someone on here understands Korean, since machine-translations are far from error-free.
     

    Attached Files:

    Last edited: Mar 23, 2019
  7. burn

    burn A Smooth-Skin
    Modder

    645
    Apr 22, 2012
    I'll leave it here for reference: UP update.
     
  8. codehobbyist

    codehobbyist First time out of the vault

    1
    Nov 22, 2019
    Hello. I have a question regarding the unofficial patch if anyone can grant me some guidance. I have searched all over and can't seem to find an answer.

    I have installed Win95 and Fallout 2 through Magic Dosbox on Android. After much trial and error, I was able to get the unofficial patch installed manually. The only way I could get it to install without directx errors and actually run was to manual install and leave out the Windows 95 file contents. Replacing the main exe produces a directx loading error. I have installed directx 3, 5, and 8 but it looks like the files are for 9 which isn't compatible with Win95?

    I can see the rock behind Klint telling me that the patch is installed and I know that the readme says you must see both the rock and version number at the title screen.

    My issue is that the version number still shows Fallout II 1.00 on the title screen. I assume I am not getting full benefits of the patch?

    Questions: Does anyone know how to bypass the directx not loading error? How will it negatively affect the patch by not including the contents of the Windows 95 folder? How else can I tell aside from the rock and version number (I prefer not to look at the spoiler heavy changelog)? Which file changes the version number on the title screen, the main exe?


    Edit: It appears this is probably a dead forum. I would be interested if anyone can has a solution. I will also inquire at Magic Dosbox forum.

    Edit 2: My solution was to set up Steam Link and create touch screen controls....and completely forget about windows 9x. This is just in case someone runs across my post eventually.
     
    Last edited: Nov 28, 2019
  9. Gorgragar

    Gorgragar First time out of the vault

    11
    Feb 8, 2019
    prob dead... took a 4 year break not playing.. tried it again with the rpu still crashes when entering Vault city clean install everything.. used GOG. just venting dont expect a fix at this point..
     
  10. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    You need to provide more details and a savegame, else nobody will be able to help you. I've replayed the game barely 6 months ago and had no crashes.
     
  11. Gorgragar

    Gorgragar First time out of the vault

    11
    Feb 8, 2019
    wow a replay thank you. honestly trying to get a savegame uploaded but cant seem to figure that out any help would be amazing. did a zip file fore the save .. that work?
    When entering Vault city I just did a quick run right there goes black screen crashes and gives me
    Application Error D:\Fallout2\fallout2HR.exe
    "The instructions at 1000431c referenced memory at 00000000 The memory could not be read from" high resolution pack is turned off.. tried it with it on too... if HR means that.
    Click on OK to Terminate the application
    same error it gave me 4 years ago when trying to play

    CHanged the violence to none and a different resolution and it gave me

    Application Error D:\Fallout2\fallout2HR.exe
    "The instructions at 004c5d09 referenced memory at 013e0300 The memory could not be read from"
    Click on OK to Terminate the application

    tried running in admin too
     

    Attached Files:

    Last edited: Jan 23, 2023
  12. Gorgragar

    Gorgragar First time out of the vault

    11
    Feb 8, 2019
    did some testing type stuff

    so on main menu of the game (new game/load game etc) you can hit control +R to pull up a map test thing? well for the main valt city down town it loaded. but for the vctyctyd.map which I am assuming is the court yard/ entrance of vault city it crashed. I am thinking the maps are corrupt someplace.. its a clean install too .. I could go to vault city before I installed the RPU on a completely vanilla FO2 game. so anyone know where the maps are pulled from? and have that file so I can replace mine? or make a video going through you fallout2 foulder and showing what files and where they are in the folders and sub folders to do with maps? cause I dont think a save game is gonna help anyone...
    any help with this would be very much appreciated thank you