Fallout 2 Restoration Project 1.1 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jan 13, 2008.

Thread Status:
Not open for further replies.
  1. tomten

    tomten It Wandered In From the Wastes

    164
    Jan 6, 2008
    Re: Just an idea...

    You'll get more answers in the "engine tweaks" thread. This thread is for discussing technical aspects of the 1.1 version of the Restoration Project. http://www.nma-fallout.com/forum/viewtopic.php?t=38116
     
  2. Shayesda

    Shayesda First time out of the vault

    7
    Jul 9, 2003
    Mhhh... dont know it is was mentioned earlier, and its not a big problem, 'cause all quests work fine there. But in Gecko everyone is thanking me for repairing the reactor... but I'm there the first time ^^
     
  3. samgamgi

    samgamgi First time out of the vault

    10
    Feb 7, 2008
    I think that only I am having this bug, but it seems that in the World Map, !!!EVERY!!! 12:30 hours of walking, I'm getting an empty encounter, and I can just go away from it, ok, sometimes this happens, but it is the ONLY encounter I'm having so far, after installing the updated version that killap uploaded a couple of days ago, the counter of the minutes in the world map doesn't even move, so, if I get the encounter at 00:00, the next will be at 12:30, the next, 1:00 and so on.

    I even tried walking with 300% outdoorsman, 10 luck and the perks that makes it easier to walk around en have different encounters but it didn't changed a thing!

    How can I solve this problem?
     
  4. laclongquan

    laclongquan Boned Hunter of Sister

    257
    Jan 11, 2008
    RainDaemon, you ask about holster problem when dealing with certain entities.

    In game there are specific areas and persons that require you holster weapons (active hand show no weapons). Off all those, only Broken hills assisant seriff(the guys greeting you when entering BH) and the Inner areas of NCR require ALL of your party to holster weapons. Merchants, and whatnot, only require you, the PC, to holster weapons, not your party.

    So? Your idea of holster is not without merit, but it's too much work for too few instances using it... I think.
     
  5. wolfsrain

    wolfsrain First time out of the vault

    97
    Jun 4, 2006
    Killap, did you updated again? I see a 6 february release(after the one from 4 february).
     
  6. convert

    convert First time out of the vault

    23
    Jan 8, 2008
    Hi Killap. I am having problems with the car. I have just returned to get it, got smitting to install both parts. I can drive it fine but if i try to get into the boot the chosen one plays the action of someone picking something off the ground then the boot completely dissapears.
    Furthermore after that the game crashes if i try to drive the car again. I have a saved game if you want to check it.
     
  7. tomten

    tomten It Wandered In From the Wastes

    164
    Jan 6, 2008
    This has been reported and discussed many times. If you want to help, please look through the pages and search for "trunk", and see what others have written.

    Don't submit a savegame unless you write exactly which OS/FO2 you are using and exactly how you installed it and exactly when you downloaded the fixes (these things make a huge difference).
     
  8. convert

    convert First time out of the vault

    23
    Jan 8, 2008
    I see that it has been discussed many times but I dont seem to be able to see a fix for it anywhere. So has any progress been made or is the jury still out on this one?

    I am running Fallout 2 1.02.23 EXP 1.1
    WinXP
    Used the 1.1 installer with all mods
    Plus downloaded the kaga, flint, encounter/knockback and primitive tribe fixes.
     
  9. samgamgi

    samgamgi First time out of the vault

    10
    Feb 7, 2008
    Simple question:
    Has killap fixed the ammo bug in Fallout 2? I mean the bug that the AP ammo and such doesn't make any difference than using the normal ammo.
     
  10. tomten

    tomten It Wandered In From the Wastes

    164
    Jan 6, 2008
    Don't know. Someone asked if you had the bag in your inventory when you picked up the trunk. Well, punk. Did you?
     
  11. Desdichado

    Desdichado First time out of the vault

    2
    Feb 6, 2008
    Killap, should we start a new thread for discussion on the EPA crash problem so we don't clog this thread with a known issue?

    is there anyway to remove maps that are having trouble saving? maybe take important items from those maps and scatter them other places in the EPA?
     
  12. tomten

    tomten It Wandered In From the Wastes

    164
    Jan 6, 2008
    Killap has said he will either fix the EPA problems in Restoration 1.2 or create workarounds for the parts that crash. I think the Restoration 1.2 thread will be best place to discuss this.
     
  13. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Don't worry about that; it's something for GameStar. Plus, are you check that fold daily or something? :shock: :wink:

    In other news, I am in better health now, but behind slightly in many real life things. So, I'm back on my feet, and progress on 1.2 should continue.
     
  14. RainDaemon

    RainDaemon First time out of the vault

    3
    Jan 26, 2008
    Holster feature

    Thanks for the heads-up, laclongquan.
    i Just remembered that in fallout 2 the caravan guards got bent out of shape if any of your party members had their guns out. i Guess this was maybe corrected in one of the updates since i just tested it now and they didn't seem to mind.

    The town greeter in Broken Hills as well as the prison guards do mind your party having weapons drawn. Either way, i still think if it's not a major effort to implement, it'd be nice to not have to tell 4 guys the same thing every single time.

    This whole fuss of mine makes me think of an interesting style of play - play a melee/unarmed character with all the dogs in the game: dogmeat, pariah and the cyberdogs... could be fun.

    One more thing in this rant - anybody here ever play a game called 'alphaman'?
     
  15. Buxbaum666

    Buxbaum666 Heterostructured Nanorod oTO Orderite

    Dec 5, 2003
    My game just crashed when I tried to kick in the door in Vic's shed. (After triggering the trap by trying to open it normally.) Sorry if this has been posted already.
    Fresh install, latest version+all fixes. I was running F2 on Kubuntu using wine, though. Maybe it's that.
     
  16. Glovz

    Glovz Vault Dweller
    Modder

    735
    Sep 16, 2005
    The AP ammo bug was fixed by Timeslip a while ago, and would definitely be included in killap's latest downloadable version of this project/patch/mod. If you are referring to the crash that occurred with FO1 ammo sounds, I believe this change was reverted by killap also, and again the latest downloadable version will fix that.

    Edit:
    Or did you mean you weren't aware of the damage mod to begin with?

    Side note:
    There are two options for the damage mod now in the ddraw.ini - one option tweaks the original damage formula but does nothing to change the affect of ammo, the second option both tweaks the formula and changes the affect of AP and JHP ammo.
     
  17. convert

    convert First time out of the vault

    23
    Jan 8, 2008
    No punk, i didnt have no bag in my inventory.. punk!
     
  18. poramiese

    poramiese First time out of the vault

    3
    Feb 9, 2008
    Well i have odd problem. The unofficial patch or the restoration package wont work with my fallout.

    I have UK version and installed the official 1.02 patch before installing neither of those. But the game wont start. It only goes black and returns to windows few sec later.

    The most weird thing is that last week i had the unofficial patch version playing fine. But then i noticed the restoration mod and wanted to test that out. Well I cant get it work. Should i play a little and then install the mod ?

    I did as readme.txt says me to do but still I fail.
    All kind of help is needed. Thanks
     
  19. convert

    convert First time out of the vault

    23
    Jan 8, 2008
    Dont install the official patch, just install the mod over a fresh install of the game
     
  20. runicNomad

    runicNomad First time out of the vault

    12
    Feb 4, 2008
    Can not reapair well (Primitive Tribe)

    Try as I might I can not repair the well in the primitive tribe area. I used the rope on the well but when I attempt to use the bucket my character just runs up to the well and does nothing. I tried putting the bucket on Vic and have him repair it and I also tried putting the bucket in my inventory and using it that way. Niether of these tries worked.

    What is the problem exactly?

    thanks,
    runic
     
Thread Status:
Not open for further replies.