Fallout 2 Restoration Project 1.2 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jun 9, 2008.

Thread Status:
Not open for further replies.
  1. Sumguy21

    Sumguy21 First time out of the vault

    14
    Aug 23, 2008
    I'm so anxious to see this released. :oops:
     
  2. kungfujoe

    kungfujoe First time out of the vault

    83
    Sep 28, 2008
    You and me both. I've halted my current 1.2 game in anticipation of starting over in 1.3. Every so often I get that "I wanna play Fallout 2" itch, and I keep having to tell myself that my progress will be for naught if I don't remain patient. :)
     
  3. Limbabnees

    Limbabnees Still Mildly Glowing

    243
    Jun 17, 2007
    To avoid this you can use the Scripts & MSG from the Miria Mod.
    Only the files the "Interaction" Folder
    Just copy mcMiria.int & mcMiria.ssl in the Scripts folder.
    mcMiria.msg in the English/Data folder.

    In the Party.txt you need copy the level_pid from an other party member, because the original pids are used by Kaga.

    Vic's levelup Pids

    [Party Member 13] ; pMVic_PID
    party_member_pid=16777278
    area_attack_mode=always, sometimes, be_careful
    attack_who=whomever_attacking_me, weakest, whomever, closest
    best_weapon=no_pref, ranged_over_melee, ranged, unarmed
    chem_use=stims_when_hurt_little, stims_when_hurt_lots
    distance=stay_close, snipe, on_your_own, stay
    run_away_mode=none, coward, finger_hurts, bleeding, not_feeling_good
    disposition=none, custom, defensive, aggressive
    level_minimum=5
    level_up_every=4
    level_pids=16777589,16777590,16777591,16777592,16777593,16777594
    I Preferre only the last 2 Pids: level_pids=16777593,16777594

    Change [Party Member 13] ; pMVic_PID into [Party Member 10] ; pMMaria_PID
     
  4. Gekko

    Gekko It Wandered In From the Wastes

    102
    May 3, 2004
    I have encountered some glitches:

    1. Somewhere in New Reno my character started to appear under every object / character in the game. I also can walk anywhere without hostile creatures attacking me unless I attack them. Im afraid I bared this glitch too long to load again.. It's weird stuff. Does anyone know this?

    2. At redding west, where there are lot of critters and the abandoned mine, the game constantly crashes when some critters hit explosives (?).
     
  5. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Check this out.

    If that's what happened to you, use a hex editor, load the save.dat from your broken save slot. Search for "FP", 36 squares after that you'll find the hex string value "38", change that to "20", save and everything should be back to normal.
     
  6. Uaine

    Uaine First time out of the vault

    36
    Dec 2, 2004
    That may be...but you might consider saving your game in one place, and continuing on with a different save. After all, the more people who play 1.2, the more bugs can be found and fixed for 1.3 :)

    I just found out about the project, so I'll start playing soon. I've got the new Fallout 3 on preorder, but I won't have hardware to handle it for another couple months, so it will have to wait.
     
  7. Gekko

    Gekko It Wandered In From the Wastes

    102
    May 3, 2004
    Hi, I tried to search for FP but it finds F and P separately (next to each other) from text string, but the editor doesn't allow me to even type FP in the hex string search. When I search FP from the text search it jumps to location where I see 38 nearby in hex window but changing that makes the game glitchy.

    Am I doing something wrong? I doubted this because I ofcourse have different character etc etc.. But then again, I have absolutely zero skills with hex editor (only done few things sometimes).
     
  8. Darek

    Darek is currently unavailable

    Jan 7, 2008
    When it's the last post in a thread you can just delete it, but not anymore. :)

    I think you got it right, search "FP" text string, the "P" has a 50 in hex value. 36 squares after that you should find the hex value 38, which should be changed to 20.

    In what way did the game become glitchy? what happened?

    If you want me to, I can take a look at your save. I'll PM you my e-mail just in case.
     
  9. Gekko

    Gekko It Wandered In From the Wastes

    102
    May 3, 2004
    Oh darn me, I think I edited the wrong 36, there was another nearer and I edited it and I didn't see the one further ahead. I should have just listened. :D

    Anyway, I'll try it out and post the result tomorrow morning. I have to go sleeping, torr very sleepy!
     
  10. Kanhef

    Kanhef Vault Dweller

    793
    Sep 2, 2007
    You want something that looks like this:
    Code:
    00004650 00004CF4 00000000 00000000 
    00000177 000000FD 00000000 00000001
    01000003 60002420
    Corresponding ASCII is
    Code:
    ..FP ..LÙ .... ....
    .... ...w ...˝ ....
    .... .... `.$.
    (with '.'s for non-printable characters)
    Stuff in the middle may vary, but the first and last four bytes should match. In your case, the last byte is 38, and should be changed back to 20. Setting it to 30 gives you the permanent stealth mode without any graphical glitches.
     
  11. Gekko

    Gekko It Wandered In From the Wastes

    102
    May 3, 2004
    Hey Darek, the register thingie worked! Thanks a bunch!
     
  12. earthdude

    earthdude First time out of the vault

    69
    May 11, 2008
    Annoying bug that must be due to some strange incompatibility: I cannot access the vertibird in Navarro. I get the dialog when guards are around, but after I kill them and click on the vertibird (I have the hand icon), nothing happens at all ever. I then did a completely fresh install (uninstalled Fallout2 and then deleted the directory, installed Fallout2 from the original disc v1.0 and then installed the restoration project over that with the auto installer). The menu screen says I have version 1.02.24 R1.2. The rock says I'm playing version 1.2.2. I then started a new character. Same result. And per the walkthrough, I have both the yellow reactor key card and I waited for Hakunin's 4th dream and last conversation. Thoughts? and thanks.
     
  13. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I was the one who wrote that for the walkthrough, but I just tested it again and ended up with the same result as you. I remember testing the "sneaky" way and also fighting after trying to access the control terminal, and they both work. Maybe I got lazy and just wrote how it should work when you fight after touching the verti, without testing it first, sorry.

    Edit: Try to exit to the world map and then go back, see if that makes a difference.

    @ killap,
    So the bug seems to be that if you don't pass the speech check for accessing the verti, and then fight, nothing happens when you click it afterwards.
    It's like something doesn't get reset or changed, and the game is thinking a guard is supposed to object, even if they are all dead.

    I'm gonna test if it works if you kill all the enclave before ever touching the verti.

    Edit: This is strange, first it didn't work. I had killed nearly everything, I got the deathclaw to join me, killed everthing, but it still didn't work, left the map to the world map and came back. Now it worked. I loaded an earlier save with some enemies and turrets left and it still worked. Weird.
     
  14. malichai11

    malichai11 First time out of the vault

    23
    Jun 7, 2007
    Which walkthrough, and where can I find it, deals with Killap's restoration pack?
     
  15. Darek

    Darek is currently unavailable

    Jan 7, 2008
  16. Blackened

    Blackened I should set a cutom tite

    598
    Jun 29, 2008
    Any ETA? Does the "will be released before Fallout 3" is still valid? I really want to see the 1.3. By the way, here is a bug I posted some time ago and then saw it on fallout modding wiki, under "RP bugs"(or something); it was "unconfirmed, unfixed".

    It is pretty simple:
    Go to the Den, accept the new quest for Lara and do the things needed by the quest until the first attack(over the church). After you kill them talk with Lara - she will ask you to go to the party and kill the remaining gang members and you have two dialog options: go with Lara's gang to kill them or ask her to wait you to prepare yourself. If you choose the second one and then use the exit grid(I used the one that leads to the map with the car)it behaves like you completed the quest after you return to the church.

    Here is what I suggest:
    Everything seems fine to me, until the point in which Lara asks you to kill the other gang members. After this, the first dialog option(to go with her in order to continue your quest)is fine; The second maybe should remain the same, but if you leave the area and come back one of the gangs should had won(I am not sure who is the stronger) - the remaining should be in the church and they should turn hostile after you approach them. Also, if too much time passes(maybe 2 or 3 hours) the game should treat you like you ran away. It will be good to add other dialog options - like running away, it seems pointless, but Fallout is in that style. Adding additional options is always good...
     
  17. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yes, 1.3 WILL be released BEFORE Fallout 3 (ie before October 28th). The current plan is Saturday, October 25th.
     
  18. Blackened

    Blackened I should set a cutom tite

    598
    Jun 29, 2008
    Oh, my bad.....
    I thought that Fallout 3 will be released 18th(not 28th)october.
     
  19. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I played around a bit more with the veribird in Navarro, and it's working for me after a fight, if I exit to the worldmap and then go back in or if I quit and load that save (my game crashed so I didn't get a chance to test if just a reload or a quit to start screen would have been enough).
    It looks to me that it behaves exactly the same way as the stubborn door in the slaver camp, ie a variable gets set but the map wont update until you leave.
    They both share the same script function (or whatever it's called), don't they?
    Guards, don't touch, fight, no guards, nothing happens when you touch.

    So why does this happen?
    Is there no way to script it differently?
     
  20. earthdude

    earthdude First time out of the vault

    69
    May 11, 2008
    Re: vertibird issue. I tried exiting to the world map and also clearing out the entire base.... not a living soul except the deathclaw. Still no go on accessing the vertibird....
    Btw, I have a super high speech skill and all 10s stats and didn't get another way to gain access to the vertibird via that initial dialog.
     
Thread Status:
Not open for further replies.