Fallout 2 Restoration Project 1.2 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jun 9, 2008.

Thread Status:
Not open for further replies.
  1. notAvailable

    notAvailable First time out of the vault

    3
    Nov 29, 2008
    I've left the Arroyo for the first time, got the Kaga, ran away, crashed on the next encounter. After that all the times I load savegame where I haven't left the Arroyo yet, leave Arroyo and crash on the first encounter.

    And no, I only installed RP and Hi-Res patch (I didn't mention it since the error is still there if I turn it off).
     
  2. Morticia

    Morticia Look, Ma! Two Heads!

    372
    Mar 9, 2008
    Ran away? = Kaga attacks, but you ran? Made it to the exit grid?

    Just checking and not insulting you. Killap needs to know so he can fix this.

    Not supposed to be able to knock him out, rob him, or run away. Or so I believe...
     
  3. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ notAvailable,
    So except for the first time, it's the encounter with Kaga that crashes your game, am I right?
    If that's the case you can go to your ...\Fallout2\data\Scripts folder and temporarily move the file glkagaen.int. See if everything works like it should after that (you won't get any of the Kaga encounters but it's not really that important).

    Before you do that though, go to ...\Fallout2\data\Proto and check that the folders in there all contain lots of *.pro files.
     
  4. Kwiatmen666

    Kwiatmen666 It Wandered In From the Wastes

    160
    Aug 28, 2006
    1)After repairing reactor one can talk to Brain in Gecko about withdrawing rats from the village near to VC even if didn't have that quest.

    2) In the encounter with the Verti-assault team after hacking into Enclave net from Gecko there are some annoying bugs:

    - all the soldiers have 2 same guns
    - the team leader has 2 yellow reactor cards
    - you can walk through the vertibird as if it wasn't there

    3) Besides the ammo mod works simply crappy: weapons such as Light Support Weapon or H&K P90c (regardless of type of ammo used) do not harm people with power armors at all;/
     
  5. notAvailable

    notAvailable First time out of the vault

    3
    Nov 29, 2008
    Yep, ran away from combat.

    BTW, I've just grabbed Fallout 2 US (1.02), installed RP 1.2 (yup, patch000.dat disappeared), and reproduced the same bug from the very beginning. Created same character (http://www.mediafire.com/download.php?yomhikcidwz), quickly got through the temple (lockpicking the door/exploding the door/stealing the key), left Arroyo -> same crash in a couple of squares. I don't know if Kaga should be the first encounter, but it worked for me only once in 2 different F2 versions and about 10 tries.


    Update: moving glkagaen.int helped, now I get normal encounters, so Kaga is at faut here. Here's the savefile before exiting Arroyo (US version, if that matters): http://www.mediafire.com/download.php?humdimwmujz
    Oh, and /proto has many files, why?
     
  6. Cosmic Sea

    Cosmic Sea First time out of the vault

    16
    Nov 29, 2008
    First all, hello everyone! 8-)

    Secondly, many thanks to all how were involved in the creation of this mod. This is truly the best thing ever to happen to Fallout 2 since it's release. Simply superb work! :ok:
    When playing the regular version, I somehow felt there was some things missing from the release version (for example, the possibility to save, let alone find Sulik's sister).

    I grabbed the 1.2 version and it has been running very smoothly (save for a couple of random crashes, but hey, it's Fallout 2).
    Anyway, I've come across a few bugs during my travels (level 16 now) in the wasteland that might be worth pointing out so they could ironed out in upcoming patches/releases of this mod.

    - The first one I remember being already mentioned in either this thread or the first one, and that's the Bozar how having a single-shot firing sound (M60 now has the proper burst sound, a situation reversed from the original version)

    - On level 11, I had my science (tagged) skill at 120%, and when I leveled up, it almost doubled to 220%.
    I kept a save state from right after reaching the new level. What do you think, should I be sending that to Killap for research?

    - Wiping out the slaver camp quest (the second NCR Rangers quest) has a bug.
    I had already freed Sulik's sister from the slaver camp and later returned to kill the slavers and free the remaining slaves. The slaves in the same hut as Sulik's sister were now gone, but I suppose this is isn't a bug, as I remember Sulik's sis mentioning the slaves where about to be transferred somewhere else soon?.
    Now when I got the quest to wipe out the slaver camp from the NCR Rangers, I don't have the option of pointing that it's already done as I'm given the mission. Even when I visit the slaver camp (either alone or having asked for support from the rangers), the quest won't finish. The ranger boss doesn't talk to me, he just keeps showing a floating text about how the slaver camp needs to be cleared ASAP.
    I'm certain that no slaver managed to run off the map when I killed them. I checked with a motion scanner, no slavers around anymore. I also tried visiting the now-empty slaver camp and killing Metzger and his gang in Den and freeing the slaves there. No luck, the Ranger quest won't finish.

    I hope these are of help when developing the mod further.


    Edit: fixed a typo. (it's version 1.2, not 1.02...)
     
  7. Kwiatmen666

    Kwiatmen666 It Wandered In From the Wastes

    160
    Aug 28, 2006
    1) In the village nearby VC Ann - Connor's wife gives me quest to bring her food, but from what she says it seems that she shouldn't give the quest before solving the mole rat problem (I had talked to Ian and Mclure so far).

    2) After optimizing the reactor I talked to Brain about the mole rats in Village location. I have a message "You came to an agreement about the monsters with The Brain" and I hear the sound of getting XP - and I get 500 indeed - but there's no message about it.

    There's more to it, you can talk to him about that many times and gain infinite experience. Moreover the quest to resolve the matter with the VC Village won't cross out, the rats won't disappear from the village and Connor will keep asking you about the results. That's pretty much about it. It seems that the quest requires thorough revision.
     
  8. Makenshi

    Makenshi Ahoy, ye salty dogs!

    Jul 28, 2006
    Question about 1.3: is there some kind of pre-change log? I mean, is there a list of things that will surely be included/modified, and/or thing planned to make it in? Something like a pre-read me...

    I'd love to see a list of what is coming next :)

    Someone please, pretty please, answer me T_T
     
  9. Kwiatmen666

    Kwiatmen666 It Wandered In From the Wastes

    160
    Aug 28, 2006
    1) You can't use the Bulletin Board in the abbey location. It has a description though so I don't know if this is intentional or not.

    2) While saving Serin in the Primitive Tribe cave area you choose the option to hurry and help him, your team members attack and kill him as well as the golden gecko.
     
  10. Munin

    Munin First time out of the vault

    67
    May 27, 2008
    I m now replaying the FO2 game with your patch, only thing I would do different now is play very very evil. But now I m wondering if I should even do this, I did play one of the earlier versions of restoration project of Killap but I wouldn't wan't to miss out on the new stuff in this version.

    Will becoming a very evil player slave/pornstart/childkiller... ruin the game for me (in terms of missing out on new content)? Since it s my first playthrough with the newest patch. The latest one I ve tried was 1.1 I think
     
  11. Cosmic Sea

    Cosmic Sea First time out of the vault

    16
    Nov 29, 2008
    Today I noticed my speech skill has also mysteriously increased. I had it around 150% and now it has jumped to 170%... :question:
    Any ideas what might be causing this?

    When I was starting out, I unistalled & reinstalled the mod a couple of times, as I wanted to change some of the additional content installed (enable NPCs changing appearance with armor and disable the 14mm & .223 pistol sounds from Fallout 1). I used the installer version.
    As these are parts of the extra content, I doubt they would cause (any) issues?

    Here's a couple of other things I forgot to mention in my first post:
    - Combat control settings like to reset on some NPCs
    This bug was already present in vanilla Fallout 2. Annoying especially with Cassiby, as when his burst fire and distance settings reset, he tends to accidentally hurt other party members and charge forward on his own, ending up either dead or in friendlies' firing lines.
    Could this problem be looked into?

    - You can't trade items with NPCs while overloaded.
    When trying to transfer items to another character while carrying too much weight, I get the "you can't carry that much" message.
    Could this be tweaked so that you can't receive anymore items while overloaded, but you could transfer away stuff?


    Also, would it be possible to get the mouse wheel scrolling to work with other inventories than your own as well?
    The car trunk for example gets filled up pretty quickly and is a burden to scroll through the old way.
     
  12. relyt

    relyt First time out of the vault

    4
    Nov 30, 2008
    Do i need to install killap's Unofficial Fo2 patch if i play Restoration project 1.2? If yes, which goes first?
     
  13. Fury

    Fury First time out of the vault

    50
    Nov 2, 2008
    - Pipboy speach thingy
    - difficulty set to easy
    - increased primary stats by drugs/perk/surgery/mirrored shades...
     
  14. kungfujoe

    kungfujoe First time out of the vault

    83
    Sep 28, 2008
    No. The patch contents are included in the Restoration Project.
     
  15. McWulf

    McWulf First time out of the vault

    2
    Jan 16, 2006
    I recently installed RP 1.2 on my copy of FO2 (us versin 1.0). Great fun, everything seems to be fine, except for a few already mentioned glitches like Kaga encounters.

    I don`t know if it`s a known issue (I searched a bit but couldn’t find anything regarding it), but my problem is with the bonus move perk. I remember it was bugged before, so you still got the movement points after loading a save during combat even though you already used them. Now it´s just the opposite, after reload the points are still there but the game doesn´t count them even if I didn´t use any, and the turn ends immediately after I used up all regular APs. It happens after each reload, the perk works as it should only at the beginning of the turn. Has anyone else encountered the same problem? Any ideas?
    :?
     
  16. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ notAvailable,
    Your save game works perfectly fine for me so it's nothing wrong with that.The reason I asked about the *.pro files was because if they go missing, Kaga crashing is the first symptom, later you might get some black maps, but that should not happen in your case.


    @ Makenshi,
    No list for RP 1.3 that I am aware of.
    A new NPC that can be recruited at EPA, is all I know.


    @ McWulf,
    That happens for me as well. But It's not a big problem since we shouldn't save in combat anyway. :naughty:

    cheers
     
  17. Munin

    Munin First time out of the vault

    67
    May 27, 2008
    Kaga

    about Kaga, the game doesn't crash with me after I leave arroyo but since I ve played the previous version of this patch I know I should meet Kaga after leaving Arroyo. Appearantly that encounter doesn't occur when I played the game (I installed hi-graphics patch & Restoration project 1.2).
     
  18. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Re: Kaga

    Are you sure you installed the Restoration Project Mod and not the Unofficial patch? They are not the same thing.
    It has happened before. :)
     
  19. Cosmic Sea

    Cosmic Sea First time out of the vault

    16
    Nov 29, 2008
    Pipboy speech thingy?

    Difficulty set to easy...
    *starts up FO2 and checks*
    Yep, indeed. That was it. I must have forgotten it on easy after some harder lockpicking. :roll:

    But then there's still the science skill at 220%. It was at 120% when I last invested skill points in it. :look:
     
  20. Naissus

    Naissus It Wandered In From the Wastes

    102
    Jan 17, 2006
    I am attempting to download the mod but while its downloading it will stop and give me a "could not be saved, because the source file could not be read". Does anyone know why this might be happening?
     
Thread Status:
Not open for further replies.