Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    It was fixed in a previous update (2.0.2d I believe). Since each update contains the previous fixes, yes this update addresses this issue. You must enter the Vault for the first time though for the fix to work though.
  2. skalderis

    skalderis First time out of the vault

    Apr 12, 2010
    Re: EPA

    No, don't have it. Just sniper/smoke animations.
  3. FunkySwerve

    FunkySwerve First time out of the vault

    Apr 17, 2010
    When I tried to install patch e over my RP 2 and c patch, it refused to overwrite any of the files. I suspected that this was something to do with it being installed in C:\Program Files, so I uninstalled FO2 and the RP, and installed in C:\Games instead. Sure enough, everything patched fine - I suspect I just missed the warning last time, which would explain why my Broken Hills issues persisted after I used the fixes.

    There's a new problem, however. I installed FO2, the RP2 (installer, not manual), then c, then e (though I don't think c was needed bc included in e, I was being cautious). I then started up FO2, and it ran fine. I immediately went to Options, to change the settings to use 1900 resolution and fullscreen. I checked the option to restart, then clicked done, and it crashed. Afterwards, when I attempted to start the game, I got this error:

    Failure initializing input devices.

    after the initial questions about registering.

    Reinstalling the RP (installer again), c, and e, I no longer got the error, so I attempted to set a lower res, 1280. This time, instead of checking to restart, I simply clicked done, and exited the program. Attempting to restart the program again afterwards yeilded the identical input device error.

    So, um, help? :P

    Thanks in advance,
  4. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Re: EPA

    Install it. It is needed for many of the maps. You can still play at 640x480 if you so choose.

    Did you set anything under the sfall tab?

    Also, what happens if you set SAFER_DISPLAY_LIST to 1 in f2_res.ini (assuming it isn't already set)
  5. FunkySwerve

    FunkySwerve First time out of the vault

    Apr 17, 2010
    Re: EPA

    Yes, I set the resolution to match the one set in in the Hi-Res tab, and set DX-9 to Fullscreen. I did not set GPU Blitting.
    It was already set the first time I checked it.

  6. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Re: EPA

    Don't set anything in the DX-9 tab. Leave it at its default settings.
  7. FunkySwerve

    FunkySwerve First time out of the vault

    Apr 17, 2010
    Thank you, that fixed it. I was able to use the sfall settings before the e patch, so either installing the game (and patches) in a different folder changed something, or something is changed with the new sfall.

    Thanks again,

  8. thai1109

    thai1109 First time out of the vault

    Dec 28, 2008

    At Broken Hills, Liz's back door is always left open. She refuses to trade stuffs even though i have not done anything, and i can access the basement without provoking her.

    Screen shot, the door closed first time i arrived but next morning it's gone :

    I'm using 2.0.2d.

    At vault 15, I broke one Darion's arm but he's still able to use the flamethrower. He mumbled about something that I must did more than breaking his arms to stop him so I supposed he was special. Is it true?

    Btw, is Kaga encounter scaled according to char Lvl?
  9. Baizhao

    Baizhao First time out of the vault

    Apr 18, 2010
    Hello, can anyone help me with my ddraw problem?

    If I try the RP 2.0+ ddraw.dll it always wouldn't start Fallout, says I need Directx3.0 and Windows NT4 SP3 or newer.

    I got Windows XP SP2, November 2009 DirectX 9, d3dx9_42.dll both in Fallout2 folder and in /Windows/system32 folder, still it wouldn't start... Oh, and if it is my hardware is Core2Quad 6600, Radeon 4850.

    To play I use RP 1.2 version of ddraw.dll, and it seems very old and limited - a lot of options in ddraw.ini have no effect. It is fully playable, but I have got a very strange bug: Neither me, nor NPCs, nor Hostiles can equip or use Hunting Rifle, Scoped Hunting Rifle, Sniper Rifle.

    I would very much appreciate if someone helped me to solve these 2 problems. Or provided me with some post 1.2 RP, but Pre 2.0 RP's ddraw.dll(s)

    Thank you.
  10. YujiTFD

    YujiTFD First time out of the vault

    Apr 13, 2010
    "Dramatic request" crash

    Stumbled upon "dramatic request" crash at the <Cat's Paw>, tried several cons with no luck. Pity, wanted some action :(

    If somebody could take a look, I'd appreciate it.Version 2.0.2e save. Thank you!

    Update: crash occurres with asking ANY service for main character, party members are doing fine. Save savegame from above.
  11. YujiTFD

    YujiTFD First time out of the vault

    Apr 13, 2010
    What Fallout 2 installation do you use? I'd suggest good 'ol Interplay CD (or CD image for that matter) with Fallout 2 v1.0. I also tried RP with GOG's version (Good Old Games, www.gog.com), but with RP 1.2 I failed (have no idea why, though, just couldn't get it working) and RP 2.0.2e is working, but anyway, installation from scratch is highly recommended. And don't mess different ddraw.dll and ddraw.ini versions, use the latest (supplied) and edit it up to your liking. Also can try DirectX Web updater, it should find and fix your DirectX troubles.
  12. Hellburn

    Hellburn First time out of the vault

    Apr 14, 2010
    Sulik won't attack Keeng Ra'at. He just stands still or keeps the distance...

    RP 2.0.2e

    Well, for me it is serious bug if NPCs don't attack the enemy (whoever the enemy is).
    No, it isn't combat preference problem. Do you think I didn't checked it out?
  13. Baizhao

    Baizhao First time out of the vault

    Apr 18, 2010
    Wow, now that is a problem... Oh wait, KeengRat dies from one SMG burst anyway. :roll:

    NPCs don't attack stuff a lot of time in my game, bad combat preferences are to blame usually. Try changing them/weapon Sulik wields. Thank you.
  14. flareno

    flareno First time out of the vault

    Dec 26, 2009
    "Anwendungsname: FALLOUT2.EXE
    Anwendungszeitstempel: 3671bf22
    Fehlermodulname: FALLOUT2.EXE
    Fehlermodulzeitstempel: 3671bf22
    Ausnahmecode: c0000005
    Ausnahmeoffset: 000af4b0
    Betriebsystemversion: 6.0.6002.
    Gebietsschema-ID: 1031
    Zusatzinformation 1: fd00
    Zusatzinformation 2: ea6f5fe8924aaa756324d57f87834160
    Zusatzinformation 3: fd00
    Zusatzinformation 4: ea6f5fe8924aaa756324d57f87834160"

    Sry it's german :P . i get this message like every 15-20 minutes
    (mostly while in battle) can anyone get something out of this Oo

    RP 2.0.2e
  15. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Re: "Dramatic request" crash

    Yeah, it's because you've saved/loaded too many times in a row on that map. Stupid buggy game engine. :roll:
    Note that this is only an issue because of the code I used to get the temp stat boost for having sex working.

    Put this file in your ...\DATA\Scripts folder, replacing the one already there.

    That will stop the game from crashing, but the temp stat boost is still broken cause of the save/load issue.
  16. Endocore

    Endocore Look, Ma! Two Heads!

    Mar 14, 2010
    I went through Broken Hills and about a third of the New Reno quests. I didn't notice many of the problems others have mentioned in these areas, but while playing I did experience the following issues:

    --from "Restoration Project Corrections.txt"
    As far as I can determine, npcs still don't get poisoned in the first place in order to utilize their new floats. I've done a lot of fighting in random encounters and my kill counter says I've wiped out about 500 scorpions and 400 rats (rats and pigrats are poisonous), which is a lot of battles and a lot of hits on my npcs from poisonous creatures. I also got the "toxic waste dump" special encounter, and stood around a while fighting geckos. Yet I've never seen any indication my npcs were poisoned or irradiated.

    --Maybe it's always been there (I can't remember), but there's a blow-up doll in Marcus' house in Broken Hills on a shelf on the south side, making it extremely easy to solve that doll part of Typhon's quest;

    --Myron told me about the EPA the first time I asked him to wait, and about the Mordino stash the second time I asked him to wait; not sure if these were reversed accidently or that's how it's supposed to be now;

    --After leaving the Stables for the first time, the coordinates for reappearing on the world map are off a tiny bit; I reappeared at the western edge of the grid square right next to the Stables. Since I had gone to the Stables directly from Virgin Street by asking Miss Kitty to be Myron's party girl, this left the Stables square still dark/unvisited;

    --Woah, a visit to Myron is very profitable as he now has several thousand dollars worth of drugs and skill books in his bedroom; whether all that should be there or not, the red condoms and empty hypodermic needles found in his bedroom don't stack with other red condoms or empty hypodermic needles;

    --In the underground level of the Stables there are some scenery fire extinguishers (maybe they've been elsewhere and I didn't notice); examining them gives the message "You see: Fire Ext.." (two periods);

    --Has the player always lost karma points by working as a fluffer for the Corsican Brothers? If so ok, but if it's something new it seems pretty judgemental given, well, Fallout 2 (of course the notification of karma changes is new, so maybe I just never noticed before);

    --Maybe it's always been this way (I don't remember), but the first time I visited the Shark Club I slept with Leslie Bishop without having talked to John Bishop beforehand; when I tried to leave Bishop and his men attacked me. Leslie was very satisfied by my high bedroom skills; isn't she supposed to escort the player-character out in this case? I also had Moore's briefcase with me (but hadn't talked to Mr. Bishop about it); shouldn't I instead have had a chance to tell Mr. Bishop I was there to deliver the case?

    --When sleeping with Leslie Bishop, there seem to be some random oddities with moving the pc and Leslie to the bed; the first time I tried Leslie was laying on the bed but the pc was standing (on the dialogue screen "snapshot"), while the second time both Leslie and the pc were standing on the bed rather than laying on the bed;

    --I was able to walk "into"/over top of the billiard table near the Bishop guards and stairs on the second floor of the Shark Club;

    --In the southwestern-most room in the basement of the Mordino bar, one can shoot through the "Vault of the Future" sign that serves as a wall; I was in that room while Miria was in the room to the north, and she was able to kill a rat from there in my room with her hunting rifle;

    --For all the bartenders in all the casinos and all the "long hair leather jacket" drug dealers in the street, there's no comment by them after the barter screen closes; in other words the area where they should say something like "Anything else?" or "Nice doing business with you" is blank, but the player has a response line "[END]" to close the dialogue screen;

    --From ncethwri.msg:

    {405}{}{I don't know! (Hands clench into fists.) They sell that poison on every corner here in New Reno! EVERYWHERE you go, they're peddling it…!}

    Either the ellipses or the exclamation point in the last sentence should be eliminated.

    --At the Wright household in the bedroom just south of Richard's room there's a child who is laying down on the floor and who doesn't seem to ever stand up;

    --Inside the Wright house there's a wandering little girl who has a little boy sprite;

    --From ncWriChi.msg:
    {151}{}{You see a black-haired little girl. Her hair is cropped short, so much so that you almost mistook her for a boy.}
    {158}{}{Her black hair is cropped short so that she can conveniently use the male child character model.}

    Now that there really are little girl sprites, these should be changed (if some little girl sprites are put on the map);

    --From ncWriChi.msg:

    Should have some punctuation mark (probably an exclamation point)

    --I'm guessing all the crates of booze in the basement of the Wright train station were an attempt to address the perennial "But everyone on the map says visit the train station if I want some booze" bug, but it doesn't seem right that the player can just loot all that booze with no consequences; it's extra work, but perhaps either Chris Wright or one of the family members in the basement should be turned into a booze trader;

    --After talking to the Wright children playing in front of the house and going with them to spy on the Salvatore Desert transaction, I could speak to them about it again and continue to visit the Salvatore Desert transaction;

    --After visiting the Salvatore Desert transaction with the kids to spy on it, I reappeared on the world map in the middle of the New Reno town square; I could be wrong, but I'm thinking one used to reappear close to but not in New Reno on the world map;

    --3 Card Monte's initial dialogue (first time talking to him) starts out as:

    Monte: You cheater. You no play fair.
    Chosen One:
    a) Uh, get down to what?
    b) I'm familiar with the game. Here's 20 chips. Let's play.
    c) Why don't you give me some information?
    d) Not today, thanks.

    --Maybe it's always been this way and I just noticed due to the karma notifications, but I lost a few points of karma after Renesco gave me the PipBoy Medical Enhancer; that doesn't make sense and seems like a bug.
  17. Nevill

    Nevill First time out of the vault

    Mar 14, 2007
    It is a part of a bigger problem. You might want to ask Timeslip if this is fixable at all.
  18. Baizhao

    Baizhao First time out of the vault

    Apr 18, 2010
    Reinstalling doesn't help, still same Error with RP 2.02e ddraw.dll :(
  19. SPC

    SPC First time out of the vault

    Jan 20, 2007
    Sorry but how does one get to the EPA? I just finished my 2.0 playthrough and never saw any reference to that site. :|
  20. Faraday

    Faraday First time out of the vault

    Mar 11, 2010
    As far as I can tell, Myron is the only way =/ I had to go & recruit him just so I could find the place D=
Thread Status:
Not open for further replies.