Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. Demonslayer

    Demonslayer Water Chip? Been There, Done That

    Aug 8, 2005
    It's the first time i installed resolution mod so anyone can tell me how to change the resolution?

    Forget: found.

    Now i'm getting failure inputing devices, help anyone?

    Solved, i guess.
  2. ocelot

    ocelot It Wandered In From the Wastes

    Sep 17, 2003
    Here you go, good sir
  3. Magnus

    Magnus Water Chip? Been There, Done That

    Dec 6, 2007
    WHY are there suddenly 15 Xander Roots and Broc Flowers in the Arroyo hunting grounds? Has this been requested by a lot of people? Does it break the game having to conserve your limited Healing Powders at the start instead of just selling half of them at the nearest vendor? Was it intended by the original devs that there be that many? As far as I recall, the description of the Xander Root says it's "rare", well right now the villagers of Arroyo could easily dope themselves up on Healing Powders, take on a pack of geckos and bring home enough meat for the next 6 months, saving you the trip to get the GECK at all. I'm sorry for nitpicking here, but this seems like a very whimsical and unfounded change to me.

    I did like the new scenery in Arroyo though, with the grass and whatnot, only that a couple of pots seem awkwardly placed, and one rug in the Elder's tent should be removed.

    All right, I'll shut up now, the mod's awesome and I'm not saying otherwise :) I just hope you'll revise the enhanced maps for v2.1 with a more conservative eye.
  4. xzel87

    xzel87 First time out of the vault

    May 5, 2010
    I have always wondered why i keep getting "failure to input device" when i try to use the dx9 mode to change resolution instead of using mash's high resolution patch. On the first try at 640x480 it can run, but when i start changing i get the errors and the dx9 mode is forever unusable.

    Should i be setting custom resolutions via the nvidia control panel?

    My thanks and gratitude for any help received :D

    Demonslayer, how'd you solve it?

    Btw, in Arroyo theres a tent NE of Morlis with a shelf that usually has 1 xander root, unfortunately a pot seems to be blocking the PC from using the shelf.
  5. Athlon

    Athlon First time out of the vault

    Apr 30, 2010
    open ddraw.ini

    Look for:

    Set these to 1 if you want fallout to access the keyboard or mouse in background mode
    ;Try these if you get the 'Failure initializing input devices' error
  6. xzel87

    xzel87 First time out of the vault

    May 5, 2010
    Finally works now, thanks Athlon.

    Never used that because i thought it was for the windowed mode.
  7. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    We're doing just that.
  8. evilincubus

    evilincubus First time out of the vault

    Jul 1, 2008
    No idea if its reported or not, but in enclave on presidental/main computer level, whenever im planting explosives (plastic ones) with steal on president or sciencists my game crashes right after the explosion.
    heres the crash/report:

    Im playing on polish version of game with the Text/English folder + i have the latest patches
    PS: are there any others explosives on enclave :x forgot to pick some from continent and found 2 plastics ones in barracs or w/e on first level.
  9. Josan12

    Josan12 Vault Senior Citizen

    Oct 15, 2007
    Yes, i have to agree with Magnus. IMO, the very early stages of the game are particularly sensitive to game balance, and the number of Broc and xander is actually quite important, IMO. I would add only 1 or 2 of each to the original quantities found, especially as they re-spawn.
  10. nyberg

    nyberg First time out of the vault

    Jan 6, 2008
    i have some problem i try to change resolution but when i press arrow to go upp my game crash. how do ichange resolution ???
    i have just made fresh install and this updato 2,0 and added e uppdate.
    installed every option..

    edit have win 7 x64,
    didnt install on c disk,

    and it have worked before on same setup for me, but now i have reinstalled it twice and no change
  11. Demonslayer

    Demonslayer Water Chip? Been There, Done That

    Aug 8, 2005
    Like every good computer user i uninstalled Restoration and reinstalled. Then instead of using 16 bit colors used 8 bits and voilá.
  12. YujiTFD

    YujiTFD First time out of the vault

    Apr 13, 2010
    Question: if loading savegame is crashing the application, can problematic part be realised and eliminated?

    [spoiler:a01ae5228c]Since I'm level 20, I was "hunting" for 4th Kaga encounter before hitting 21. Found him in Advanced Power Armor, knocked him down and killed his associated. Then I looted Kaga's unconscious body and went for looting other corpses, and while I was doing that, Kaga woke up and stood still. I tried to talk with him or interact in any other way, but failed. Oh, well, I saved, got into the car and drove off.[/spoiler:a01ae5228c]

    Then I felt urge to reload last QuickSave and it crashed the game. I tired it several times with reloading game and PC but achieved nothing. That means I've lost the save and have to rollback and lose the progress?

    Here is the save just in case. It situation cannot be resolved - don't bother DLing save, just let me know. Thank you in advance.

    P.S. Other saves are working great.
  13. Ravager69

    Ravager69 Sonny, I Watched the Vault Bein' Built!

    Dec 21, 2007
    I had a very similar situation, but still in 1.2. It didn't cause the game to crash, but the encounter went to shit 'cause of that.
  14. nyberg

    nyberg First time out of the vault

    Jan 6, 2008
    found out how to chagne res,
    i changed in 8bit mode then changed to 16bit, and it worked,
  15. Herr Mike

    Herr Mike Look, Ma! Two Heads!

    Jul 28, 2008
    Feel free to ignore this one as it may be an old issue or one that is not worthy of your attention:

    When I save during combat mode and load, it gets all wonky when I continue. All the turns but mine appear to be simultaneous, and no combat messages appear in the message window.

    I don't make a practice of saving before each shot or anything, so it's not really a big deal, but there it is.

    I also want to note that I think the random encounters are a bit too dangerous. I almost like the additional challenge, and I understand that running should be a viable strategy most of the time, but your companions don't run when you do meaning Sulik rarely makes it to Modoc.

    Anyway, awesome work to all involved.
  16. xzel87

    xzel87 First time out of the vault

    May 5, 2010
  17. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Did Gruthar die somehow? Your save game indicates you killed Dr. Schreber at Navarro, but perhaps you didn't do this in time and the Enclave came and killed everyone at V13.

    I looked at your save file and it says you didn't do anything with the economic disk. You need to in order to get the best ending for Gecko.

    Nope. But it would make sense that they would. Mom wouldn't want dealers to be around the orphans. Also, did you massacre everyone in the Den? That would explain all the blood pools I saw. :P

    So, many people say the encounters are much harder in the RP. I don't understand, since I haven't changed them at all. So, I dunnos. *shrug*
  18. Magnus

    Magnus Water Chip? Been There, Done That

    Dec 6, 2007
    This might be a stupid question, but are you using F2WR? With the changes to ammo, armor and weapons damage it makes random encounters of Raiders or Slavers positively terrifying.
  19. xzel87

    xzel87 First time out of the vault

    May 5, 2010
    I had too much fun head-bashing druggies with my crowbar :D..well i doubt mom could actually make those dealers go away because she cant even handle some lowly weak squatters.

    btw, i reloaded to the "before" game and it was normal, so maybe just a one-time glitch or something.
  20. smilodom

    smilodom Look, Ma! Two Heads!

    Apr 17, 2008
    I think it would make sense if you have the "antidote" to cure the jet addicted, thus the "Den" get rid of the drug dealers.
Thread Status:
Not open for further replies.