Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. G-Flex

    G-Flex First time out of the vault

    Apr 28, 2010
    For what it's worth, I've had trouble with plastic explosives in the Vault City courtyard as well (although I must stress this was the unofficial patch, most recent version, and not the RP, so it may or may not still apply). The explosions weren't triggering where the bombs were dropped sometimes (even if they were planted on someone), instead often choosing this one particular spot in the corner of the fenced-in servant area, or occurring offscreen. I'm pretty sure it crashed the game at some point as well, although I'm not sure that was in the same area.

    Oh, and when they occurred offscreen, the bomb on the ground... didn't go away. The description still said the timer was ticking, so it probably left a useless non-exploding-yet-ticking plastic explosive behind.
  2. Midnight

    Midnight First time out of the vault

    May 10, 2010

    I have installed RP2 on a new and fresh Fo2 installation and it work almost fine, with one issue still ... I haven't the children.
    I have checked during the installation to have children, the arts seem to be at the right place, i did a complete install but still no children in Klamath or the den.

    I have the french Version of the game, i have edited the fallout.cfg to put langage in English.
  3. smilodom

    smilodom Look, Ma! Two Heads!

    Apr 17, 2008
    I meet the "Robbers" (for already two times now) at a random encounter in a cave.
    They didn´t fight just some who had super power fists, but for the others there was no problem to kill them.
    So i end up with more of 10 turbo plama rifles about 10 YK42 and even 2 Gauss rifles, not mentioned the ammo.....?

    Another issue when i meet the "lesser Deathclaws" also in the caves, it´s like prize shooting in disneyland yoe get too much "Ep" for really nothing...
  4. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    If you ever get it again, please provide a save game for me to test.
  5. Athlon

    Athlon First time out of the vault

    Apr 30, 2010
    someone who has had the same problem?
    when i try to leave mira behind me. she turn hostile against me.

    and when I get shot at sometimes, I die, even if they hit me with 56hp. and i have 153hp.
  6. Luigibacsi

    Luigibacsi First time out of the vault

    Jan 18, 2009
    I have seen this bug(?) with enemies. It usually happens when you get a critical on them.
  7. Eccelons

    Eccelons First time out of the vault

    May 6, 2010
    hi, dunno if this belongs here, but in SF when i fight in the ring, my npc start shooting too. makes the fights easier ofc, cause they kill them pretty quickly but i guess its not supposed like that.
    also when i get to frog morton in redding, one of his guards is next to the building in a no go area.
    i still use the d version not e though
  8. Reikis

    Reikis First time out of the vault

    Mar 13, 2008
    I just installed fresh install of Fallout 2 and newest version of RP. When I select my char and after seeing/skipping elder vid game crashes with error:

    The instruction at 0048d9c4 referenced memory at 00000014
    The memory could not be read from

    Game freezes when I try to make my own char without errors.
  9. thai1109

    thai1109 First time out of the vault

    Dec 28, 2008
    I'm not sure if these are bugs:

    _ The second Morton brother always runs next to me even though he has light support weapon. If my memory serves me right, i has had this issue since Unoffical Patch, not sure about vanilla.

    _ The price suddenly dropped. I used to buy a power armor for 50000+, now only 30000+. The only dramatical changes are probably my lvl and 2 extra NPC.
  10. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I think I know what this is all about, or at least I found a way to replicate it. When you enter the cave the robbers are set to wield their weapons right away, but if this gets interrupted they get stuck somewhere in between (the game thinks they are wielding weapons but their animations don't show it and they can't use them). It's most likely starting combat mode too fast that fucks this up. I tried a few times but only got a few of them to get "stuck", never all, until I entered the cave and pushed the "A" key right away.
    Well, not the Power Fist ones obviously as they don't use any "wielding" animations.

    I tried to add this in ecrobber just to test, and it cleared them and they would start using their weapons again.
    procedure combat_p_proc;
    variable only_once;
    procedure combat_p_proc
            if (only_once == 0) then begin
                    only_once := 1;
                    metarule(43, self_obj);
    So I was thinking if you could maybe put the whole wielding code in combat_p_proc instead?

    Also, I didn't study the whole code so I don't know exactly what is up, but using metarule 43 on the critters with power fists seems to be a bad idea as they won't re-equip them on their own. I'm guessing the combat ai won't let them as they are set to "ranged then melee", but maybe it's just a question about using the right command.
  11. Psihotik

    Psihotik It Wandered In From the Wastes

    Sep 22, 2009
    One more bug, not sure is it vanilla or RP one: some NPCs, usually Marcus, skip their turn and just don't do anything. They have full or most of their health, armed with a weapon and set to "AGGRESSIVE", but nothing, just skip their turn even though they could be of a lot of help.
  12. Xellos

    Xellos Where'd That 6th Toe Come From?

    Feb 10, 2006
    crippled maybe ?
  13. Psihotik

    Psihotik It Wandered In From the Wastes

    Sep 22, 2009
    Nope, I checked. And I can see that green silhouette around them for around a second and they just pass the turn.
  14. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Are your opponents large creatures and is Marcus using unarmed or melee?
    Then it's the same bug as the one below.

    killap, I've looked into the problem with NPC's not doing anything until their opponents are standing right next to them (broken repair bot in Klamath canyon is a good example). This is mainly if your NPCs are unarmed or using a melee weapon, but the bug seems to affect ranged as well, but not to same extent (they wont react within the same distance as normal, but they don't need to be right next to their opponents).

    The problem is the "multi hex" flag that larger critters are set to. See below how it affects a critter:

    First is normal critter, second is multi hex critter and last is a no block critter. The first and last works as it should.
    What I believe is happening is that the NPCs are looking for the critters center hex but is effectively being blocked by the outer ring that the multi hex critter has. Whether it's because they can't see their enemies or that they can't do whatever they are trying to do, they end up doing nothing.

    I don't know if this can be fixed in the engine, if not would it be good enough to not have any multi hex flags set for the critters?
    I'm not quite sure of it's function. Is it only to prevent you from "walking trough" part of the critter? If that's it, is it such a big deal to not use it? Will it look too bad?

    If you want to remove that flag you have to edit the protos (in the Mapper or otherwise) and also replace all affected critters that are already on the maps. That's because changing that flag on critters already placed on maps is broken in the Mapper, it can only be done before a critter is placed.

    Try to go to Klamath canyon with a couple of NPCs and see how they behave with different weapon types equipped, and then change the robots "No block" flag to "yes" and see the difference.

    So what do you think?
  15. agris

    agris Look, Ma! Two Heads!

    Jul 8, 2004

    What about changing the multi-hex critters to a single hex that blocks (i.e. the same as the tribal in your picture), rather than one that allows creatures to walk through it?

    For the Mr Handy, the multi-hex flag allows it to use a melee attack from further than 1 hex from the _center_ hex. Right? Well, changing them to single-hex will remove this ability. Is it possible to give the custom melee proto that the Mr. Handy uses a range of 2 to compensate?
  16. Darek

    Darek is currently unavailable

    Jan 7, 2008
    That was what I was suggesting (or at least trying to). :)
    The no block was just for testing purposes.

    Hmm, didn't think of that, will have to test.
    The no block flag together with the multi hex flag works as normal anyway.

    Edit: Yeah you are correct, the 2 hex melee attack disappears, though that shouldn't really be a problem as you have to get one step closer to him as well for your attack, so it evens out.
    The only way to get him to have a 2 hex range that I know of would be to equip him with a custom weapon.
  17. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I'm assuming large critters are set that way to prevent the player from clipping their legs, arms, etc.

    NPCs being unable to attack seems much more than some minor clipping. What other critters (besides the Klamath robot) are affected by this? Would it be possible for you to make a list of the ones that need to be modified?
  18. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Well, people who like going solo might not like a change like this, not that I care much. :)
    But an alternative solution would be preferable if we can find one.

    Anyway, I just checked the protos for Muti-Hex critters, and these are the ones:
    All Large Radscorpions
    All Large Deathclaws
    All Brahmins except for Angry Brahmin and Wild Brahmin
    All Repairbots except Weak Mr Handy
    All Large Molerats
    All Centaurs
    Frank Horrigan, but not the dying one
    Also the following new ones are missing that flag but should have it if it would work properly:
    Mother Alien
    Mr Handy Robot
    and maybe Mother Sporeplant
    Wasn't as many as I thought, mostly random encounters affected, still annoying though.
  19. Psihotik

    Psihotik It Wandered In From the Wastes

    Sep 22, 2009
    Yes, the first time I spotted that problem was in Klamath, with the robot, but I had some problems with the deathclaws in Abbey.
  20. Apmucm

    Apmucm First time out of the vault

    May 12, 2010
    Hi, thanks for awesome mod.
    I have a little problem. Cassidy and Sulik run away like cowards while in battle, but Vic is not. Everyone have full HP, combat mode -aggressive. Thanks a lot.
Thread Status:
Not open for further replies.