Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. onkelfrosti

    onkelfrosti First time out of the vault

    May 12, 2010
    I don`t know if mentioned, but i have a bug in this way:
    When I wish to enter SAD on world map or the military base after i have blown free the entrance
    The game crashes.
    I use the german version with rp 2 and patch e.
  2. joochian

    joochian It Wandered In From the Wastes

    Apr 1, 2010
    why dont make other npc spews out more floating text.. at a higher rate as cassidy...

    i wished i had a limit break,,,
  3. FallMan

    FallMan First time out of the vault

    Mar 14, 2009
    killap - any news about 2.1 update?
  4. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    In testing stage now. Hopefully ready in a week or so. I'll keep everyone posted. And no, it won't be epically delayed like 2.0 was, that was different.

    Also, now's the final week for new bug reports. Please post any issues asap, so that fixes for them make it into the 2.1 release. I would also appreciate it if people could try to reproduce the "UNCONFIRMED" issues over at the RP wiki.
  5. CreziFella

    CreziFella First time out of the vault

    May 13, 2010
    Hello killap, I've been trolling your restoration mod for a long time, and after seen your newest version, I just had to register an account here and wanted to say "Awesome x100000 job!". 2 1/2 years and still you're keep going! Wow! All the best to your future projects! :)

    BTW : I installed your new version, when I met Kaga for the first time (I was level 4, with the 9mm handgun with Sulik with me). He was with 2 other tribal.. when I'm killing the other 2 tribal he fled but didn't end the battle, instead he run off into the tent (the map have a tent) after I've dealt with both of the tribals, I go after Kaga.. he have 333 HP and I killed him o_O for some reason he woudn't attack back and just talking like he would run... but he didn't until hes dead.. is this a bug? I guess I won't be encountering him anymore after this huh?
  6. lbandi

    lbandi First time out of the vault

    May 13, 2010
    First hi everyone! Im newbie on the forum!

    I checked my original Fallout2 Master.dat file (which on its CD) an the size doesnt as the same that u wrote (my master.dat filesize is:333 098 563byte and when i install the RP on it the new master dat file got the same size (and it has benn overwritten, i checked the dates) So i cant solve the save issue. Tried reinstall and removing the read-only option..etc.

    If someone upload a working RP master.dat file to somewhere (RS, Megaupload ...) i will thank it!
  7. Aracnoid

    Aracnoid First time out of the vault

    May 13, 2010
    i'm just installed the 2.0 version.
    in character screen there is a race and style selector but there is just one model. is it normal or can i download models separately? and from where?
  8. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Well see, the Master.dat file is quite large and if we would start distributing it we'd get mighty close to piracy.
    Anyway my original Master.dat file is the same as yours, 333 098 563 bytes and I have no problems updating it.
    Tell you what, try to patch your master.dat manually.
    Download and extract this into your main Fallout 2 directory.
    Then go into the batch_work folder and run f2.bat, or if you want you can run the other *.bat files in this order; new_npcs.bat, remove_bad_protos, add_fixed_protos.bat (and delete_tmp_files.bat once your install is successful). Also delete the whole batch_work folder once you are done with it.

    I don't think anything more exist yet, though I seem to remember that a black dude was being worked on, but I may be wrong.
  9. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yeah, just the long hair dude is available right now. Hopefully at some point a the bald dude will be ready and as Darek said, a black dude is also in the works.
  10. Aracnoid

    Aracnoid First time out of the vault

    May 13, 2010
    actually i was hoping for female models. :)
  11. lbandi

    lbandi First time out of the vault

    May 13, 2010
    Im done all the thing u said (i checked it twice to do the same that u wrote) and now the program doesnt starts. I get this error message:

    "You are trying to use sfall with an incompatibile version of fallout expecting Fallout 2 v1.02US

    fallout2.exe had an unexpected crc Expected 0xe1680293 but got 0xfce8ff04

    What did i wrong? Can i do something with it? My OS XP SP3
  12. isfet

    isfet First time out of the vault

    Jan 19, 2008
    oh yeah :D a redhead would be a real treat ...

    Anyway, I just noticed the "new" fire gecko skins I've made a while back for 1.2 (I believe the old grayish ones were used in that release) made it to 2.0. Thank you Killap it's an honor to have my small piece of art included in this magnificent project. I almost forgot I made those :D

    One more thing - is it normal to kill Kaga during the first encounter? At the time of the encounter I was a low lev diplomat character, but Kaga got bugged in a strange way. He wasn't able to leave the map, he was just running along the edge of the map until Sulik and Vic beat the cap out of him.
  13. Herr Mike

    Herr Mike Look, Ma! Two Heads!

    Jul 28, 2008
    Aren't we all? :wink:
  14. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I don't understand why that would happen. The master.dat patch I linked to alters neither fallout2.exe nor sfall.
    Are you sure you have the US fallout2.exe (the one that comes with the RP)? Maybe when you reinstalled it didn't get copied over or something.
    If you want to, you can try with mine.
  15. .Pixote.

    .Pixote. Antediluvian as Feck

    Sep 14, 2009
    There most likely will be new female critters in the future, but to give people a rough idea as to how much work is involved note:

    The PC critters has approximately 140 animations, with 6 different directions, and on average 8 frames per animation (Some more some less) - 140 x 6 = 840 x 8 = 6720. That is just the basic frames, when you add the various procedures in building the critter (An accurate estimation is 8 procedures per frame including Photoshop and the Frame Animator) 6720 x 8 = 53760

    Almost 54,000 things must happen before you get to play a new critter, so hats off to the fine people who built the new critters – Xíl, Josan, and Jotisz. The black PC critter will need to be rebuilt because of some technical issues, so most likely Mr. Baldie will be the first off the production line, then Mr. Blackie and then some female critter (Ms Red Head). I will try to help devise a quicker method of critter editing by designing the appropriate actions in PS, but can we take this discussion over to New animations 2 thread.
  16. Herr Mike

    Herr Mike Look, Ma! Two Heads!

    Jul 28, 2008
    Downloaded and extracted the 2.02e update. The menu screen version # did not change, and now the game crashes when I try to load a save. If I try to start a new game, it just sits at a black screen.

    I'm on Windows 7, which I'm no expert with, so it might be something I'm doing wrong.
  17. lbandi

    lbandi First time out of the vault

    May 13, 2010
    Today i uninstall the whole game and clear the whole game from the registry, then i did this:
    1. Install the game, i used humongous install (checked the master.dat size was: 333 098 563 byte)
    2. Install the v2.0 RP (after this the master.dat size still 333 098 563 byte)
    3. make the batch_work thing that u advised
    4. replaced the fallout2.exe the one that u shared
    (at this point the master.dat is still doesnt changed, it seeems that nothing can update the file) :?

    Now the game starts BUT the savegame doesnt working (same problem before) and now i recognize that the caharcter saving doesnt work too. Im get annoyied with this problem, i wanna play so much but without saving the game its impossible. :?

    I hope you got some trick to get rid off this bug.[/quote]
  18. killap

    killap Bear Dude Moderator Modder

    May 16, 2005

    What OS are you running?
  19. Mirr

    Mirr First time out of the vault

    May 1, 2010
    *Edit Here is how I patch my MASTER.DAT under Debian with wine.From RP Manual install copy batch_work folder.Lets say we put it in /home/user/Desktop.Copy in it your MASTER.DAT file and open some terminal emulator(like gnome-terminal).Go to the batch_work folder($ cd /home/user/Desktop/batch_work) and run this command :
    $ wineconsole cmd
    Now we have new window.In it write or copy/paste :
    START dat2 d master proto\CRITTERS\00000502.pro proto\CRITTERS\00000503.pro proto\CRITTERS\00000504.pro  
    This command Remove Kitsune, Dex, Cat Jules protos from the master.dat in the event the RP was already installed - prevent dups.If patching "fresh" one it size must remain unchanged.
    START dat2 a master proto\CRITTERS\00000502.pro proto\CRITTERS\00000503.pro proto\CRITTERS\00000504.pro
    Add Kitsune, Dex, Cat Jules protos to the master.dat.File must be bigger now.
    START dat2 d master proto\CRITTERS\00000089.pro proto\CRITTERS\00000079.pro
    Remove bad Cassidy proto and bad Skynet proto from master.dat.Now little smaller.
    START dat2 a master proto\CRITTERS\00000089.pro proto\CRITTERS\00000079.pro
    Add fixed Cassidy proto and fixed Skynet proto to master.dat.Bigger...

    Move your MASTER.DAT file back in to your Fallout 2 folder.And hopefully there will be no more save errors.For some reason using f2.bat or separately other .bat files do not work for me.
    @lbandi maybe you can try something similar using windows xp cmd?
  20. Psihotik

    Psihotik It Wandered In From the Wastes

    Sep 22, 2009
    As I understood, the man who did the music for Fallout 1 and 2 has now remastered that same music and posted it on this site :http://auralnetwork.com/releases
    They will be available for free download soon, so they might be used in future releases of RP, right?
Thread Status:
Not open for further replies.