Hi-Res Patches for Fallout1&2 & the BIS Mapper

Discussion in 'Fallout General Modding' started by Mash, May 14, 2008.

  1. Mash

    Mash Vault Engineer Modder

    369
    May 3, 2008
    Re: Little help with the res patcher

    The Dvd must come with a different version. If you install the TeamX patch the resolution patch should work.
     
  2. joe_strummer

    joe_strummer First time out of the vault

    17
    Jul 8, 2008
    Re: Little help with the res patcher

    Ok, I'll try it later when I get home!
     
  3. joe_strummer

    joe_strummer First time out of the vault

    17
    Jul 8, 2008
    Re: Little help with the res patcher

    I extracted TeamX patch to D:\Program Files\GSP\Fallout\data and overwritten what was prompted and when i try to apply res. patch to D:\Program Files\GSP\Fallout\ i still got that message but when I try to apply it in D:\Program Files\GSP\Fallout\data it installs but resolution is the same no matter how I change the .ini file.
     
  4. Mash

    Mash Vault Engineer Modder

    369
    May 3, 2008
    Re: Little help with the res patcher

    There is a TeamX 1.2 as well as a TeamX 1.3.3 patch. The 1.2 version contains the falloutw.exe and should be installed first.
    The contents of the TeamX patches should be extracted to the fallout directory rather than fallout\data I think, as the TeamX falloutw.exe should overwrite the original found there.

    Edit:
    I may have misread your post. Did the f1_res_patcher.exe patch successfully?
     
  5. joe_strummer

    joe_strummer First time out of the vault

    17
    Jul 8, 2008
    Re: Little help with the res patcher

    No, I have to falloutw.exe. One in fallout directory and one in fallout/data directory which is FALLOUTW
     
  6. Mash

    Mash Vault Engineer Modder

    369
    May 3, 2008
    Re: Little help with the res patcher

    Yep, you have extracted to the wrong place, the FALLOUTW.exe belongs in the fallout directory. Re-extract the TeamX patch to the fallout directory and than apply the res patch.
     
  7. joe_strummer

    joe_strummer First time out of the vault

    17
    Jul 8, 2008
    Re: Little help with the res patcher

    It worked, but everything is smaller. Does it have to be like that?

    My save games are invalidated and version is 1.1
     
  8. Atombunker

    Atombunker First time out of the vault

    21
    Apr 7, 2008
    Read the readme. It says:
    Mash, maybe you should consider a different default value, it keeps confusing people. :)
     
  9. Mash

    Mash Vault Engineer Modder

    369
    May 3, 2008
    Re: Little help with the res patcher

    It sounds to me like you have installed the official 1.1 patch :?
    I have the TeamX 1.2 patch on my machine and the bottom of the main screen reads 1.2.
    Your saved games will definitely be incompatible with version 1.1
    This is a link to the TeamX patch http://www.nma-fallout.com/forum/dload.php?action=file&file_id=1076
    Every thing is smaller because you can see more. You can reduce the resolution in the f1_res.ini file. details are in the readme.
     
  10. joe_strummer

    joe_strummer First time out of the vault

    17
    Jul 8, 2008
    Saves are still invalidated :(

    I can start from a scratch.
     
  11. Mash

    Mash Vault Engineer Modder

    369
    May 3, 2008
    Sorry to hear. I thought you were just starting.
    If you backup the savegame folder first, you could always uninstall and reinstall from the dvd, to get you back where you started.
    Otherwise I would also install TeamX's 1.3.3 patch(if you haven't already)here's the link http://www.nma-fallout.com/forum/dload.php?action=file&file_id=1075
     
  12. joe_strummer

    joe_strummer First time out of the vault

    17
    Jul 8, 2008
    I'll just start all over. I have forgot most of the story and quests so it will be better that I start from beggining.

    I would like to thank you for making this patch and helping me!
     
  13. panje

    panje First time out of the vault

    1
    Jul 11, 2008
    Is there any way I can download this patch somewhere else? NMA server godly too slow. When download almost finished, its disconnected...arghh what a headache

    Already re-download more then 20 times, results still the same

    edit: done download at speed less than 1kB/s
     
  14. Atombunker

    Atombunker First time out of the vault

    21
    Apr 7, 2008
    Must be something on your end. I can download just fine, and it's only 114KB... even on dialup this should only take seconds.
     
  15. Zathrus

    Zathrus First time out of the vault

    4
    Jul 12, 2008
    Mash,
    I've got the weirdest thing with the resolution mod:
    I've got original Fallout2. I installed it using the "How to install Fallout 1/2 under Win2000/NT/XP" instruction here. works fine. Then I installed US 1.02 patch from the download here. works fine. Then I installed the resolution patch (the link here is broken). I searched from it and downloaded it from elsewhere, version 1.3. I extracted contents of the downloaded file into my fallout2 directory, then started f2_res_patcher.exe. That works just fine. Ok. The game has run fine up til this point. I start it now. It runs ok up til the actual game screen with player char on it starts.....The screen before that are ok....but smaller.....I'm running on a 16x10 lcd set to 1920x1600. The background is all covered with the "earth" tiles .....the ground......but.....the actual game screen looks roughly square at the lower center of the screen. VERY strange. I look at your notes......and downloaded from microsoft and executed vcredist.exe for Visual C++ 6.0. When I execute the file, nothing visual happens.....no acknowledgement, or diaglog popups or anything....I "think" it ran..... Is there an email that I can send the screen capture of this to so you can see this weird thing? Any help would be much appreciated. I've reloaded the entire installation several times and get the same thing... I don't think the vcredist.exe is the problem anyway..... Also I've got your resolution mod for Fallout 1 working just fine!

    Thanks for your help.

    I'm new here.....dying to play old games...no new rpg's or shooters to play til ..like October.... :( been digging in my pile of older games....I've got and played every rpg and shooter that's ever come out since 1990.... I'm suffering for a game to play...Then I remembered FALLOUT and DIABLO.....did Diablo already.

    Please help! :)

    Zathrus
     
  16. Zathrus

    Zathrus First time out of the vault

    4
    Jul 12, 2008
    Mash,
    I tried setting Auto_scrn_size = 1
    and setting
    scr_width = 800
    scr_hight = 600 (you can't spell height....hehe)

    even that doesn't work...there are still "checkerboard-looking" rectangles around game screen which looks like its actually 600x800ish.....weird.... I can see that when I "scroll" around the outside. I tried setting my Windows XP screen size to 1024 x 768, changing back to auto_scrn_size=0 , and it STILL looks the same, just bigger..... so all settings give me the "Exact same image" just bigger or smaller. All show the ground tiles from screen edge to edge, but with the game screen roughly rectangular at lower center looking about 600x800? yes that's right 600x800, not 800x600...... It's taller than it is wide. This is really weird. You need to see this screen capture.... please give me an email address to send it to you or explain how to display it here....its big....2m, taken in 1920x1200 mode (default for my Dell 2700).

    I'm DYING to use this mod! HELP!
    :(
    Zathrus[/img]
     
  17. Zathrus

    Zathrus First time out of the vault

    4
    Jul 12, 2008
    Mash,
    I see what's happening! It's ONLY the first screen that shows the PC standing outside the temple at the beginning of the game that's looking screwed up!...
    Once you walk INTO The temple, everything looks GREAT! How strange......so its only the first screen....... You probably still need to see this..... anyway....I'm setting auto_scrn to off and using 1024x768.....even though my screen is a 16x10. It won't let me enter any size in the .ini file that my video card doesn't specifically know. It's an NVIDIA 8800 GTX. But its filling the screen out fine in the correct resolution once I walk into the temple!..... so am I the only person to see this? I'll play further along (haven't really started yet!) and let you know if after I exit the temple, it looks strange again.....

    Zathrus
     
  18. Zathrus

    Zathrus First time out of the vault

    4
    Jul 12, 2008
    Mash,
    ok, I've figured out that I'm probably stupid. That entry screen outside the temple......although its the first one I saw and I thought it was screwed up......it only has a limited number of tiles in its picture! so on higher res.....there's nothing outside that 800x600.........thus......just ground...... I'm wondering where else I'll see this....but I'll know the picture itself is not as large as I've got it scaled to! at least I think this is the correct assessment. Do you agree? (about the picture size and about me being an idiot??)

    :P :oops: :wink:

    Zathrus
     
  19. Mash

    Mash Vault Engineer Modder

    369
    May 3, 2008
    There are several small maps in the game that don't extend far past 640x480. Some examples are the temple entrance, the bridge, the enclave entrance and the mountain random encounter maps.
     
  20. Styphelus

    Styphelus First time out of the vault

    15
    Sep 24, 2007
    Is there anyway to reduce the number "extra" tiles around the screen? For example, when i get to the edge of a map, I see quite a few extra tiles "stitched" on although my character can't move beyond a certain point. Is it possible to remove a certain amount of those tiles so my character stops moving closer to the edge of the screen instead of seeing all those extra tiles? Same goes for the extra tiles on the top portion of the screen.

    I'm not talking about smaller maps like the temple entrance, but about any other good size map that requires scrooling back and forth.