Megamod 2.4 Technical Issues and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Dec 3, 2009.

  1. Snowguy

    Snowguy First time out of the vault

    84
    Dec 12, 2005
    FALCHE for Fallout 1 seems to work, though with some irregularities. There may be other programs that work better though.
     
  2. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    I have no answers for this one. This is just odd. I can understand a failure to save a game due to missing proto files. I can understand a failure to load due to the fact that the game was saved when Klint just joined the party or had new armor put on. But this one is too odd. A failure to load also occurs if important files are deleted (like certain proto files), if certain files get corrupted (again, certain proto files) or if important files were changed (like certain files in the data/data folder).

    Can you try the trick I mentioned earlier? Have Klint join you outside the temple, then enter enter the temple in order to save the game.

    I mentioned earlier that it might be necessary to enter another map before you can save. In the other post, he said he traveled all the way to Klamath before saving. That should not have been necessary: just saving on the trapping grounds or the Arroyo bridge after Klint joined on the main village map would have been sufficient.

    Please let me know what happens.
     
  3. GhostWhoTalks

    GhostWhoTalks First time out of the vault

    69
    Sep 9, 2005
    I have a save game where after saving and then quitting attempting to load causes the game to crash. The only thing I can think of that has changed is that I told Klint to "wait here until I got back" while in Klamath, as I have not done anything out of the ordinary at the point where I am at.

    I am told "The Instruction at 004bd590 referenced memory at 05aca000 The memory could not be written"

    Any ideas what happened? I can supply the save game if this is something you would like.

    GWT
     
  4. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    The same is true for telling him to wait here for you. Go to another map, and then save/exit.

    Until Klint is completely redone to be like other party NPCs, it would be safer to just go to another map after any actions involving him before saving and exiting the game.

    Edit: Also, finally went to explore the Glow. Not sure what is happening there. All the relevant scripts seem to be working right, but, after using the rope to try to enter the upper level, I get a crash. I will work on this and keep you all posted.
     
  5. zenitfan4life

    zenitfan4life First time out of the vault

    72
    May 27, 2008
    Hello, this is my first time playing MegaMod and I'm having some problems updating it to the 2.4 version. So I go to this link: http://falloutmods.wikia.com/wiki/MIB88_Megamod and I see 3 files under the download section: 2.35, 2.35.2, and 2.4. Obviously the 2.35 is the main one since its over 100 megabytes. I follow the instructions in read me, delete the data folder in fallout directory, paste/overwrite the extracted files from 2.35 file, and run the RUNME.bat file. Then I launch Fallout 2 and it works fine, says I'm running MegaMod 2.35. Good. But when I try to copy/overwrite the extracted files from the 2.35.2 or 2.42 files into my fallout directory my game does not even launch. What am I doing wrong?
     
  6. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    Found and fixed the cause of the crashes at The Glow. If you absolutely have to get inside and don't want to wait for the next release, you can delete tglowent.int, tglwuppr.int, and tglwlowr.int in the data/scripts folder. This will not break your game, but the Glow will not work as intended by doing this (meaning that lighting will be messed up and radiation poisoning will not work entirely as intended).

    @zenitfan4life: I can't begin to tell you what is wrong without some more information. Are you trying to play this with the hi-res mod? Was this a fresh install of the game? Did you apply the MM to another game/mod first? Is there an error message?

    Also, just to be on the safe side, find this in your ddraw.ini and make sure it is as follows:
    WorldMapFPSPatch=0

    You might also want to try playing the mod in a different graphics mode, by changing the value in the last line of this section of the ddraw.ini:
    ;Set to 0 for 8 bit fullscreen
    ;Set to 4 for dx9 fullscreen
    ;Set to 5 for dx9 windowed
    ;A dx9 mode is required for any graphics related script extender functions to work (i.e. fullscreen shaders)
    ;Modes 1, 2 and 3 are no longer supported
    Mode=4
     
  7. Graveworm

    Graveworm It Wandered In From the Wastes

    112
    Mar 28, 2010
    I have found this bug a long time ago [spoiler:f9e21f3ee0]in a galaxy far, far away...[/spoiler:f9e21f3ee0]
    environmental armor animation is quiet ... strange
     
  8. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    For which character? On the player character? Or on specific party NPCs?
     
  9. Prinygod

    Prinygod First time out of the vault

    14
    Aug 12, 2008
    sorry for the late response my internet went down
    the line i deleted was art_cache_size=1029, before i did that it the game wouldn't work

    I said this in an earlier post, but im running win xp 64-bit so if the above is not normally needed to be done that is maybe why

    And yeah the stat problem was probably the weather mod because my perception was horrible, but i also had a problem with my carry weight being lower than it should even though any addiction had passed
     
  10. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    Yeah, that art cache line...
    Not sure exactly what it is for, but I had a similar problem once in getting another mod to run. I didn't delete that line, I just had to increase it. However, the value of that line is probably conflicting with some new art that was introduced, and I doubt it has anything to do with the issues with Klint.

    I have yet to try out any of the drugs/addictions in my latest playthrough. I'll test it soon, though, to see if this process has been somehow affected by one of the many global scripts or changes to the player character's script.
     
  11. Graveworm

    Graveworm It Wandered In From the Wastes

    112
    Mar 28, 2010
    for the player. also, after loading save with this putted on, PC disappear from the screen, becoming visible after changing to other armour and back
     
  12. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    The problem is either missing art files or a problem with the armor's proto file. I'll check this out and let you know next week (I have some real world stuff to deal with first).
     
  13. Graveworm

    Graveworm It Wandered In From the Wastes

    112
    Mar 28, 2010
    sure. real world first of all 8-)
     
  14. Prinygod

    Prinygod First time out of the vault

    14
    Aug 12, 2008
    i had used that one drug that increases your carry weight, so it may be a scripting problem with it. As for art cache, i understand it wouldnt have anything to do with klint, but what about primative village? What did you set yours too, i can set mine and see if it fixes it

    Also, to clarify, i needed to delete the art cache line to run plain fallout 2, as well as mods
     
  15. Graveworm

    Graveworm It Wandered In From the Wastes

    112
    Mar 28, 2010
    a couple of bugs:
    car sometimes disappears in wastelands when out of fuel
    car disappears when on city map force to go to some location using number keys (except 1)
    Gecko enclave encounter still bugged - too many soldiers, they appears one over other, and their quantity is growing with time very quickly
     
  16. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    Issues with the car have been resolved for the next release, thanks to Nirran.
    Pretty sure that I have the Gecko/Enclave soldiers issues resolved for the next release.

    Also, it always bothered me that EMP grenades never affected critters in power armors, including the player. That will change for the next release. So, if you are using those things, and you are in the blast zone, you aren't gonna like the results. That means I'll also have to give some upper level enemies some EMP grenades. Yes, this could be fun... :twisted:
     
  17. Panzerkampfwagen

    Panzerkampfwagen First time out of the vault

    65
    Feb 15, 2010
    Hello everyone,

    I have a problem with Megamod2.42 downloaded directly from nirran.com. When I'm trying to play the game by clicking fallout2.exe in game folder, an error appeares, that I'm trying to use sfall with wrong version of fallout. This is very strange, because I have that file from the downloaded mod. Anyway, if anyone has US 1.02 version of fallout2.exe, please upload it on mediafire and share link with me. This file from my game - polish dvd version - ain't working too. Thanks. (and sorry for my English)
     
  18. Ghouly89

    Ghouly89 It Wandered In From the Wastes

    188
    Jul 14, 2010
    You can find the download for version 1.02d (what you're looking for) under the files section of the website. Look under Fallout 2 --> Patches --> Fallout 2 Official US Patch v1.02. :salute:

    There are also versions of the same patch in other languages, so you can look for those.
     
  19. Panzerkampfwagen

    Panzerkampfwagen First time out of the vault

    65
    Feb 15, 2010
    Thanks Ghouly89, I must be blind.
    But, isn't it the AtomicGamer? Yeah, 5 minutes to download... then another 5 minutes... and another... and another... never ending story.

    ~~

    OK I've already find it.

    ~~

    But now I have same problem as mentioned here - http://www.nma-fallout.com/forum/viewtopic.php?t=54577&highlight=megamod and both re-installing and setting all proto files read only don't work.
     
  20. Overseer

    Overseer First time out of the vault

    47
    Mar 5, 2008
    Hi to all, i have installed fresh fallout 2, copied megamod 2.35 and megamod 2.4 and everything is working, but when i try to enter the temple of trials, something is bugged. The game still goes, but the screen is bugging, and everywhere i go it mess up the picture and graphic goes crazy. Any suggestions?