Megamod 2.43 technical issues and suggestions

Discussion in 'Fallout General Modding' started by MIB88, Dec 8, 2010.

  1. Legion

    Legion First time out of the vault

    Feb 26, 2011
    Bug update:
    1. New Reno exit grid - fixed in fresh install
    2.Bunker 21 still makes my car disappear upon enterin any location after leaving


    @Buletti and Mslavko82
    yeah, weight is a problem in Fallout, has been, will always be for me anyways. I'm a Packrat and the armor drop mod hasn't helped that one bit but a very simple solution to this is using F2se and set you carrying capacity to 999 pounds ( okay it's cheating but so is editing the weight of ammo ;-) besides this is much faster and easier^^)

    hmm I could outfit a small army with the stuff in my inventory....any modders around that want to make a "gear-up arroyo" mod so they can fend of the enclave instead of getting captured?^^
     
  2. Bulletti

    Bulletti First time out of the vault

    Mar 4, 2011
    Cannot enter V15 properly with car, didn't test walking yet.
    Gives a full black area with party members and trunk visible.

    Small location east of VC and Gecko - same thing, but without car.

    Will try a fresh install is problem persists.

    I would, but I'm anti-cheating oriented. I want to play ''as is'' with all the flaws and suggest features and impeovements, so others can also enjoy any ideas I get =)
     
  3. MSlavko82

    MSlavko82 First time out of the vault

    Sep 16, 2009
    Don't try fresh install, it will be the same. Map V15ENT.MAP is bugged, I saw the same, forgot about that. Included V15ENT version is from 3.8.2010, and it gives you only black screen, car trunk, party members and nothing more. Use map from previous version of MM (V15ENT from 27.5.2009), it is working correctly, here you go:

    http://rapidshare.com/files/451858988/V15ENT.MAP

    Just replace appropriate map in Data/Maps folder.

    Same thing is with location east of VC and some small location between SF and BOS Facility. I just don't know what should be there, so I didn't find out which map are problem...

    There is no need for that kind of cheating in MM, at least for now.
    Simply pick up two slaves in some random encounters (when you encounter slavers on the way, kill them and you get the option to free the slaves or capture them - when you talk to them) and you get 999 carry weight. You lose 80 karma for that, though. You can sell that slaves in Den, VC or NCR later for some money (50~150), but it is much better to keep them to carry stuff (they simply appear in your inventory as icons...).
    This kinda makes things too easy, and when creating character, you can simply take strength 4 and small frame - and never worry about carrying stuff, so it probably should be changed... Maybe only evil characters should be able to have slaves, and maybe only those who became slavers in Den - kinda makes sense. Also, maybe every slave should add 50 carrying capacity, or something like that - is is more realistic and better gameplay-wise...
     
  4. Bulletti

    Bulletti First time out of the vault

    Mar 4, 2011
    It's like the CoD series. You can't fix a problem by creating a new one. Weight issues HAVE to be taken into reconsideration, and having slaves as a good person doesn't really make sense, I agree.

    Have a slave or two - karma can't go above -250, so you'll STAY evil. Slaver's tattoo would also be a good idea. The weight was balanced in vanilla IMO - MM took fiddling with it too far, since you can that easily ignore carry limits for the rest of the game =/

    Thanks for the map!
     
  5. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    Are you sure about this? Not at all what is supposed to happen. Even if you took 100 slaves the maximum should only be an extra 200 pounds (and you should reach the maximum with 8 slaves). Can anyone else confirm this?

    Funny. You talk to 20 people, and there will be 20 different opinions as to what is/was balanced in the vanilla game or any other mod. Or, everyone has their own opinion about how much realism is/should be in the game, depending on what is convenient for them with their style of play. For example: people might whine that ammunition weighs too much because of the addition of the New Year/New Vision mod, but they forget the fact that they can carry 275 pounds on their backs all across the Wastes with no problem whatsoever. But I digress...

    The whole thing with being a freelance slaver was a work in progress. It was supposed to include specialized training, equipment, and/or perks and have its own set of consequences. I haven't finished with it.
    I do like the idea of the karma cap, though. Maybe not -250, but some type of cap. They don't have to be restricted to being evil. Hell, even Mad Max had a slave for a while, and he wasn't evil. :P
    No slaver tattoo, though. There was supposed to be a price for not being an actual Slaver (one of them, possibly being an enemy of the Slavers' Guild as well others).

    Also, for anybody keeping score: Klint has been completely rewritten. While he is no longer the tank that he was before, he is still quite formidable (on par with Sulik). He levels up like the other party NPCs (no longer with an armor change). All issues with saving/loading games with him have been resolved. He puts away his gear as told. And more. In short- he works perfectly now. Although I've included something to give him a little more life/backstory (learned in his dialog), this is something I'm still working to expand.

    Edit: Now that I think about it, I probably should tone down Klint's traits to make him a little weaker than Sulik. After all, Klint already gives the advantage of being able to heal the player.
    Now on to the Brotherhood Bunker...
     
  6. Bulletti

    Bulletti First time out of the vault

    Mar 4, 2011
    Decided to post this here...

    List of annoyances I've come across so far:
    - Maria, the vertibird girl. Typos in her dialog
    - Car in vanilla showed how much battery if left by binocularing it. No longer in MM.
    - Cassidy refused to equip any firearm at a time. All NPCs won't change armor to better, eg. combat armor to power armor. Need to remove combat armor, take it, and then try again.
    - Vic, at his highest level, has repair skill the second highest, as opposed to best skill.
    - With power armor, Cassidy's best skill becomes Unarmed.
    - Skynet's main terminal at Sierra is typo-ridden. I have this file fixed.
    - At Bunker 21, there are two or three soldiers in leather armor with stealable dog tags. They are all Dickinsons. Are they related, or is this an oversight?
    - Raymond at X location is typo-ridden.
    - Siege's script is typo-ridden, and unsuitable style of language for Fallout, and for the Enclave and BOS.
    - Baby, the AI at BOS bunker is typo-ridden
    - Major Burke's scripts are bad, as said in the PM to you. He also has typos and grammar issues.
    - The warehouseman is also bugged at BOS bunker.
    - Gen. Burton, too.
    - BOS non-combat members are labeled as clerks. Shouldn't they be scribes?
    - There are multiple elders. BOS only has one traditionally.
    - All paladins, ''clerks'' and knights are missing the ''You see: X...'' text, instead showing only ''Paladin''.
    - The Marshal is also typo and bug ridden.
    - The holodisk quest for BOS is also bugged, as it repeats itself, reverting back to ''not delivered''.
    - Only once could I see the dialog option ''sent by Matt'' when talking to Maj. Burke.
    - All humanoid NPCs with power armor of any type are able to use any weapon class. Sulik prefers to use a plasma rifle, and due to low actual skill, misses 75% of his shots. Vic also likes it, but due to high EW skill, he's not half bad. Cassidy still switched to his gauss pistol when using the option to have them use extra APs.
    - Couldn't get Marcus to show his new armor, nor did I see any inven art for it. He apparently still had it on, and seemed to be on par with adv. power armor. Tested with gaussrifle and plasma grenades. Consistency remained. Criticals still were lethal.
     
  7. MSlavko82

    MSlavko82 First time out of the vault

    Sep 16, 2009
    Absolutely sure. But that explains a lot. I remember, when I took one slave, that it didn't add to my carry weight at all. However, once I took second slave, I instantly have carry weight 999. Actually, I get 50 PackRat perks immidiately. I just checked it, it's how it works. But, I have Nirran custom perks installed, so maybe somebody without them should double-check, maybe there is conflict (doubt it though, Nirran customized his mod specially for MM).

    Here is savegame, if it is any useful to you: http://rapidshare.com/files/452936296/SLOT02.rar

    Anyway, 8 slaves - 200 carry weight ~ that would be just right :))) Well, I should assume it is a bug, not a feature... me dumb :(
     
  8. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    Thanks, Bulletti, for the bug reports. When I have some time Friday I will address each of those.

    @MSlavko82: Every 2 slaves is supposed to provide one level of Strongback. After those three levels are obtained, then two more slaves are supposed to give the Packrat perk. Thanks for the savegame. I have never seen that before. I know it worked right at one time. However, it is entirely possible that I messed something up while changing/fixing/upgrading the obj_dude.int script.

    And yes, definitely a bug you are experiencing.

    Edit: Just tried it out. I don't get the same error you've gotten, but there is a problem. Took 2 slaves, and I got one level of Strongback. Took four slaves and got three levels instead of only two. I briefly looked at the script again, and it looks fine. I haven't changed it from when it was working. Very odd.
     
  9. thir

    thir First time out of the vault

    Mar 27, 2011
    Sorry for repost of http://www.nma-fallout.com/forum/viewtopic.php?t=58208 i just noticed this thread and could find a delete button, anyway my question are:


    The installation instructions are a little vague...

    What i did is:
    1. Install fresh copy of FO2
    2. Install MIB88 version 2.43 (although in the install it says its 2.42 and after the next 2.44).
    3. ??? (it says to run runme.bat but there is no such file)

    that's it or i skipped a few steps?


    also how do i change the game resolution, I found that ddraw.ini and f2_res.ini contains resolution setting but they dont seem to effect anything :/

    My screen resolution is 1280x800, so i assume i'll have to use 1024x768, right?
     
  10. thir

    thir First time out of the vault

    Mar 27, 2011
    Ok here is the basics of hot fix:
    1.
    2.
    3.

    EDIT:
    4. you need to copy the misplaced hs_tohit.int file from "add this for a challenge" folder to the script folder (what is if you want to use brust)



    anything else? and i would love some help with my previous question regarding resolution.
     
  11. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    There is nothing else that you need to do to get the mod working, but keep in mind these two things:

    1. Don't change Klint's armor while on a map, save the game on that same map, and then exit the game. If you do, that game will fail to load. If you change Klint's armor, be sure to go to another map before saving the game. I have completely rewritten Klint, so this will not be a problem in the next patch/update.

    2. Expect issues with the Brotherhood of Steel Bunker and associated quests/locations. There are a number of bugs there I need to correct.

    Regarding the resolution, I never adjust the settings. You would probably find some useful information in the thread specifically devoted to the resolution mod or earlier in this thread.

    Regarding the bug list from Bulletti:
    Most of those are just plain bugs. I know, I know: I meant to comment on these a while back, but work actually took me out of town, and has kept me (and still keeps me) from doing any modding.

    I corrected her dialog.

    I am aware of this. We tried to find a way to fix it, but couldn't find a solution. This was something hardcoded for the original car. The presence of the paint job mod created by Nirran causes the problem with not seeing the charge left on the car. Small price to pay for the mod, though, especially since a rough graphical representation of the car's charge appears on the worldmap screen.

    This doesn't make sense to me. I mean, I can't think of a reason for this.

    I haven't changed Vic's stats at all, which means this is a vanilla bug. Or, rather, it would be if his highest level was available in the vanilla version. I'll take a look at this and adjust if necessary.

    What is it supposed to be? And, why should it necessarily change? I mean, the same thing could happen to the player character, in that wearing power armor could make unarmed your best skill when it was something else before.

    You can e-mail any fixed dialogs to me, and I'll be sure to include them in the next release.

    Not an oversight, it just wasn't a big deal to me originally when I was working on that mod. I only used the inventory items available. However, I can easily create three or more original dog tags.

    I'm sorry, but could you be more specific about who this person is?

    I don't think I even opened up that dialog file. However, I'll take a look at it and adjust as necessary.

    I'll look at it, if you haven't already done so.

    Yes, I still have that pm.

    Bugged how? Or, do you just mean the dialog is messed up?

    Again, in what way?

    Perhaps. However, 80 years have passed. Who's to say there can't be a change in how they are organized? I'm not saying I wouldn't change it. I'm just saying, it doesn't necessarily have to be the way it was in Fallout 1.

    Same as above.

    Try to remember back: Is it just this location? Or is it all new locations (and therefore, all new critters)?

    I'll take a look at his dialog.

    What do you do causing it to revert back to being uncompleted? Or, do you mean it never gets crossed off?

    Do you remember what you did differently?

    Ok, you are saying something completely contradictory here. You say Sulik prefers to use a certain weapon, despite his low skill. Then you say Cassidy prefers to use that same weapon because of his high skill. It can't be both! Or, the weapon could be chosen regardless of skill level.
    What is the artwork when they have these weapons? Are they custom? I mean, are the graphics those created by Josan and Jotisz? Or are the graphics the standard animations for people in armor? If it is the former, then the weapons they are using, I assume, are weapons they are originally allowed to use. Those two did not create artwork for party NPCs if they were not originally supposed to use those weapons... at least, that is what I thought was their intent.
    If the artwork is the general artwork, then, well, I'll get around to fixing it when I am REALLY bored. Here's why: it would mean copying most of the art files multiple times to account for each party NPC, making sure to remove the artwork for weapons they can't use, and giving them new names to make them character specific. It is extremely tedious.

    There is no inventory art for it. Marcus's graphics are supposed to change. I don't think it is on par with advanced power armor. It gives him a little added protection in the form of several perks. But, I received another report suggesting that that feature of the mod is not working.
     
  12. thir

    thir First time out of the vault

    Mar 27, 2011
    and the rest od the scripts what do they change?

    GL_Replace_Books
    hs_afterhitroll
    hs_combatdamage
     
  13. thir

    thir First time out of the vault

    Mar 27, 2011
    klint, when he blocks my way and i try to move him a side, in 90% of the time he stutters and stays in place.


    after i got my car stolen, finished the dialog in the chop shop as mademan, upgraded my car and got back to new reno i found out that my trunk is empty... including shit load of ammo and few quest items like the laughing gas for Salvatore i got in Modoc.

    anyway to fix it or save edit that quest item back? otherwise i'll just have todo with the sweet revenge of wiping them all out.
     
  14. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    One replaces the books... one of Nirran's mods. The others make combat more challenging (also Nirran's work).

    I've never seen an issue like this before with Klint. However, as I've said a couple of times already: I have completely rewritten Klint, so, any issues you might experience now will not be present in the next release.

    I've never seen this error before. I'll work with Nirran on this issue, though. You might want to try a previous save... or an editor. Your choice.
     
  15. thir

    thir First time out of the vault

    Mar 27, 2011
    I dont have a previous save available. what is the most compilable save editor with mib88? (I downloaded the most recent one i found in the download section. )

    I dont care about most items but i want to add the laughing gas and the verti bird blackbox, since those are quest items, from new quests i have never played before, but i cant seem to find them in the really long list :(

    if anyone have them in one of his saves, it''s will be very appreciated if you can paste its id in misc items (something like 41-941 )


    EDIT:
    when you go upstairs with mrs bishop, klint comes along. (either he the type who likes to watch or she got to tribal's for the price of one)

    Mess the cow, can help you out in the ring, if you stand near the ropes, she will bite.

    Any chance that one of them responsible for critical hits? because i didnt caused anyone to go blind, fall unconscious, fall in pain, etc... even thou i was aiming at the head/eye/groin, in fact normal shooting seems far more effective so far (thou its possible that my stats aint good enough yet)
     
  16. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    I think Falche works... the first one, not the later version.

    Open up the Fallout2/data/text/Englsh/game folder. There is a file called pro_item.msg. Open it with a text editor like Notepad. You can see all the items there. All new items from mods are after 540 ({54000}) or so.

    I'll fix the issues with those Reno scripts regarding placement of party NPCs.

    Nirran is the best one to answer the issue regarding what files do what.
     
  17. thir

    thir First time out of the vault

    Mar 27, 2011
    I had some connectivity problem. so, I couldn't post bugs before, here is what I remember:

    * The abbey: the map seems unfinished(endless floor to the right) and if the location of GECK is the only quest there, it will be such a shame.
    * Gecko: Vertibird assault team, has dialog glitch, if you choose the 'i am just a dumb tribal, how could I hack into it' path, they start move out but then the dialouge restarts like nothing happened.
    * Vault city, court yard: the cage door is always opened. the only time it closes is after the distracted guards return and ask who opened it)
    * New reno: Upon receiving Salvatore second mission, to shake up rocketmen for 1000, the option never shows up in his dialog (either that or i fucked up something)
    *Cold Hearts, there seem to be some kind of 1+1 barging for quests, for every quest I receive through dialog, my pipboy updates one extra.
    I got 'Gain the allegiance of Metzger' with 'laughing gas' and 'Scout basement in New Reno' with either 'Jimmy the Screw' or 'Tubby tribute money'


    * Broken hills, residential area: maybe its just my imagination but it seem to lag... and there is a dinamite there with wired description..


    * you may want to check the burst script, because at some point i became extremely lucky, with every burst a critical even with 18% hit chance, half room away and a guy in combat armor its was a one shot kill :? I wiped the VC raider base like nothing, its must be the easiest fight I had so far.
    * I had some wired results with scoped weapons, hit chance. getting a lower chance of hitting a target with my sniper rifle than my shotgun :?


    I never had this problem with anyone but, klint who refuse to remove armor/weapon and likes his tesla armor.


    thanks
    561 Laughing Gas
    758 Black Box



    Edited.
     
  18. hrona

    hrona First time out of the vault

    Apr 2, 2011
    I had some problems with this Mod so i though i will post them with how it got fixed:

    1: Kick to windows after trying to enter Temple
    Fix: Creating new character helped, some random bug?

    2: No ants and "Error" phrases in dialog:

    Fix: because i changed installation folder of Fallout 2, but i only uninstaled it with Fallout2 uninstaler this crap occurred. Use Total uninstal to remove Fallout2, Megamod and all registry entries of those two. Make clean instal.

    3: I went as far as to "The Rat Tunnels" and when i try to load my Save i get Application Error and game crashes.
    Any idea?
    Fix: Found on this thread that file "obj_dude.int" is responsible for it. Would be nice to fix it in download, coz i got the mod today and error is few days old.
    And more importantly anyone got that file from 2.42 version of mod? Cant find it anywhere... :(
     
  19. MSlavko82

    MSlavko82 First time out of the vault

    Sep 16, 2009
    For editing savegames, use F2SE. It is working perfectly and it is easier to use than FALCHE...

    @Thir:
    You don't get criticals from aimed shots any more, it is bug, also connected with:
    Obviously, you shoudn't be able to do that, it is also bug.

    First, check if you have HS_Tohit.int script in your data/scripst folder. It is neccessary to make burst shots normal again. If you don't have it, download Custom Perks mod from Nirran.com (it is not in Megamod part, it is in "Scripts / Mods I wrote for Fallout 2" part. You can install whole mod, or, if you don't want, just copy all HS_xxx.int scripts from mod to your F2 Data/Scripts folder.

    Second part is missing criticals. Problem with them is that Nirran in his mods (which are partially part of Megamod, but some files missing) changed critical values in damage.ini file. However, I think he is playing melee and didn't actually playtest it enough - he reduced (drastically) your aimed critical chance - so you never (or very rarely, even with sniper perk) get critical from aimed shots and cripple enemies etc - read page 8 disscussion. Replace your damage.ini file with this:
    http://rapidshare.com/files/455675703/Damage.ini
    That is edited damage.ini file I use, I change values for criticals from negative to positive (it shouldn't work like that, negatives should be, but negatives don't work, and positive work - playtested for 30~40 hours of gaming). Anyway, voila - you have normal criticals, normal damage and normal critical chance :D Cheers!

    @hrona:
    http://rapidshare.com/files/455676924/Obj_dude.int
    http://rapidshare.com/files/455676961/fcdrfung.int
    Download both and replace appropriate scripts :wink:

    Download map V15, you will need it:
    http://rapidshare.com/files/451858988/V15ENT.MAP
    Just replace map in Data/Maps with this file - don't be confused, it is older file, but it is wokring - newer file is bugged...

    Also, do the same thing as Thir to repair combat damage and critical chance :mrgreen:
     
  20. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    @MSlavko82: Seriously- thank you very much for answering all those.