Megamod 2.44 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Jun 22, 2011.

Thread Status:
Not open for further replies.
  1. Panzerkampfwagen

    Panzerkampfwagen First time out of the vault

    65
    Feb 15, 2010
    Hello, I'm just installed Megamod 2.44 windows installer + Hi-res patch, and I encountered some bugs just in the beginning.

    1) They aren't any ants in the Temple - I think they were some ants in previous versions of Megamod?

    2) I can open the doors in the temple on level 1 without using anything.

    3) Jordan's dialogue contains only "error" messages (so I didn't passed his trial and had to steal the key)...

    4) ... after dialogue with Elder, appears another dialogue about Jordan and problems with his trial, and this dialogue appears every time I finished it, so I cannot play more (pushing "0", etc do nothing).
     
  2. IAR80

    IAR80 First time out of the vault

    88
    Oct 1, 2006
    Hi MIB88 remember me? Still problem with the mod I see. Well, I have one myself. My VISTA show me this message when the game crash: (sorry is partially in Romanian language)

    Semnătură problemă:
    Name of the problem event: APPCRASH
    Application name: fallout2.exe
    Application version: 0.0.0.0
    Marcaj temporal aplicație: 3671bf22
    Bad module name: DDRAW.DLL
    Bad module version: 2.13.2.0
    Marcaj temporal modul defect: 4dc98e0a
    Cod excepție: c0000005
    Deplasare excepție: 0004e909
    Versiune OS: 6.0.6002.2.2.0.256.1
    ID setări regionale: 1048
    Informații suplimentare 1: fd00
    Informații suplimentare 2: ea6f5fe8924aaa756324d57f87834160
    Informații suplimentare 3: fd00
    Informații suplimentare 4: ea6f5fe8924aaa756324d57f87834160

    This error appear when I load a game, not all the time, more like 50% of the time. Sorry if it was reported.
    Also I have installed (Nirran) megamod 244 (clean install) and the error appear mostly after I finish a combat.

    Best Regards.
     
  3. xenite

    xenite First time out of the vault

    2
    Sep 8, 2011
    Hi,

    I just installed the Fallout 2 + the megamod 2.44, does this mod have armor loot and the npc change appearing according to the armor they wearing?
    I read the wiki page about the skill that need to loot armor but when i kill the raider, no armor is found on their body.
     
  4. thetjester

    thetjester First time out of the vault

    1
    Sep 13, 2011
    Hello

    Ive been playing through for quite a while and now my armor class is 000 even when i put armor on, is there any way to fix this?
     
  5. Artson

    Artson First time out of the vault

    1
    Sep 13, 2011
    I'm also experiencing the armor class problem.

    I'm using megamod 2.44 with a humungous install and I have Hi resolution patch 3.02 installed. I also have the obj_dude script provided on one of the first two pages.

    I'm not sure but it most likely started before I installed the hi res mod. It has been a steady decline from 20+ to 12. I have a save(during combat) that when I load makes me have either 12, 14 or 6 armor class. This number changes when I load the that save again. Also when I load and my the armor class is anything but 12 the screen has flickering white or yellow checkerboard pattern(this glitch appeared before the hi res mod).

    This checkerboard pattern appears occasionally upon loading a save or moving between maps.
     
  6. IAR80

    IAR80 First time out of the vault

    88
    Oct 1, 2006
    From what I saw the problem with crash on loading is happening when you save in combat. It will corrupt the save game. Still, after I clean the save up, the error remain. This time will appear after third or fourth time when you load the same save and occasionally moving between maps.

    Best Regards.
     
  7. dust'n'rust

    dust'n'rust First time out of the vault

    1
    Sep 19, 2011
    Hi, I'm new here.
    Recently i started playing F2 again with the megamod 2.44, and I must admit, that it really makes me wanna play this game again :) Only thing is, that i'm experiencing some bugs too, most of 'em already fixed by patches posted in this thread. But, as I can see, the armor class bug isn't only my problem and its even notoriously haunting all of us, mod-players. So, guys, keep up the good work and we're waiting for the ac-problem cure :clap:
     
  8. bozar_bullet

    bozar_bullet First time out of the vault

    16
    Jul 20, 2011
    So the main recent bugs of 2.44MM are:

    AC problem
    BOS bunker
    Marcus' armor


    Is there a chance that there will be fixes for these, or will there be a completely new version of MM with previous saves unbale to work?
     
  9. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Sorry for the long delay in posting again. Nirran has actually been doing a lot of work on the MM while I was away due to real world issues and a blown up computer. So, to answer the last post, a new version will be coming out. Marcus has been fixed. The BoS Bunker has been fixed. Most of the fixes/changes would not render previously saved games unloadable. However, one of the files changed was the party.txt file, so, a new game would have to be started upon installation. The change in the file allows for a new party member, someone that many were asking for. You can decide for yourselves whether or not having him join your party is worth having to start over. :P
     
  10. Elitech

    Elitech Still Mildly Glowing

    282
    Apr 22, 2008
    Any idea when this new & improved version of Megamod will be available?
     
  11. LordSchmee

    LordSchmee First time out of the vault

    2
    Oct 9, 2011
    Hey, I've had 2 problems so far:
    1. Dunno if this was a fix or what, but originally I could talk to Matt and get the Vertibird quest at like Lv1... went down earlier and he said I wasn't experienced enough.
    Tried again a few levels higher and again he said I was too inexperienced... do I need a certain level or stat?

    2. I can't find Fassard. I know he's supposed to be in the bar at BH, but he's not. I also had the problem where I couldn't load the BH map, and deleted the map file in order to get it working, but now Fassard is gone... Not sure if deleting the map file was the problem or not, wouldn't think it'd be?
    And yeah, I definitely have the "find pilot Fassard" quest, I checked.

    Any way to fix this, or hax the Pilot perk? I'd rather not have to but if it's the only way...
     
  12. recore

    recore First time out of the vault

    3
    Oct 8, 2011
    A pleasant day to everyone!
    I was able to play megamod 2.44 before, got a few characters and finished it a lot of times since my computer was low on memory I tried to delete some files then I accidentally deleted all fallout 2 folder/files including the installer for megamod 2.44. So I decided to install it again and downloaded the megamod from nirrans website, it was then that I have encountered this problem: I am unable to proceed to a screen where you can select "New game, Load game, etc.." right after the cenimatic. It just goes black and when I look into the tast manager it says not responding so I decided to terminate it.
    Heres what I tried:
    1. Tried reinstalling and redownloading the megamod 2.44
    2. Reinstalled it to a different location
    3. Restarted my computer
    4. Deleted the patch.XXX file and data folder from main directory
    5. Tried to install the mod with and with out deleting the data folder
    However, I am still encountering the problem( I am able to play fallout 2 (v1.02d) before installing megamod)
    Maybe it has something to do with the .ini files or something? If so, can someone orient me on what to do? Thanks in advance!
    I would like to thank MIB88 for creating this great mod, and nirran for being an advocate and a great help in fixing bugs and helping us players. God bless you guys always. Words are not enough to describe our appreciation for you guys..^_^
     
  13. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
  14. recore

    recore First time out of the vault

    3
    Oct 8, 2011
    I appreciate your quick reply dude, checked my current directx using dxdiag and it shows 9.0c and my master.dat file size is 325,374KB. I guess its not the issue? I do not get any error message, it just turns black after the cenematic thus I cannot access or see the game's main menu in order for me to start a game which I was able to do so before reinstalling it. I am really thankful for the effort
     
  15. LordSchmee

    LordSchmee First time out of the vault

    2
    Oct 9, 2011
    Following on from the bugs I had before, I now find it impossible to access certain save files. I think this started ever since I acquired the Vertibird. I start the save, get a pop up about memory being unable to be read or something, then if I click OK the game crashes anyway and I have to end the process through Task Manager.

    Any way to patch this? It makes the game impossible to play otherwise. ><

    EDIT: Ah, never mind, found a fix on page 2 or something. Any chance you could add all the fixes/problems to the first post? Would make it a lot easier to keep track of stuff, I think. Just a suggestion. ^^
     
  16. recore

    recore First time out of the vault

    3
    Oct 8, 2011
    LoL..About my problem, its not really a problem since I just needed to defrag my system and it worked. Apologies everyone.XD
     
  17. Flytag

    Flytag First time out of the vault

    2
    Oct 11, 2011
    Awesome! Looking forwards to the next release! Another NPC Companion! :)

    If anyone is having problems with a familiar set up (Megamod Plus Hi Resolution Patch) Here's the steps I followed which should get you there in Windows XP with an ATI video card.
    [spoiler:91983a5fa0]
    -Install Fallout 2 ->Full Install
    -Patch Fallout 2 -> 1.02d official update
    -Install MM 2.44 Manually [Extract to ..//Fallout2]
    -[Checkpoint:..//Fallout2/proto/CRITTERS/ <fourty> *.pro files exists
    -Run ../Fallout2/ProcessDat2.exe
    -[Checkpoint: <all> *.pro files in ..//Fallout2/data/proto/critters should be 416 bytes a piece]
    -set to Read-Only ..//Fallout2/data/proto/critters/*.pro files
    -set to Read-Only ..//Fallout2/data/proto/items/*.pro files
    -Rename ..//Fallout2/PATCH000.dat to ~PATCH000.dat
    -Update ..//Fallout2/data/scripts/obj_dude.int 6/17/2011 -> OBJ_DUDE.int 10/11/2011
    -Install Fallout 2 Hi Resolution Patch 3.0.2
    -Update ..//Fallout2/ddraw.dll [sfall2.13] -> ddraw.dll [sfall 2.16]
    -OpenFile/Ensure ..//Fallout2/ddraw.ini -> [GRAPHICS] Mode=4 or 5
    -OpenFile/Addlines ..//Fallout2/ddraw.ini -> in [MAIN] add lines
    ExtraCRC=0xe348e17f
    ExtraCRC=0xed141a65
    -Download Vert_Fix.rar [from NMA forums] and update ..//Fallout2/data/scripts/*.int contained within
    -Download small_roach.rar [from NMA forums] and update ..//Fallout2/data/art/*.*
    -Download Lenny Fix.rar [from NMA forums] and update ..//Fallout2/data/scripts/*.*
    -Rename ../Fallout2/data/scripts/GL_Test.int -> ~GL_Test.int
    -Downloaded and replaced ../Fallout2/data/scripts/b21.int <- b21.int [from NMA forums]
    -Downloaded and Replaced ../Fallout2/data/scripts/WCBRNBOT.int <- WCBRNBOT.int [from NMA forums]
    [/spoiler:91983a5fa0]
    I ran into many of Vrede's problems trying to get everything running smooth and stable.

    all NPC AC seems stable - Miria and Vic levels up correctly. Robot Sentry Combat Controls appear as uncorresponding but Robot Sentry still works as intended.

    Only a few crucial things I've been finding out recently that I haven't found on the forums yet.

    -Dialogue errors on Speaking to BOS NPC Barton
    -sfall 2.13b - Dialogue works but app crashes upon trying to end dialogue OR has no dialogue with one option 'go on' with it ending dialogue window (no crash)
    -sfall 2.16a - app doesn't crash but dialogue window opens and closes immediately

    -BOS Steel Mission seems to have a loopable mission with Steele
    -Bunker Monster fight got skipped (WIP AFAIK)

    -Lenny to human quest seems to have a loop quest. Dialogue option to discuss offering him to become human again doesn't go away after his sprite successfully changes. It seems to reactivate the trigger clause in which you just need to hit the final switch on the computer for the 9000 xp reward. Sprite is otherwise now stable with lenny fix. (does removing the GL_Test.int script file in Lenny Fix.rar resolve this for the moment?)

    -car trunk and body of car have inconsistent sprites (e.g. Ghost Town, car front is clean, car trunk is rusted sprite). Car body mouseover 'look' doesn't show power remaining.

    -I can convince Chris at Navarro Gas Station that my NPC companions are guards, but when I get to Navarro entrance, I can't 'sheepshead' my way in first time. If I go through the other dialogue options, the password option is offered upon second time talking to guard. Yet after I choose sheepshead for the 'dialogue clearance' I still get attacked if I try to walk inside... So basically I just massacred and haven't tested the Vertibird... I waited but I guess I didn't wait long enough or didn't see it land?

    It's a lot of fun; thanks to the modders for bringing together such a charming mod for the community!
     
  18. Drobovik

    Drobovik Vault Archivarius Modder

    417
    Jun 20, 2011
    Hello, where can I get OBJ_DUDE.int 10/11/2011? I didn't see a link for it. Thanks
     
  19. Flytag

    Flytag First time out of the vault

    2
    Oct 11, 2011
    since this is the megamod 2.44 bug discussion thread anything mentioned in my hidden notes refers to something I found within this thread. Hope that helps.
     
  20. yoteamo

    yoteamo First time out of the vault

    1
    Oct 21, 2011
    I cannot launch Megamod

    Hi,
    I cannot find any information about my bug. Windows XP professional x64 SP2, Fallout US 1.0 + 1.02d patch US + Megamod 2.44. When i launch the game, i see the screen flash and then my desktop. Once i saw the beginning of video, but then desktop again. When i deleted ddraw.dll, game launched. I've tried VirtualBox - same effect. I've changed through all modes in ddraw.ini and nothing happens. I spend all day to find solution. My english is rather poor, i know, i am russian.
    salviomanuel@yandex.ru
     
Thread Status:
Not open for further replies.