Megamod 2.44 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Jun 22, 2011.

Thread Status:
Not open for further replies.
  1. VictorTadeu

    VictorTadeu First time out of the vault

    1
    Oct 22, 2011
    Hey, guys, I'm having a problem to sharp my spear in arroyo! I should get the flint from my aunt, right? But there is nothing like that when I talk with her! I aleady talked with the hunter and the sharpened spear guy, but nothing! The only conversation option I hav with my aunt is "You are just an old crabbed hag. I'm leaving". Nothing in barter and nothing to steal...

    Any help?
     
  2. brazybg

    brazybg First time out of the vault

    1
    Oct 23, 2011
    hey guys. great mod but after doing everything in the instructions i still cannot save. any help would be greatly appriciated. thanks
     
  3. Gambigobilla

    Gambigobilla First time out of the vault

    1
    Dec 2, 2011
    I have a problem in EPA. When i enter only my character and car trunk is visible (not even car itself!) everything else is black. Mouse and items console shows too. Saving in this situation creates a corrupted save game which cannot be loaded.

    I tried reinstalling from both single click installer and zipped version. the problem still continues.

    i goggled for help and it seems same problem occurs in restoration project mod. It can be simply corrected by installing hi-res patch. So I tried installing hi-res patch just to fail again.

    Is it something about map edge data (the edg files)? Hi-Res readme file doesn't say where to copy them. So i copied them \fallout2\data\maps\folder , \fallout2\f2_res\ , \fallout2\f2_res\map_edges\ and \fallout2\f2_res\maps folder (yeah, both four places!!!) again i failed.

    If you can help me how to correct this i really appriciate.
    I can send save games in and before epa if needed.

    Thanks in advance.
     
  4. Prosatanos

    Prosatanos It Wandered In From the Wastes

    177
    Oct 25, 2011
    If angering your aunt she won't give you a flint.You are on the start of the game ,start new one. Try . I think this is the your problem.
    Don't forget to say what's going on.
     
  5. ghussack

    ghussack First time out of the vault

    2
    Dec 3, 2011
    the moment the game starts/loads I get this error
    "Weather mod error: could not load default shaders"
    is there something I can do to make it load?

    EDIT: it is a fresh install of megamod 2.44
    EDIT: where can I find the sources for the script gltsrain.int to understand what is happening? (that message comes from it..)
    EDIT: oh I see that you are making fixes for 2.44, I wonder if there is a place where all these fixes could be found toguether? thx! for now I think on going on each of this thread page for the links, but an ftp or something would be great !
     
  6. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    I've got this error while running sfall in 8-bit graphics mode. Make sure you are using DirectX mode instead.
     
  7. ghussack

    ghussack First time out of the vault

    2
    Dec 3, 2011
    the current error for 8bit is: "shader functions not available"

    I am using in ddraw.ini
    Mode=4 ;Set to 4 for dx9 fullscreen
    I tried also =5 to no avail.

    if I could read what throws that "could not load" error out, I could guess what is wrong, but I cant find the source for gltsrain.int, neither a way to decompile.

    I think all required files are in the right path as I just installed megamod, so I run out of guesses :(

    any more tips? thx !

    EDIT: oh ok, I managed to get some error log, btw it is on linux :D ... :/
    Code:
    fixme:d3dcompiler:D3DCompile data 0x274f7b0, data_size 727, filename "data\\shaders\\weather\\rain-def.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274f7b0, data_size 721, filename "data\\shaders\\weather\\snow-def.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274f7b0, data_size 754, filename "data\\shaders\\weather\\sand-def.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274f7b0, data_size 710, filename "data\\shaders\\weather\\rain-esc.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274e178, data_size 658, filename "data\\shaders\\weather\\snow-esc.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274f7b0, data_size 691, filename "data\\shaders\\weather\\sand-esc.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274f7b0, data_size 710, filename "data\\shaders\\weather\\rain-inv.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274e178, data_size 658, filename "data\\shaders\\weather\\snow-inv.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274f7b0, data_size 691, filename "data\\shaders\\weather\\sand-inv.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274f7b0, data_size 710, filename "data\\shaders\\weather\\rain-map.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274e178, data_size 658, filename "data\\shaders\\weather\\snow-map.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274f7b0, data_size 691, filename "data\\shaders\\weather\\sand-map.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274f7b0, data_size 710, filename "data\\shaders\\weather\\rain-skd.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274e178, data_size 658, filename "data\\shaders\\weather\\snow-skd.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    fixme:d3dcompiler:D3DCompile data 0x274f7b0, data_size 691, filename "data\\shaders\\weather\\sand-skd.fx", defines (nil), include 0x32f35c, entrypoint (null),
    target "__fx_2_0__", sflags 0, eflags 0, shader 0x274e0f0, error_messages 0x32f570 stub!
    
    I will play with the the shaders files and see what happens :/
     
  8. zaopatrzeniowiec

    zaopatrzeniowiec First time out of the vault

    41
    Dec 1, 2011
    Hi. I have version 2.44 of megamod installed on 1.2 Fallout 2. I cant play game and dont know why. Every time I enter the temple the game goes black and there appears error sound.
    Also when game starst there is information about not working shaders of weather and when I`m turning on ProcessDat2 like readmme suggested there is information about Dat Replace.txt not found. I am instaling sfall 2.16 after megamod because without this it sloowing down too about 20% of oryginal speed. Also one on couple reinstals there apear something like sand storm. I suppose this is that weather shader? Can I somehow turn of this crap? Im playing on Xp pro sp3.
    What should I do? Is this mod working anyway or just have couple additionals locations and 100 000 000 bugs?
     
  9. nad02s

    nad02s It Wandered In From the Wastes

    125
    Jan 31, 2008
    Hi, it seems to be that time of year again, so I'm playing through Megamod again ;)

    This is on win7 x64 with megamod 2.44 and some of Nirran's compatible scripts thrown in.

    I've just repaired the Gecko plant for Vault city, so here is a list of all the serious-ish bugs I have found up until this point:

    1: Ran into the same problems reported earlier to do with failing to load a save after entering Klamath sewer, or Klamath west side. Fixed by using older Dude-int script.

    2: Several problems with AC and Perception all I believe caused by the weather mod. Only fix I have found is to reload to a point before problems occur and remove weather. (Also reported further up).
    It was odd though, it was raising my Perception to silly amounts and reducing my AC. My char has 9 Per, the scripts were giving him an extra +3 and -12 AC or something similar.

    3: Swift learner perk does not appear to work. The only messages I have seen are always : "you earn 0xp from the Swift Learner perk"

    4: Klint went unresponsive, I only noticed this just before Vault city, but not sure exactly when it occured.
    He remained in my party and followed me from area to area, but would not follow me within an area and would not allow me to enter any menus to control him.
    When talking he would only respond with floating text saying something like: "Welcome back chosen one".
    So I shot him in the back and recruited Cassidy ;)
    *For some reason I got the feeling this may have been caused by overloading him.

    5: I found some Environmental armour because of the random loot script quite early on. Anyway I noticed that when I saved the game while wearing it my character would disappear. I would have to remove and re-equip the armour to re-appear and be able to move again.

    I'm really loving the random items script btw :) I reduced the chances of getting anything worthwhile though, just so that when you do, its that much more rewarding.

    This is not really a bug, but I seem to remember in previous versions Cassidy had a better graphic for leather jacket or no armour, IIRC it was the Evil cassidy graphic. In this current version he looks like a regular leather dude with leather jacket on, with no armour on he looks like a farmer/peasant both with hair.
    Maybe I got that confused with another mod though, perhaps the RP. Its been a while since I last played.

    Anyway I can't really recall any other bad bugs, just minor Fallout bugs.

    So thanks a lot MIB for never giving up on this beast of a project. And Nirran, some thanks your way too for helping MIB with the task.

    Cheers.
    Dan.
     
  10. Vault15

    Vault15 First time out of the vault

    8
    Dec 31, 2011
    Megamod 2.44 Savegame Crash *FIX*

    Please spread this fix around as much as possible

    The modding team actually released a new MM 2.44 obj_dude.int file, but since it was so hard to find I figured I'd leave a couple of links to it (replacing the 2.44 original file with this one fixed ALL saving issues):

    The file to replace can be found in Fallout 2/data/scripts/

    http://www.mediafire.com/?pe22ycpb666j696

    (Backup)
    http://www.sendspace.com/file/80quue


    If anyone knows how to fix the Armor Class glitch (always at 0) please respond. I have a feeling that I can replace a file from an old version of the megamod and it'll fix.


    .
     
  11. nad02s

    nad02s It Wandered In From the Wastes

    125
    Jan 31, 2008
    As I mentioned in the post above yours, to fix the 0AC bug you must revert to a save before this happened and remove the weather.ini file.
    Annoying though if your quite a way into the game.

    If you knew exactly which script was responsible you might just be able to remove it and continue, but I have no idea which one it might be.
     
  12. Vault15

    Vault15 First time out of the vault

    8
    Dec 31, 2011

    Oh, I wasn't ignoring your post. Sorry, I should have mentioned that I deleted the weather.ini file from the very beginning since I didn't care for the effects on screen. I was hoping that an old megamod .ini or script file could fix the new one (if this is the case like the obj_dude.int replace). I will keep seeing if I can find the answer since my character is pretty far in the mod now. Worst case scenerio I beat the game with 0 armor class Lol. Hey, I don't mind a challenge...
     
  13. nad02s

    nad02s It Wandered In From the Wastes

    125
    Jan 31, 2008
    Oh so you actually deleted the weather.ini before this even happened?

    Oh bugger. Maybe I'll end up with it on this play-through too, its already my second start.

    Hehe, yeah I suppose levelling up like a mother.... could off-set that penalty :)
     
  14. Z?

    Z? First time out of the vault

    5
    Jan 5, 2012
    The game crashes whenever I arrive in Broken Hills. Anything to fix that?
     
  15. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    If you are going to disable the Weather mod, gltsrain.int script (DATA/SCRIPT) should be renamed/removed as well.
     
  16. nad02s

    nad02s It Wandered In From the Wastes

    125
    Jan 31, 2008
    Ah, cheers for mentioning that. I wonder if that will fix it for Vault15 despite his character already being messed up.


    I haven't even been there yet. But I'll probably head that way soon to pick up some things I need like the bad-ass klingon, er I mean mutant bodyguard.
    EDIT// I experienced no problems with Broken Hills and was able to finish it as usual.


    EDIT2//
    Maybe this is a bug: I found Grant's Armour at the Ghost-town. I read in the older megamod thread that the armour is supposed to be broken powerarmour, however it is using the combat armour graphic instead of metal or PA when equipped. Its also very *very* heavy, so really instead of just being the most overweight armour in the game, it should just not give any STR bonus to show that its broken.
    The bug is really in its appearance, the other issues are just design flaws ;) Since its metal it should at least have a metal armour graphic or some PA thing.

    Found two places (Ghost town and Abondoned/Destroyed Lab) where the air is so toxic it overcomes the filtering system on the Power Armour, maybe it would be nice to have the script mention this...
    IE: " The air here is so toxic that the filtration system on your armour can not filter out the toxins from the air."
    Im really nit-picking though hehe. But I mention that because at first I thought it might be a bug until I remembered that there is a gas mask somewhere. :)

    I mentioned before how saving while wearing the Environmental Armour would cause the PC to disappear, it also happens with the 'Professional Power Armour' which is the one that uses the fallout tatcics PA graphic I believe.

    Cheers.

    EDIT3// Oh one other thing, does anyone know if the submarine is included in the latest version or is that still an RP only addon for now?
     
  17. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    To all: I am sorry if it appeared as though this project was dead and I dropped off the face of the planet. I am still around... kinda. Busy with real world issues for a while. And now, I am away from home again... for a while. I may have some time here and there to work on the MM. It's not dead, I promise. ;)
    Thanks to all of you who continue to follow this mod, submit reports, and answer questions for others.

    @nad02s: Thank you very much for the lengthy bug reports list and descriptions. They have been very helpful. I will try to answer some of your questions now. I know there are a couple of messages with bug reports. I have only a limited amount of time right now, but I will answer a few now.

    But before I do, I just want to let you know that the next version of the MM will have the weather mod disabled. Most people don't seem to like it... and there are still some bugs, it seems. If the bugs get completely resolved - and maybe they have been fixed by Nirran, since I have some files but have not put together 2.45 yet - maybe I will include it again. I was thinking of keeping it, but not having the screen affected. For example, show in the message box that you are in the middle of heavy rain or a sandstorm, lower perception, but not have the screen affected so that the player can still see what is going on. Just a thought.

    I don't know what is going on with Broken Hills. I never had any crashes there. I will investigate if others continue to have problems.

    Lich originally made the armor for one of his mods. I don't remember changing any of the stats on it, but I may have. I will change the graphic used... it definitely should not use the combat armor graphic. I will change it to the power armor graphic. I have an image in my head of power armor being very heavy. The only reason it seems light, I thought, was because it is self powered. Even then, it is still a heavy. However, I will think this over. What is the weight right now?

    No, just an oversight on my part. Power armor should still protect you in both locations. However, it does give me an idea: There are certain chemical agents that totally mess up filtration devices. I can readily think of a few in which a gas mask will protect you for a while before becoming useless. Maybe these two areas could have a such a chemical. Or I can use this idea in another area to force the player to go it alone without a party. That fits in nicely with one of my other ideas: injuring ALL party members, not just the player, in those hazardous areas unless they have gas-masks or power armor. Hmmm...

    Gotta run.

    Edit:
    The sub from the RP has not been included yet.

    I'll go through the script and see what might be in the newer obj_dude script that is causing the conflict.

    Weird. The weather mod is supposed to lower your perception and lower your AC. The idea, of course, is that you cannot see so well in a sandstorm, but neither can your enemies (lowering your AC to make you a little easier to hit). Like I said above: this may have been fixed in one of the files Nirran sent to me, but I just can't remember right now.

    Um, is that from the MM, or one of the mods by Nirran? I ask because I couldn't find that dialog in any of the files I have. Is that supposed to be the XP Master perk? I don't know. If it was one straight from Nirran, maybe the corresponding .ini file needs to be edited.

    Interesting. I will have to test this. I mean, I can imagine that he goes unresponsive with regards to combat settings. That would indicate a problem with a proto file. It almost seems as though a global variable was reset...

    Thanks. I will find out why this happens with this and the professional armor.

    Then I think you will like my idea for the Scrounger perk that I will re-add to the game. ;)

    Not quite. The original B-Team mod, of course, made him look like the player in that particular armor. Josan12's version of the redone armors did not include a leather jacketed or non-armored Cassidy. He said that, by the time Cassidy was recruited, the player would not be using the leather jacket and would definitely have armor for Cassidy. I don't think he ever went back and painstakingly made any new graphics for those two situations. Maybe I will change the code to have him use his original graphic in those situations.
     
  18. nad02s

    nad02s It Wandered In From the Wastes

    125
    Jan 31, 2008
    Hey dude.
    Your most welcome, I'm glad they were of some use to you. I'll try to keep them coming for you.

    Off the top of my head it was 150 or 145 I believe, I'll try to remember to get the correct value as I did make sure to save the armour during my play throuigh in-case it has some other purpose to it.


    That would be great, especially having party members affected by such things. Just like the green goo I suppose, when you first encounter that its just about enough of a threat that you have to think about how to proceed.

    Ah I'm sorry about that one, it does seem likely its a Nirran script. It may well be the XP Master one, but tbh Im not sure, I installed a couple of his scripts even the cheaty ones :oops:

    Just a quick update to this one, I found that you don't actually have to re-equip the armour, but rather must simply enter the inventory screen. So just pressing I and exitting the screen is enough for the PC to re-appear.

    Now I did/do have some more bugs for you, but due to some issues I had I may have induced these myself while repairing my game, but regardless here are some bugs off the top of my head:

    Saving the game now reverts all NPC armour graphics to defaults... So I mean say you have Sulik or Cassidy in PA, they have a snazzy new graphic in the MM, however it seems that now whenever I save, their custom graphic is reverted to a default PA graphic.
    And to revert them to their custom graphic requires them to remove and re-equip their armour.
    I need to test this further to find out if indeed it was caused by something I did. (Edit//Now I think about it, I did re-install megamod at some point and may have forgotten to ensure some files were read-only)

    Bozar has 2 single shot modes and 2 aimed single shot modes, they both seem to do the same damage but one has sound the other does not. (Again this could be caused by me messing with Nirrans scripts, specifically I installed his weapon upgrades mod but didn't like the way it reverted the Bozar to a machinegun so I undid that one change.)

    I'm picking up a lot of 'reserved item' thingies that use the drug graphics (Buffout ect). I assume its all from the random items script.

    These are all minor bugs, hardly worth mentioning. However here's one I should mention:

    BOS bunker quests seem bugged again, here's a quick run-down of whats happened:
    Got the plans for Matt at SanFran, head to BOS bunker (name?), arrive at Bunker and initially I was given scripts/quests in the wrong order ;
    On my initial arrival I ran straight to the guy in charge and on speaking to him it activated the second quest (Which is the fetch and carry quest).
    Now I noticed that if you take your time in running to him, as you approach he will actually speak to you (He'll initiate the conversation), activating the first quest (the squad under fire one). This all worked as normal.
    However on returning as usual I was given the second quest. So I ran to the other BOS base (name?) made the delivery and picked up the thing that looks like a water chip, I won't attempt to spell it ;)
    Then I returned to the base with lots of guards (The first base).
    I remember that from a previous version that there was a reason for all of those BOS guards outside, however this time the 'invasion' didn't happen and this is where it all went a bit funny. After handing the object to the CO (Whatever his name is, the guy with a blue cap) the siren sounded and ended the conversation however nothing much happened after that. The only way I was able to progress was to enter into the bunker and then immediately leave the bunker. The CO then tells me I should immediately report the situation to the General and I'm teleported inside. However the conversation with the General was bugged and ended before anything was said, I will edit the post once I'm back on the Megamod with the actual dialogue choices and which one it was that ended the conversation prematurely.

    Ah I just remembered one other bug I ran into.
    At Navarro once the Vertibird had landed, it would disappear if I 'inspected' it, but if I just clicked on it and moved the mouse away quickly (so it wouldnt inspect it/ view it) it would not disappear.
    This sounds vague, I'm working from memory and will have to check it out further for you.

    Oh one other thing, its not a bug at all but more an annoyance (Its in Vanilla too IIRC): I always found it really annoying how in Redding the Sherrif will only let you work for him if you are a certain level (level 10?), IMO this always went against my idea of how Fallout should work (Level requirements), what do you think?
    I know its a tiny little thing but its something I always run into every play-through and the memory stands out :)

    Cheers.
     
  19. diggerzz

    diggerzz First time out of the vault

    16
    Feb 2, 2012
    I find the "Random Chemicals" in the Ghost Farm location.
    If use it, occur three events:
    1. Random Chemicals does NOT disappear from inventory.
    2. My Character acquires the status of "Poisoned"
    3.After some time game hang and terminated.

    P.S. Why do need Random Chemicals?
    Sorry for offtopic.
     
  20. Warhameron

    Warhameron First time out of the vault

    9
    Dec 17, 2010
    hi
    I just finished shaman quest and try to make Healing Powder (but how ? -have first aid 24,mortar ,Brock Flower and Xander Root) and how to skinning golden gecko (i watch jordan, but i dont have perk)
     
Thread Status:
Not open for further replies.