Fallout 2 mod Megamod version 2.47 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Mar 20, 2017.

  1. Samhain

    Samhain First time out of the vault

    Oct 9, 2017
    So I've been thoroughly enjoying the mod. I've completed most quests. I'm about to head to SF to hit the Enclave.
    I've gotten most random encounters: King Arthur, Giant Head, Cafe, Bridge, Guardian, Federation Ship, etc., etc.
    All seem fine. I had only a few bugs/crashes, that haven't impeded me from continuing.

    1. Modoc - Sheriff Jo, if you mess up the conversation with him, (act rude), you can not ask him about the Geck. Subsequently, you can not get the Ghost town quests. (Slags, Saving Johnny..) (I fixed it by replacing Modoc's save files with earlier ones)

    For those having problems with the trap door in Modoc, in the shack with the kid who's dad is missing, I got it open after A) Oiling the door a CRAP TON, making sure to see a display about having oiled the hinges. B) Repairing the door a CRAP TON TOO. I had to click to repair it on all four corners, the middle, top, bottom, left, right, (you get the idea). It will open. Just DON'T dynamite it. I even tried using a crowbar.

    2. S.A.D. - Private Dobbs will join my party, but after telling him to wait, he say's that I'm looking a little over crowded, and won't rejoin my party. (I have Vic, Skynet, Marcus, Cassidy, Klint, Sulik, Dogmeat, Cyberdog, Goris, Bess. But 10 CH, Cult of Personality, and Magnetic Personality. I've tried giving myself a crap ton extra Charisma.) As I typed this, I realized when I replaced the Modoc files, for a little bit I had two Bess's. I didn't dismiss the first Bess when I "doctored" the second. But I read somewhere that Bess doesn't add to the follow count. IDK, I could, and probably am, wrong. :)

    3. Coastal Encounters - Once , I got caught in a fight between Cannibals and Fishermen/Tribals. Protected the innocents & saved the day, but discovered I couldn't leave the map. There was no visible/reachable exit grid. Now I stay away from the coast.

    Don't know if it's a bug or not, but I use the raiders cave as a player home, and the dead, "melted", corpses aren't disappearing. It's been over two weeks. Not a problem, I think it adds to the decor. ;)
    I think there were a few more, but I can't think of them right now. So they obviously weren't a big deal.

    GREAT WORK with this mod though. F2 is in my Holy Trinity of video games. I wouldn't go to a desert island without it. :D This mod has made it a completely new experience. Thank you for your hard work!
  2. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    you will sure enjoy helicopter driving, if you manage to obtain it ... its not that simple quest but unique for this mod and you can then load your truck into helicopter :D
    • [Like] [Like] x 1
  3. Arathos

    Arathos First time out of the vault

    Feb 2, 2017
    Hmmm, perhaps I've run into a bug but I'm not sure if it is meant to be one or not.

    Namely after flirting with Emily from Trapper town I get two choices in response with one of them being "So? We both like this game so why should we stop?" but if I select that choice I receive no response whether positive, negative or neutral. In fact I cannot exit the dialogue till I choose the other choice.

    Its a bit strange how there is no response whatsoever. The only other time I couldn't progress by chosing a dialogue was when I tried asking the guy who was guarding the exit at the beginning of the game to let me go home. Then he got silent and I couldn't get an answer out of him(and had to just say that I'm leaving then)...but that was clearly intended. With Emily though I'm not sure...
  4. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    you play male or female char ?

    about emily, did you talk to sally - owner of bath in klamath first befor you go to emily ?
  5. Arathos

    Arathos First time out of the vault

    Feb 2, 2017
    Male. I recall from a previous play that one can only be friends with Emily if playing as female (unless I missed something) as there is no flirting.

    And no, I did not talk with the bath owner yet. Though I convinced Emily to join said bath service later :)

    Its just about that "blocked" dialogue tree option which sorta bugged me whether it was intended or not since I was curious about Emily's respnse to it lol.
  6. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    for me its a bug, if you can convice her befor know about that job ... but in most of quests in fallout its so ... e.g. you have empathy, smooth talker, negotiator perk and yup you are smarter than genius :D :D :D
  7. Samhain

    Samhain First time out of the vault

    Oct 9, 2017
    Found a few more bugs.
    Vault 14 -

    1. The citizen from Broken Hills, ?"Syrian"?, who is on the second floor. When you free him, he doesn't disappear. The dialog box comes up again and you can keep freeing him for 500 exp. On a second playthough, the glitch didn't happen. The difference between each playthough was that the first time, I didn't have anyone with me. The second, I had Marcus.

    2. The first time I got down to the Doc, I thought I could just get the armor for Marcus on my own. Since I read that it was "lootable" armor for Marcus. So I didn't have him with me. I had to go get him from my Hideout. But when I entered my base the game crashed. I suppose this has something to do with Marcus, but I'm not sure. I didn't try to recreate it again.

    3. The doctor who can give you the armor for Marcus, when asked if he would give you the female wanamingo as a follower, the dialog screen goes blank and you can not leave the conversation. No dialog options, and if you open trade, there was nothing in my inventory. I had to quit & restart the game.

    4. Getting the Armor for Marcus, then telling Marcus to wait, causes the game to immediately CTD. I suppose there is some animation error or something. Marcus was equipped with a Rocket-launcher if that makes any difference. I suppose that this and bug 2 are related.

    I've decided that it's best to just overload the Vault 14 reactor and demo the place than bother worrying about armor and more companions. :) Who doesn't like a bit of fireworks? :D

    Redding/Ruined City

    1. Talked to Jim Horton, got to the Ruined City, but DIDN'T identify the body of Mike Horton before talking to the tribal. Doing this, it is IMPOSSIBLE to identify Mike. You have to talk to Jim, go to the Ruined City, DO NO TALK TO TRIBAL, find Mike, use the Binoculars on him. Make sure you see his name in the Monitor, then it is safe to Talk to the tribal and complete that little event.

    I had screwed it up the first time, and had to replace RNDBD.SAV and RNDBD.fog in my save folder, with copies from a game in which I had not talked to the tribal yet. Open F2SE, find the REDDOWN.SAV in the World Map tab, open it, find RCHORTON.INT in the scripts and reset all the variables to zero.

    This makes it so the Ruined City was on my world map, But I hadn't started the Jim Horton quest. So I could just talk to him, go straight to the RC, find Mike's body, Talk to Jim, then go back to RC, talk to tribal, finish that event. Profit.
    Last edited: Oct 19, 2017
  8. Samhain

    Samhain First time out of the vault

    Oct 9, 2017
    1. I have no idea whats going on, but I can not get the ranger safe houses to appear on my map.

    2. In San Francisco, I can not get to the Shi Submarine. Even though I have the quest to disable the sub, I used the tanker and made it to the Enclave without incident. There was no boat at the docks to take to the Sub.

    Edit. -
    Environmental Protection Agency - Crazy bugged. Besides massive amount of random crashes, can't get any of the new followers. (Kitsune, Cat..) Even though their critter data is present. *Not implemented yet?*

    Brotherhood Bunker - Can do the first mission to find the lost squad, and join the BOS. But then nobody talks to me and I can't enter the bunker. Guess I wont be curing Lenny.
    Last edited: Oct 19, 2017
  9. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    only remains from other mods, megamod dont use them - i mean ranger safe places and submarine
    • [Like] [Like] x 1
  10. Samhain

    Samhain First time out of the vault

    Oct 9, 2017
    Slaver Camp - Can not unlock the door to Suliks sister. All guards are dead. I have the keys. Dialog just keeps saying the slavers would hear if I unlocked the door. Tried explosives, lockpicking, science, repair, sneaking.... WTH?
  11. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    answered at previous page :D
  12. chieftain486

    chieftain486 War. War never changes...

    Apr 9, 2017
    It seems a lot of people experience problems with Slaver Camp. Maybe it would be beneficial to release temporatily pack (call it or something) just to patch these holes, without serious updates [yet]?
    Last edited: Oct 20, 2017
  13. Samhain

    Samhain First time out of the vault

    Oct 9, 2017
    I did the editing with F12SE. Got into the shack, but clicking on the fence gate, causes CTD. Talking to Suliks sis, instant CTD. With Sulik, without Sulik.

    I'm fine with waiting for the next big update/release. This is a small side quest with no real impact on the ending cinematic's of the game. :) Beat the game, that still all works. :D

    Other Bugs -
    1. Using the Compass Watch, causes the Highway man to glitch out. The front end of the car gets reverted to the gray color, while the truck stays what ever color it was.
  14. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    bugs are everywhere, megamod has ton of scripts which are from different mods so here and there you discover something interferring, for me will be the biggest update if author contact Foxx and implement directX graphics in this mod, Foxx made it for russian Fallout1, Fallout2 and Fallout Nevada ... :D
  15. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    I recently started a new job... one which provides me less free time than my last job. But I haven't forgotten about all of your posts, bug reports, or the mod. After all, I just spent a lot of money to retrieve the data from the hard drive that the mod was stored on!
    I promise the mod isn't dead yet. I just wanted to let you all know the reason for the delay. Hopefully I can get something out by the end of November... at least, that's what I'm shooting for. Please keep those reports coming. And thank you to those of you who follow the thread and provide answers to those having difficulties.
    • [Like] [Like] x 2
  16. jackass888

    jackass888 First time out of the vault

    Jun 5, 2004
    Thank you for for this great mod!

    Tried a playthrough with 2.47.1 version with hard difficulty, but also tried easy. I think I installed everything correctly.
    *The overall damage balance seems VERY off. Some places and foes seem impossible even on easy combat difficulty, since they one-shot you. And some foes just dont do damage. The whole balance seems backwards - I can easy take out an Encalve patrol, but I get killed by slavers.

    *Laser weapons are useless - doing 0 points damage on unarmored and ~3 points dam on powerarmor and robots.
    *Burst weapons very often 1-shot kill powerarmor, robots with 200 damage. Shotguns, assaultrifle, minigun. Flamer still useless
    *Small cheaper weapons are OP. 10mm 30dam shots are regular.
    *Miniguns are strange. Often doing 0 damage and then ~200
    *Melee is underpowered. Unarmed for man and muti is ok I think. Animals are underpowered.

    *Sometimes unbearable lag occurs after loading a level
    *BOS bunker is not functional. "You need the code" after completing quest. BOS entrance contains insane amounts of ammo for stealing.
  17. Alphons

    Alphons National Beholder

    Aug 9, 2017
    Only wanted to say that it's a great mod, even with bugs. It can be seen that you put a lot of work and free time into it. Also good luck at new work!
    Last edited: Oct 28, 2017
  18. Arathos

    Arathos First time out of the vault

    Feb 2, 2017
    Me too cannot deal with the Slaver camp. Can't open the door no matter what I do. :(

    A minor fix to deal with that issue? Or even a save to how it goes afterwards? Help...
  19. agayardo

    agayardo First time out of the vault

    Nov 14, 2017
    Thanks for this great mod.

    It seems that it is important to have balanced curly braces in MSG files and violating that results in Error options in dialogues.

    Here are the instances of unbalanced curly braces I found. Are these real issues? Any suggestions for other kinds of errors that could be checked for automatically? Thanks!

    In file BOSLORI.MSG
    {164}{}{I hope you've got a heart . . . (She looks at you falling on the floor.)

    In file bosstdnt.msg
    {204}{}{Maybe you will relieve me?
    {304}{}{[Whispers] Will you let me play Fallout 5 on your computer tonight?

    In file Copy of AItem6.msg
    {4287}{}Am I a doctor?}#11

    In file kcaldo.msg
    {206}{}{Oohh-hey! {you give the man those cute yellow thingies]}

    In file kcjasper.msg
    {210){}{Hi there. I'm Jasper. I don't think I've seen you around here before. What's your name?}
    {330}{}{Like I said, it's pretty complicated. [Continue the conversation.]}[331}{}{The whole thing is so confusing. [You finish your drink.] Care to buy me another drink while we sort this out?}
    {419}{}{[Draw back rebuffing his kiss, smile, then leave.]}[420}{}{Rebuff his kiss with a smirk, then walk away and leave.]}
    {560}{}{I'm great, sweetheart. I unloaded my biggest haul of pelts ever, and just finished paying off my guys-- wow, were they happy. I don't think some of them had ever had so much coin at one time before. And just when I thought things couldn't get any better, in walks you through the door. Honey, I know we agreed to keep things betwen us at a simmer rather than a boil since we don't get to spend time together very often, but here-- I want you to take this and buy yourself something nice. Treat yourself. [He offers you a bag of coins. Judging by the weight, it's about 500 dollars.]
    {731{}{. But if not, I meant what I said. Even if you are right, it doesn't matter to me. Maybe we don't get to spend a lot of time together, but it's been long enough for me to make my decision. I'm crazy about you, }

    In file NCSTULIT.MSG
    {411}{}{{He sticks his toothpick back in mouth and chews on it.) Got a name?}

    In file rafael.msg
    {287}{}Am I a doctor?}#11
    {2016}{}Fuck. How should i cure this?}

    In file teacher.msg
    {311}{}[Can I find holodisks in this place?}
    {337}{}{Vree thinks that the research of new weaponry and the information gathered from the mutant research is more important than our history. She forgets, that all our life is dependant on history. It is very bad, that many of the new iniciated, doesn't even know who Roger Maxson was, and what he has done for us.
  20. chieftain486

    chieftain486 War. War never changes...

    Apr 9, 2017
    I have a question about Redding. I cleared Wanamingo mine and gave the excavator chip to Marge. Then I talked to doc, Marge, Dan McGrew and mayor. All of them have their own vision of the future of Redding (with Vault City, NCR or New Reno), but none can give me any directions as to how I should act to make one of those aliances possible.
    The question is, is there any way to get those quests or they are just not implemented [yet] ?

    Also, to the topic of this thread (@MIB88) :
    1) In Broken Hills many of caravan guards have two combat shotguns (one equipped and one in their inventories). I think one should be enough. :)
    2) I confirm that currently there is no way to normally complete the "repair the purifier" quest in Broken Hills: you can enter the mine but game totally freezes the moment the fight mode activated. The only way now is to use Ctrl-R trick to get to the broken machine without a fight, then install the filter, then use Ctrl-R again to leave the mine.
    3) In NCR the Bazaar shop has three shelves, but when you browse through them, you get to see (almost every over time) not the content of the shelf you clicked but the inventory of the owner (stimpack and combat knife (or spike knuckles)). Then you have to quit the dialog completely, click on that shelf again - and only then you see the right content! It's not critical, but it's annoying.
    4) In Modoc in the shack area (north-west) some radscorpions have strange hit point info. If you have Awareness you see something like "52/26", and then after the first hit it always got below 26, so that "52" is obviously a glitch.
    Last edited: Nov 24, 2017