Fallout 2 mod Megamod version 2.47 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Mar 20, 2017.

  1. assassin01

    assassin01 First time out of the vault

    10
    Jul 27, 2013
    Hi.
    So what version should I install if I want to play this mod? The one that is pinned in the first page of the forum the 2.47.8 or the installer that linked in by @_Pyran_ ?
    Which one is the less buggy/stable state that don't break a playtrough?:shrug:
     
  2. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Thanks. I'll check it out. Unfortunately, that's a pretty generic error message. What exactly are you doing when the error happens? Does it actually happen in the middle of dialog?


    It's up to you. Pros and cons for each. The one on the front page is my latest version. All options will be in the game. It has some fixes not in the installer as well as more content:

    -Numerous dialog and grammar fixes
    -Minor corrections to various maps
    -Cleaned up code in some scripts
    -Inclusion of most of the Handmade Guns Mod by Werwolf
    -Added new version of EPA maps
    -Inclusion of Fallout 2 Cartoon Intro Remake Mod by Biedron0
    -Brotherhood of Steel quests should work a little better
    -PC can no longer keep getting experience repeatedly for scouting out Broken Hills for Stark
    -Updates to talking heads
    ---Addition of talking heads created by Goat_Boy
    ---Corrected backgrounds for conversations with some party NPCs
    -Modified the armor for Dogmeat to act like other armors (removal of perks)
    -Added PipBoy timer notes created by Lexx


    However, the installer version is easy to use. And, you can select elements of the mod that you want to play with.
     
  3. Arathos

    Arathos It Wandered In From the Wastes

    122
    Feb 2, 2017
    No plans of @_Pyran_ making an installer version for the latest version in the near future?
     
  4. Valerij Bosch

    Valerij Bosch First time out of the vault

    21
    Nov 15, 2018
    I cant play the mod since it crashes right uppon entering the trial temple:
    "The instruction 004a48ad referenced memory 6f63208b"
    "The memory could not be written"

    I used the manual installation
     
  5. assassin01

    assassin01 First time out of the vault

    10
    Jul 27, 2013
    Thanks for the info @MIB88 . I think I will have to do 2 seperate playtroughs since both versions has something the other has not (inventory filter,apperence change,new weapons,additional talking heads). It would be nice to have the 2 versions content merged.

    Also can I use some additional mods from Nirran? The additional "custom perks" and "party member perks" he has on his site?
     
  6. Valerij Bosch

    Valerij Bosch First time out of the vault

    21
    Nov 15, 2018
    I have no idea how I managed the mod to work but it works now, yay :3
    However, I played the restoration projct before since I couldnt get it to run but I remember that the mega mod had pretty more stuff I liked and I couldnt ignore it, hence I keept on trying until it worked.

    Sadly the current version is not compitable with:
    -Restoration Project - Companion Expansion
    -Restoration Project - Talking Heads Addon
    -Restoration Project - Talking Heads Actually Talk (THAT) Mod

    Obviously they wouldnt work but I still tried it but sadly no changes could be seen. Kinda wish this awesome mod would also integrate these too. But I think they kinda annoying to impliment and need much effort to do so. Still, a man can dream.
     
  7. SPIT

    SPIT First time out of the vault

    23
    Nov 20, 2003
    Ok, so it happens when I actually agree to provide them with the tnt, and I have it. After that the dialog screen is supposed to shut down - it shuts down and I get the error.

    Also more problems: the Slave camp - When I try to talk to Sulik's sister the dialog box with a talking head opens but it's stuck, It overlaps the entire screen and I can't do anything. I once managed to get to her village, but the game also crashed. :|
     
  8. Valerij Bosch

    Valerij Bosch First time out of the vault

    21
    Nov 15, 2018
    I get a crash once Im visiting the new location (Orphanage?) in Den.
     
  9. obimark

    obimark First time out of the vault

    33
    Aug 1, 2012
    Try reloading before entering, worked for me
     
  10. Valerij Bosch

    Valerij Bosch First time out of the vault

    21
    Nov 15, 2018
    Thanks for the suggestion but that didnt fixed it, however I tried with a new method since I gave up on that point.
    Basically before entering you have exit the town, then enter it and only then you can visit that place.
    Same goes for saves: If you enter that zone, save there and want to reload, I get the same error. However, when I reload a different save where its outside the place, exit and re-enter the town and then reload - only then I can load the save. Weird bug but your suggestion kinda made it possible to continue with my run.
     
  11. obimark

    obimark First time out of the vault

    33
    Aug 1, 2012
    Bugs encountered so far:
    General: party members are not leveling up, I got exclamation they leveled up, but stats reverse when exiting map

    Klamath - find out who is rustling the brahmin quest can be started, but not completed
    The Den - crash upon entering Den residential, but can be solved by exiting game and entering
    game freezes when obtaining car from Smitty - copied smitty script from 2.47.6 and worked after
    Vault city - quests keep popping up all over the place, once I got quest to scout NCR, but I was supposed to scout Gecko...
    Vault village - crash when exiting first conversation with Connar
    Broken Hills - Francis doesn't want to speak with me, even though I have solid positive karma - around 700
    Francis, Phil, Typhoon and Jacob become non-responsive after a while, can't pinpoint where - reverting their scripts to 2.47.6 makes them talkative again
    New Reno - Eldrdige has two reserved items in his inventory
    Slave camp - can't unlock the gates to small shack north of main building, lockpick doesn't work, even after talking to guard there I can't use keys because someone will certainly hear me
     
    Last edited: Jun 2, 2024