Troubleshooting FAQ, for technical help

Discussion in 'Fallout RPG Gameplay & Tech' started by Odin, Feb 24, 2004.

  1. trustno1

    trustno1 First time out of the vault

    May 30, 2007
    French fix for blackouts

    I haven't seen this posted anywhere (sorry if it has):
    I can't say about Fallout 2, but this fixed the "blackouts" in Fallout 1 for me (dual core AMD, 7900GTX on WinXP). It's french, but online translators are enough to understand the readme - just unzip the appropriate archive anywhere (I've put it in my Fallout dir), launch the fo1_screen_refresh.exe (or fo2_screen_refresh.exe) and leave the window that'll pop up open. Clicking "OK" will turn it off.
  2. Fishbrain

    Fishbrain First time out of the vault

    Aug 28, 2007
    Hi, this is my story:

    I have a Pentium 4 1.8 Ghz with 512 MB RAM and Windows XP Home (with all updates) and the video card GeForce3 Ti 200.

    I followed the guide to manually install Fallout 1 (Windows) because the direct install wouldn't work ("OS not supported"). I downloaded the v1.1 patch and extracted it my Fallout 1 folder. But when I try to run it, all that happens is that the Loading Screen flashes up for a moment and then I'm back to Windows (Fallout doesn't run in the background).

    I tried different things to solve this problem: I deactivated my video card, reduced hardware acceleration, deactivated Write Combining, tried various different settings for the compatibility mode - but none of these worked.

    Any ideas what else I could do or where the problem might be?

    I also tried to install the game on my other machine, a notebook with Intel Duo T2450, 2GB RAM, ATI Radeom X1700 and Windows Vista Premium - but I got similar results. However, I haven't tried all of the above solution on that machine yet.


    I also tried to run Fallout 1 with DOSBox, but I ran into some problems there as well. First of all, there was the problem of installing the game. I mounted my CD drive with DOSBox and ran the installation exe. There, the program had difficulties in finding my hard drives. It only found C:\ and there it said I only had enough space for a medium installation (which isn't true, but after all, I guess it doesn't matter). I chose a medium installation on C:\ but after that nothing happened. The screen just froze (or maybe it was just slowed down? I read about such problems with DOSBox).

    I also tried to manually install a DOS version of the game so that I could then run the game itself with DOSBox. However, I didn't really know how to do it, so I simply took all the files from the PROGRAM\DOS directory of my Fallout CD and copied them into the folder where I manually installed the Windows version of Fallout. I renamed FALLOUT.__ to FALLOUT.EXE and SOUND.__ to SOUND.EXE and adjusted my FALLOUT.CFG file by changing the paths of master_dat, critter_dat and music_path2 to C:\ (since my fallout directory would be mounted as C:\ in DOSBox).

    After that, I had exactly the same effect as with my Windows version of Fallout: the loading screen flashes briefly (only much slower than in Windows), then I'm back to my desktop - or rather: the DOSBox interface.

    Do you know to manually install the DOS version? Or do you perhaps have other tips for using DOSBox?

    Thanks in advance for your help!
  3. Fishbrain

    Fishbrain First time out of the vault

    Aug 28, 2007
    Okay, just in case anybody's interested: I finally managed to solve my problem.

    I still don't quite understand it but I managed to get the game to work on my laptop. What I did was basically this: I got myself the original US version of the game: and now it seems to work fine. Previously, I only had the German version, which came with the CD of a gaming magazine. That one still doesn't work but I don't really mind because now I can not only play Fallout but also kill children while doing it. Cheerio!
  4. Ammut

    Ammut First time out of the vault

    Jun 24, 2007
    Installing Fallout 2 on Ubuntu

    I searched and searched, found nothing so here I am writing of my experience installing Fallout 2 on Ubuntu Linux.

    Wow, did I just say I installed Fallout on Linux? Yes indeed! To do so you will need one thing:

    Wine. Wine is a Windows emulator available on the internet or even in your distro's package repository. I use Ubuntu, so installing it was a snap with their GUI interface. After installing Wine, pop your Fallout 2 cd into the drive and wait for the cd to be mounted (or if you need to, mount it yourself from the command line).

    Run the setup.exe file (it should open automatically with Wine). If it doesn't open, use this command:

    wine cddrive:\setup.exe

    Which should open up the installation screen you normally see on a Windows box. Install the largest size, and after installation patch the game with whatever mods you want. From here you need to figure out a way to open the game itself. Navigating in your file browser won't do it; so what you need to do is open a terminal (or from the command line) and run:

    wine C:\Program Files\BlackIsle\Fallout2\fallout2.exe

    or (from a GUi interface)


    then navigate to the directory to run the game. You've done it! Hope this helps anyone out there who doesn't like Windows but loves Fallout.
  5. Per

    Per Vault Consort Staff Member Admin

    Apr 1, 2004
    Added a few simple common problems and repaired the "insufficient disk space" solution which had got mangled somehow.

    Remember, people, this is the thread for solutions, not problems.
  6. DolAtoR

    DolAtoR First time out of the vault

    Nov 21, 2007
  7. Silencer

    Silencer Night Watchman Staff Member Admin

    Nov 7, 2003
  8. M-26-7

    M-26-7 Still Mildly Glowing

    Jul 20, 2008
    I've read the FAQ and I read the solution to the saved game problems and while it seems a bit extreme I might do it.
    But I ask:
    Is there anyway to keep your saved games so you don't loose it all in the uninstall and what if I only get the message sometimes? Could it be that only some slots are affected or am I just getting lucky despite the fact that all my saves have worked upto the Den and now I've gotten the eror about 4 times.
  9. Brother None

    Brother None This ghoul has seen it all

    Apr 3, 2003 Fallout:

    If you are experiencing a lot of lag with Fallout 1/2 purchased from Good Old Games, go to the main folder (\Fallout) and rename or remove ddraw.dll
  10. FalloutMyLove

    FalloutMyLove First time out of the vault

    Oct 6, 2008
    my problem.

    Hello Everyone I tried to instal Fallout 1 on my notebook ( OS : XP Proffesional Sp 3) .. everything worked ok except the fact that , i can't HEAR NOTHING, the sound is not working .

    I followed the instructions above in the first tread : i reduced the rendered sound speed to NONE, i checked if my driver is ok and still not working ...

    I olso mention that i rule the game from command-prompt becouse from direct clicking the fallout.exe executable it fails, a creepy error and it close...

    here are the sound settings :



    What else can i do ? pls any help would be deeply apreciated...

    Pls help me becouse i finished fallout 2 many times since i was a kid, and now after many years i feel that i HAVE TO FINISH the first sequel too, if not ... my fallout experience is incomplete... pls help me ... be my shield of hope :)


    LATER EDIT: OK, after struggling to find out , i used the sound.exe and i tried the soundblaster 1 , irc 5 , port 220 , dm 1 , and it works ... BUT THE SOUND IS SO LAGGY :( can i do something ? pls help me..
  11. ScottXeno

    ScottXeno It Wandered In From the Wastes

    Nov 10, 2008
    Hey, I was recently playing the first Fallout on my laptop, and something occurred to me. I didn't want to start a whole new thread, since this one was here, and this may not be the right place for it, but anyway... I am usually doing multiple things at once. Sometimes I am working, but want to take a break and play for a minute, or sometimes I am having a conversation, but want to play at the same time. I've kind of poked around, and haven't seen a solution anywhere, and I looked at the preferences, but I was wondering, does anyone know if there's a way to set it so that you can play in a window? I want to be able to minimize the game but not turn it off, just kind of set it aside. It's a real pain when I need to switch to another task and have to save, quit, and exit out of the program to do whatever it is I need to do, and then reopen the game.

  12. Per

    Per Vault Consort Staff Member Admin

    Apr 1, 2004
    Apparently you didn't poke enough. There are threads on playing in windowed mode. This is a thread for solutions, not questions.
  13. ScottXeno

    ScottXeno It Wandered In From the Wastes

    Nov 10, 2008
    Ah, sorry. I figured this thread was for asking for help with technical problems with the game, and figured that running it in the window might be a tech issue since you can't normally. I'll give it another look, must've missed the thread.
  14. barely

    barely First time out of the vault

    Nov 21, 2008
    This might go a bit off-topic, so but is the most likely looking thread so.. I got the's Fallout 2, and am trying to get killap's Restoration Project mod to work.

    Is it possible and if, how is it done? Installing GOG's F2 and then RP on top just gets me a "fallout running on compatibility mode" notice without the game ever starting. Removing ddraw.dll gets the splash screen but also an error message "wmAreaInit:: Error loading Cities."
  15. Darek

    Darek is currently unavailable

    Jan 7, 2008
    If you are using the Restoration Project you can't remove draw.dll.
    You need to remove the compatibility mode, so right click on whatever you use to start the game, go to properties and then compatibility, and un-check that option, and apply the change.

    If it's not checked, first set it to run in compatibility mode, apply your changes, then go back and remove it.
    You may need to restart your computer somewhere in between/after for the changes to take effect, according to some reports. I haven't seen anything conclusive on that though.

    Also, your post should have gone in the RP 1.2 thread.
  16. CrowbarDoom

    CrowbarDoom First time out of the vault

    Nov 22, 2008
    Hi, I made an account here at the fine NMA community in the hopes of solving my tech problem.

    I've downloaded the demo for Fallout 1 and extracted the file with Extraction Wizard. When I try to run the demo, the game locks up on a black screen and I have to restart my computer. Is there any way I can fix this?
  17. Fargo

    Fargo First time out of the vault

    Nov 25, 2008
    Hi everyone,

    I started playing Fallout 1 again recently and came across the „screen turns black“ bug. Doing a web search on the issue, I seem to have stumbled upon a surefire solution I wanted to share with you: It seems that the screen turns black any time Windows redraws the screen. This is caused by any sort of animation, like an image in an open browser window or an animated task icon. In my case, it was caused by Outlook, which animates its task icon every time it checks for new mail. After simply shutting down Outlook and any other application that may cause Windows to redraw, I have been able to play uninterrupted for hours now.

    Edit: original credit goes to "baylor" on

  18. Yackemflaber

    Yackemflaber First time out of the vault

    Apr 26, 2010
    I've searched but have not found a solution to my Windows 7 graphical bug where it distorts some colors, I have found threads with people with the same problem, but no obvious solution other than to stop running explorer.exe as the Interplay employee told me.
  19. rodney

    rodney First time out of the vault

    May 16, 2010
    I tried this but everything seems to be in order and I am still recieving an error.

    This is my current fallout2.cfg

    is anything missing?
  20. fallout_fan

    fallout_fan It Wandered In From the Wastes

    Sep 11, 2008
    The problem Im having is with Fallout 1 and its that message about not having 20 megs of free hard disk space. Anyone know a way I can fix this? Normallly I just uninstall and reinstall copying my saves over to my documents and then putting them back in the game afterwards.