Fallout 2 Restoration Project 1.2 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jun 9, 2008.

Thread Status:
Not open for further replies.
  1. kamikaze66

    kamikaze66 First time out of the vault

    2
    Jun 27, 2009
    The ctrl+r => select the map => save the game to a new slot => replace broken map on previous save with the new one worked!

    Thank you for your help Darek!

    Also I'm eager to try ver. 1.3 when it's complete, I hope it gets out soon :)

    Thanks again!
     
  2. Kanbay

    Kanbay First time out of the vault

    23
    Jul 2, 2009
    will 1.3 be in 3d ?
    serious because
    im checking site since 1 year or even more but there is no update

    i dont know how 1.3 will be but 1.4 will be with clubs and stones

    albert einstein
     
  3. Blackened

    Blackened I should set a cutom tite

    598
    Jun 29, 2008
    It's estimated to be released at the end of the summer. And it will have a lot of new features.
     
  4. Dravean

    Dravean Where'd That 6th Toe Come From?

    477
    Mar 6, 2005
    I know news on RP 1.3 progress has been slow, but I assure you that it's consistently being worked on by Killap and his modding posse.
     
  5. Sieg

    Sieg First time out of the vault

    10
    Dec 8, 2008
    It's to bad we don't have a progress report or something, just so we're not in the dark. Killap is doing his best I imagine so it can't be helped I guess.
     
  6. Lill

    Lill It Wandered In From the Wastes

    112
    May 3, 2008
    Wow, not bad. 1.3 on the way?

    Last time i were here, i waited for 1.2 :) and it was before fallout 3 hit the shelves. And now, when i were to see if 1.2 were out, there is 1.3 coming? :puppy-dog:

    I'm never gonna be able to start playing fallout 2 lol
    :D gotta wait then.

    It's okay tho, i got too many games to play anyways, so better make the wine better with the waiting XD
    'N go waste my brain on something else in the meantime O_o
     
  7. UniversalWolf

    UniversalWolf eaten by a grue.

    Aug 28, 2005
    The trick is to let your anticipation keep building until you're ready to explode. One day you'll come here and the new version will be ready, and you'll be ULTRA PSYCHED! You'll enjoy it more that way.
     
  8. TwinkieGorilla

    TwinkieGorilla This ghoul has seen it all

    Oct 19, 2007
    has anybody figured out a way to get Falche to work with Kilap's patches yet?
     
  9. Blackened

    Blackened I should set a cutom tite

    598
    Jun 29, 2008
  10. TwinkieGorilla

    TwinkieGorilla This ghoul has seen it all

    Oct 19, 2007
    cool. i'll check it out tonight. i'm currently playing a pretty rigid old-school type game (trying to adhere to pNp rules, no re-loads in certain situations, etc) with the latest Killap patches and not really lookin' to use Falche but i always like having the option to tweak anything.

    some sort of OCD perk i must have chosen in the womb.
     
  11. delosombres

    delosombres First time out of the vault

    5
    Jul 7, 2009
    Hello guys. I've probably found a bug in RP 1.2 quest.

    My setup: (WinXP SP3, no compatibility mode)
    Clean install of Fallout 2 1.0 US/UK
    RP 1.2 + fixes (four *.int files) that has not yet been added to the archive
    Newest Sfall (1.44c i think)
    Hi-res patch (2.1)
    Weapons Redone 2.0
    Widescreen maps (for removing crappy tiles in small maps like Temple of Trials or Arroyo bridge)

    Now, about the the quest. It's in the Broken Hills. This one:

    Determine whether Chad is skimming money from the caravan runs.
    You get this task by talking to Marcus. Go talk to the caravan guards and find Max, the only guy in green armor. Max will say that he knows Chad is guilty, and keeps accurate records of it in his house. If you confront Chad at this point, he will deny everything. Talk more with Max and it turns out that he designed the complicated lock on the door, and tells you how to unlock it. Chad's house in on the far end on the E side of town. Unlock the door and check the desk for a briefcase.

    Now what's my problem? THERE IS NO GUY IN GREEN ARMOR. ALL GUYS ARE WEARING BLACK LEATHER JACKETS. They all keep saying the same. If i ask about their name, they say "My name is *random name*, that's all. Even if i keep talking to everyone again and again (ther names are changing) and find Max, nothing happens. He is saying the same bs like everyone else. WTF?

    Btw, my INT is 10, speech 102%, CHA 2.

    EDIT: Small question. Is there any way to fix that stupid AI when enemies sometimes go meele (to adjacent sqare) with ranged weapons? You just keep runnin and shootin and they are lost poor dumbtards. It's really annoying. I wonder how could this pass betatests.
     
  12. Morticia

    Morticia Look, Ma! Two Heads!

    372
    Mar 9, 2008
    Welcome delosombres,

    If there is no guy in green leather armor, then the first suspect would be the widescreen maps. I could not find these maps so no way for me to check them. He should be standing to the left of the back door, regardless of stats. (Not combat armor, but leather like Cassidy has when you meet him.)

    Then
    The guards give random names in v1.2 but I never checked to see if they gave different ones each time you asked. If you found someone named Max in a leather jacket though, that would be a bug.
     
  13. delosombres

    delosombres First time out of the vault

    5
    Jul 7, 2009
    I've already tried it without widescreen maps (just clean install + RP) and nothing happed however i did not start a new game. Just used my saved games, so it could still be a cause.

    Here:
    http://www.nma-fallout.com/forum/viewtopic.php?t=42386&postdays=0&postorder=asc&start=380

    Made by Styphelus. DL: http://www.megaupload.com/?d=HO5NP60V

    There is a guy behind (closest to) the facility (or whatever it is) backdoor and only this guy sometimes say "My name is Max.". But he is wearing black leather like everyone else. Also, no quest talk.

    So it probably is.
     
  14. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ delosombres,

    There is no bug, just some confusion about what is the Restoration Project and what is the Unofficial patch. Those maps you got are for the patch only, and nothing else (even though the creator suggests otherwise).

    Max does not exist on that map, and the maps are saved in your savegames after you have visited the location once, so changing the map later wont have any effect. You need to load a save from before you have ever entered the place for it to work.

    There will probably be a few other "bugs", but probably nothing major, since the updated maps don't touch the new RP locations.
     
  15. delosombres

    delosombres First time out of the vault

    5
    Jul 7, 2009
    OK. Thanks for clarification Darek.

    So there is absolutely no way to fix it within the current savegame? I tried to delete BHILL.SAV files from the save directory but after that the save did not work at all.
     
  16. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Well, you can try to push Ctrl-R at the title screen, load up broken1.map and save game to any available slot (do this without the widescreen map).
    Then copy the new broken1.sav into your old save slot. But I can't promise this will work. Also, you and your car should not be on the old map you are trying to fix. If you are, leave and enter a desert map, then save, then do the Ctrl-R thing.
     
  17. jmarsh07

    jmarsh07 First time out of the vault

    31
    Apr 22, 2007
    Hey Killap,
    You haven't made a post for 2 weeks now, and I was just wondering if you had any time update for 1.3. Been waiting to play this version for a long time now. ( I put off playing 1.2). Just looking for a complete version so I can have my fallout 2 fix.
    This going cold turkey is not fun :cry:
     
  18. vad

    vad It Wandered In From the Wastes

    137
    Jul 23, 2008
    There is no need to delete any *.sav file. There is a list in save.dat with each map you visited. You can delete any map from list by my Savegame Editor. Deleted map will be recreated next time you visit it.
    Or use Darek's method, it works too.
     
  19. Kanbay

    Kanbay First time out of the vault

    23
    Jul 2, 2009
    1.3 is a myth
     
  20. GrayJ

    GrayJ First time out of the vault

    2
    Jul 9, 2009
    Hi, I'm trying to install the RP, but I'm having trouble finding the correct location. It tells me that it "must be installed to the Fallout 2 installation directory."

    Help?

    (Also, the directory of my Fallout 2 folder is C:\Program Files\GOG.com\Fallout 2, if that helps...)
     
Thread Status:
Not open for further replies.