Fallout 2 Restoration Project 1.2 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jun 9, 2008.

Thread Status:
Not open for further replies.
  1. Morticia

    Morticia Look, Ma! Two Heads!

    372
    Mar 9, 2008
    You should get a 'browse' option to find your Fallout2 install.
     
  2. GrayJ

    GrayJ First time out of the vault

    2
    Jul 9, 2009
    And just install straight over it?


    Edit: Well, I did that, and now it's giving me an Error, saying that it's running in "Compatibility mode" and won't start.... Help?

    Edit (Again): Nevermind, got it working. Thanks. Never seen a mod that you install over the original, lol... It's always been just dl'ing them to a certain folder within the original files.
     
  3. Morticia

    Morticia Look, Ma! Two Heads!

    372
    Mar 9, 2008
    Killap knows quite a bit about how Fallout works, nearly equally as much as those who created it in the first place, I imagine. At least he is able to fix what they fuct up.

    So I caution to NOT make killap a God, but a saviour. :)
     
  4. delosombres

    delosombres First time out of the vault

    5
    Jul 7, 2009
    Darek & vad: Thanks much for help. I appreciate it. But...

    I think i've found another "bug". But it seems that this time it's a serious one. It's in the Sierra Army Depot LEVEL 3. There is a computer (SkyNet) opposite the 2 elevators (one can be open using Dixon's Eye and the other one needs a different eye) AND there are 2 forcefields.

    This:

    http://i26.tinypic.com/292pwec.jpg

    The problem is that if i tell the computer that "My name is *my name*" or "I'm a friend", nothing happens. FORCEFIELDS WON'T DEACTIVATE. I just can't go in. Every guide i've read mentions that you just need to tell him you're a friend and go to the control center where mainframe is located. Forcefield is absolutely no issue. That's all. This game is starting to annoy me pretty much because i spent 1 hour+ nitpicking every pixel in all three levels like mad, uselessly.
     
  5. player1

    player1 First time out of the vault

    15
    Jun 20, 2009
    Well, you can always use your repair skills on those emitters near forcefields to temporary deactivate them. Or turn down power from outside base, and just go through weakened forcefields (taking some damage).

    This happens in regular game too, not just in restoration or unofficial patch.
     
  6. Recon Rover Rick

    Recon Rover Rick It Wandered In From the Wastes

    130
    Aug 21, 2008
    Don't forget blowing up the force fields with dynamite or just escaping through the hard to lockpick maintenance door on the east of the level if you're finding yourself stuck.
     
  7. delosombres

    delosombres First time out of the vault

    5
    Jul 7, 2009
    Did it that way. :D (Super Stimpacks helped a lot)

    I don't think so because there is XP reward for deactivating the fields in EVERY level.

    http://falloutmods.wikia.com/wiki/Fallout_2_Quests

    Disable the force fields in level 1 - 200xp
    Disable the force fields in level 2 - 320xp
    Disable the force fields in level 3 - 440xp
    Disable the force fields in level 4 - 560xp

    Lol? I've only managed to deactivate level 1 and 2 by USING THE COMPUTERS. So how can you disable all of the fields in level 3&4 with repair skill?
     
  8. TwinkieGorilla

    TwinkieGorilla This ghoul has seen it all

    Oct 19, 2007
    playing with latest versions of Kilap's patch and RP.


    regarding the Merk missions which should lead to a dialogue option which allows the continuation of the "Murder Carlson" quest. it ain't happenin'. i tried two different clean re-entries into NCR without having spoken to Merk yet. definitely didn't piss him off, definitely did clean jobs and all i got was "i see no reason for us to continue speaking, good luck in all your ventures" with a single option for dialogue "fine by me" and if i ask/pay for information there is an option about Carlson wherein i get a response and have one single option which is "that's all i needed to know".

    the fuck?
     
  9. Morticia

    Morticia Look, Ma! Two Heads!

    372
    Mar 9, 2008
    @ TwinkieStabilis,

    Only the 2 jobs are available from Merk that I know of, then he has no reason to talk to you.

    Bishop wants Carlson dead, and one of the ways to get in is to talk to Merk. I never knew about this and always stole the pass instead.

    From The Vault.
     
  10. TwinkieGorilla

    TwinkieGorilla This ghoul has seen it all

    Oct 19, 2007
    yeah, i know about stealing the pass. but i'm wondering why i can't get the dialogue with Merk about Carlson.
     
  11. Morticia

    Morticia Look, Ma! Two Heads!

    372
    Mar 9, 2008
    @ TwinkieStabllis,
    Per's Guide doesn't say anything more about this than you mentioned already, but looking at the dialog, 'scmerk.msg' shows the line is there.

    {#229} "Tell you what. I like your work and Carlson could use another guard. Give a little time and there'll be a job waiting for you down there."

    I don't know how to check the script, (nor which one it is) to see what makes it available. (Darek knows how to do that, and I should because he showed me and I forgot) Do we have to buy the fake Vault 13 map from him first, then confront him about it? Those lines are right above that one, as are several others that I have never seen before.

    Need to figure out the requirements to get the option before determining if it's a bug.
     
  12. TwinkieGorilla

    TwinkieGorilla This ghoul has seen it all

    Oct 19, 2007
    nice! i went ahead and stole the damn pass anyway, but i'd love to know for the future as this way (dialogue) would be my preferred way of doing it for a certain character type.
     
  13. Kanhef

    Kanhef Vault Dweller

    793
    Sep 2, 2007
    You can download the original script sources here. I don't think killap has made his modifications public, so there may be some differences with his patch and RP. When trying to figure out how someone's dialog works (e.g. ncr/scmerk.ssl), I copy in the lines from their dialog file (text/english/dialog/scmerk.msg). A bit tedious, but it makes it fairly readable. Sometimes, before each node I note which responses/nodes lead to it, to make backtracing easier.

    Merk's script is annoying because some #defines are used to make most nodes start with "nbody(xxx)" instead of the normal "procedure Nodexxx begin". A find/replace of "nbody(" with "Node" will make searching for a particular node easier.

    Once you have the quest to kill Carlson, when you pay Merk to answer questions you can ask about him. If you've retrieved Dr. Henry's papers and don't have a bad reaction, there's a response that leads to line 229 and gets you hired.
     
  14. Morticia

    Morticia Look, Ma! Two Heads!

    372
    Mar 9, 2008
    Thanks Kanhef
     
  15. Julius

    Julius First time out of the vault

    27
    Jul 11, 2009
    Restoration project bug conundrum

    My Fallout 2 with restoration project v. 1.2 installed will not start up with any kind of compatibility. It gives an error message that says either something along the lines of "it appears it's running in compatibility mode" or "requires windows 95 or directX 3 or later". I do have DirectX latest version just fyi. The issue is that while it does run when I'm not running it with compatibility, the colors are fucked up. My question is if there is any way to fix the color issue without running it in compatibility mode or any way to fix the compatibility mode issues. Thank you in advance.
     
  16. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Re: Restoration project bug conundrum

    Try downloading version 1.44c of sfall and copying over ONLY ddraw.dll to your main fallout 2 directory, overwriting the file already there.
     
  17. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Has something been changed in sfall regarding the compatibility mode or the graphics?

    Anyway Julius, if that don't work there is a way to fix the messed up colors (but it don't work for everyone). In your fallout 2 folder, open the file ddraw.ini.
    Find this section:
    Code:
    [Graphics]
    ;Set to 0 for 8 bit fullscreen
    ;Set to 4 for dx9 fullscreen
    ;Set to 5 for dx9 windowed
    ;A dx9 mode is required for any graphics related script extender functions to work (i.e. fullscreen shaders)
    ;Modes 1, 2 and 3 are no longer supported
    Mode=0
    Where it says "Mode=0", change it to "Mode=4"
     
  18. Julius

    Julius First time out of the vault

    27
    Jul 11, 2009
    Tried this first cause it was the easiest, and now it works.

    Tak for hjælpen, ni behøver inte at give os skåne tilbage nu. :D

    And thanks for the quick replies
     
  19. your evil twin

    your evil twin It Wandered In From the Wastes

    165
    Apr 29, 2006
    I'm using the most recent version of sfall and the most recent version of the fallout 2 high resolution patch, and when I try to play Fallout 2 in dx9 mode I get screwed up movies. But weirdly I CAN play Fallout 1 in dx9 mode with sfall and high-res patch without screwed up movies!

    Is there actually any appreciable visual difference between playing in dx9 mode and playing in 16bit mode? When I couldn't get dx9 mode to work I instead switched to the high res patch's 16 bit mode, and 1280x800 resolution, and it looks fine to me, as good as 1280x800 resolution in Fallout 1 in dx9 mode.

    I'm aware that with Fallout 2 you can do some kind of "scaling" option in dx9 mode, but I don't understand what that's all about anyway. ;) Readme for sfall or the high res patch doesn't explain what it does, just that the option is there.

    At first I got some kind of compatibility problem, I wasn't running in any compatability mode and yet it claimed that I was. Can't remember if it was Fallout 1 or Fallout 2 unfortunately. I fixed it by going into the executable properties, changing it a bunch of random compatabilities (windows 98, windows 95 etc) and then back no compatabilities, and this time it seemed to stick.

    Also, the readme mentions the option to have reloading use weaon idle animations, but I can't see the command for that anywhere the ddraw.ini file. Bizarrely I think I was somehow able to activate it in Fallout 1, but I can't activate it in Fallout 2.

    I think it would be awesome if it were possible to actually disable the weapon idle animations and have them ONLY play when you reload. Some of the idle animations look fine as idles, but some look silly - reloading the SMG and throwing the old magazine away, for instance. I'm just standing there, with a an SMG half full of bullets, and my character just suddenly appears to throw the bullets away! Lol. That always bothered me.
     
  20. Uaine

    Uaine First time out of the vault

    36
    Dec 2, 2004
    Metzger dialog bug

    Sorry if this one has already been mentioned.

    After Metzger reveals the location of the Slave Camp, he says "What the hell you asking for anyway?"

    I have two available replies, and they are identical:

    "South west of here, huh? (You make note of this on you Pipboy) Just wanted to make sure the Guild is as powerful as it claimed to be. I must be going now"

    I can provide a saved game if it would help.
     
Thread Status:
Not open for further replies.