Fallout 2 Restoration Project 1.2 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jun 9, 2008.

Thread Status:
Not open for further replies.
  1. GanymeDes-

    GanymeDes- It Wandered In From the Wastes

    Oct 11, 2007
    I think you need to use electronic lockpicks for those. If you are talking about the three black safes on the floor.
  2. Limbabnees

    Limbabnees Still Mildly Glowing

    Jun 17, 2007
    I also tried the Electronic Lockpick Mark II, said nothing about need electronics.


    Using High Resolution 1024x786

    Problem NCR Compleet Brahmin Raids. Normal need high Outdoorsman.

    Now it possible to see the green exit and possible to walk near original map...to Vault 13!
  3. GanymeDes-

    GanymeDes- It Wandered In From the Wastes

    Oct 11, 2007
    Yeah, I noticed that too.
  4. Wings012

    Wings012 First time out of the vault

    Sep 5, 2008
    I was thinking, hasn't Gauss weapons been a bit too nerfed?

    I find it doing like... 4-8 damage on regular shots against Advanced Power Armour(while criticals still fuck them up a tonne), but against like Frank Horrigan.... it does 0 damage criticals! 0 damage blinding! Its totally whacked. Somehow the 3/2 as opposed to the old 2/1 damage modifier seems to change things a fair bit.

    Although for some reason, the Pulse Rifle totally rips the hell outta Frankie.

    That said are Alien Blasters still available on traders over Modoc? Lurking around there while I was above level 17(I remember that being a requirement), I couldn't find jack. I did find these new types of trader though, they would fall asleep during the conversation, wake up and attempt to sell a totally random arse item to you at a ripoff price(Minigun for 12k :/), tempting you with some whacked description of the item. And then they'd leave the area and refuse to speak to you anymore.
  5. Limbabnees

    Limbabnees Still Mildly Glowing

    Jun 17, 2007
    I found Mr. zzzzzzzz, after modify random encounters in the ddraw.ini "WorldMapEncounterRate=1"

    With "WorldMapEncounterRate=30" i kept driving around and he never came.
  6. Darek

    Darek is currently unavailable

    Jan 7, 2008
    It's not the Restoration Project but the AP ammo fix you chose to install with it. You can change it back to default in ddraw.ini.

    That is the trader you want, what he sells you is random, sometimes he's carrying the alien blaster.
  7. Ragfox

    Ragfox First time out of the vault

    Jun 17, 2003
    I was browsing the text files included in the /cuts directory and I've noticed this:

    [spoiler:d23bbdc20a]In NAR_VA2.txt the phrase "you banished yet another species to the realms of extinction" has been modified in "you banished yet another species of the realms of extinction"[/spoiler:d23bbdc20a]

    Wasn't "banish to" the correct form?

    Just curious ;)

    (I don't know if somebody has already pointed this out. If so, I'm sorry.)
  8. Limbabnees

    Limbabnees Still Mildly Glowing

    Jun 17, 2007
    Question for the next version.

    I liked the idea of the Survivor Mod, No more stealing from Shopkeepers, all critters have weapon in hand, instead of in inventory. And much more.

    Please think about this...

    Just extract the survivor.exe patch and try to combine, but its not my thing :D
  9. Devhead39

    Devhead39 First time out of the vault

    Sep 11, 2008

    I recently reinstalled Fallout 2 and have been trying to get it to work for a few days now. I've got it almost completely up and running, and have run into one final glitch. After completing the opening portion of the game and being sent to Klamath to find Vic, I cannot move from the world map to the town map in any location other than Arroyo. I am running:

    Windows XP Pro w/ Service Pack 3
    Fallout2 1.02d US version, Medium install
    F2RP 1.2, installed via Windows Installer version

    Has anyone else experienced this issue?
  10. Kanhef

    Kanhef Vault Dweller

    Sep 2, 2007
    If you're trying to enter towns by using the town/world map button, note that that only works after you've been in the town; the first time you have to click the green triangle on the map.
  11. Devhead39

    Devhead39 First time out of the vault

    Sep 11, 2008
    Well, Thank you very much, and I feel pretty silly now.
  12. wr3ck3d

    wr3ck3d First time out of the vault

    Aug 27, 2008
    I think i found a bug with the kaga diplomatic encounter... i saved the game there (i had used some stupid shortcut techniques to get power armor --> it was my second play! sorry!) and then i reloaded it and the kaga diplomatic dialogue starts again, if i save reload save reload i can gain infinitely 500 exp for telling him off...

    another thing is, I found a bug with my world map that I've been able to recreate multiple times with federation shuttle and the whale random encounters... through different games and fresh reinstalls... i first noticed that strangely the federation shuttle random encounter disappeared on the world map as soon as i stepped into the exit grid, after traveling along awhile, i decided to revisit sulik's primitive tribe, this is where i noticed that federation shuttle and the whale encounter were stacked right on top of each other as locations on the world map. when i try to enter into these locations usually the whale will load despite the federation shuttle being on top of it...

    so these two bugs:
    1. Kaga diplomat, reload save reload will give you infiinite 500 xp, as long as you pass the speech check each time
    2. weird, world map interaction with federation shuttle random encounter + whale encounter...

    -- EDit

    i played for awhile longer, and in one of my reloads, i chose the NEVER! option, which kaga never reappeared to fight me, so i just ran off into the exit grid to see if i would encounter him later... and yep there he is!
  13. Limbabnees

    Limbabnees Still Mildly Glowing

    Jun 17, 2007
    Future requests:

    About our "Wonder Boy" Myron.
    Maybe boost his stats a little, he isnt able to locate the coordinates from the Hobologist Stash. Need Science 125 or more. Needed to boost my own Science, what i usually do too :D
    But still...
  14. Darek

    Darek is currently unavailable

    Jan 7, 2008
    No no no, changing NPC stats is not an option. You could argue for a lower science check though, but I think it's a bad idea. Everything shouldn't be available to everyone... where you put your points should make a difference.
  15. Kanhef

    Kanhef Vault Dweller

    Sep 2, 2007
    A bit of a nitpick: the critical hit message "almost tipping it over" (line numbers 6405, 6705, 6805, 6905 in combat.msg) isn't accurate. For geckos and aliens, every critical hit that uses that message actually does knock the critter down, so it should be replaced with something that matches the effect. I haven't tested spore plants and giant ants yet, but I expect they'll be the same.
  16. Thassa

    Thassa First time out of the vault

    Sep 8, 2008
    Ack. Just about to finish the Modoc/Slags quest when the game started freezing. I got the quest from Jo, went to Jonny's father and got the quest to find Jonny, went to the farm, got the message, talked to Jonny, tried to talk to the Slag leader, took the message to Jo, talked to Jonny's father, and now every time I go to the farm from either of two saves the game freezes as soon as I enter the farm map. :(

    Listed the entire order of events just in case the problem is related to that.

    I'll try playing from an earlier save and avoid talking to Jonny before I finish Jo's quest this time around.
  17. ballystix

    ballystix First time out of the vault

    Aug 23, 2008
    application errors

    Hi there, i would first like to say how grateful i am to be using this restoration mod, like what others have said, im just replaying the game in preperation for fallout 3. However im running into some "application error" crashes.

    In the Narvora air base, one of the NPCs in the left most hangar map, clicking on him resulted in a "application error" crash. Like what others have said, no actual error message pops up, i get a black screen and the typical windows warning beep when something bad happens, music still plays in the background. I'm forced to minimize and end the task. Since no error message is visible, what i did was ctrl+c, which usually copies the error message into the copy/paste buffer. Below is the error for this specific case:

    Application Error: D:\Fallout2\FALLOUT2.EXE
    The instruction at 00489675 referenced memory at 00000640
    The memory could not be read from

    Click on OK to terminate the application

    This is not the first time this has happened. At the EPA, this crash occurs quite frequently when trying to access certain doors or computers, i could go through. Quitting the game, saving or reloading does not help, the crash seems reproducible no matter what is done. Someone mentioned closing more programs running in the background, i'll probably give that a shot next time i play.
    Other places where i've experienced this crash is at one of the bartenders at NCR, the one with the guy with the bad attitude in the left bottom corner of the bar (right before the president's entrance). So to sum up, the application errors have occured in 3 major places so far.

    The system im running:
    -fallout 2 version 1.02.25 RP 1.2 (quoting what is said in the bottom right corner of the main menu)
    -Windows XP
    -Running at 1280x1024 resolution
    -no other modifications to my knowledge..

    Thanks in advance
  18. killap

    killap Bear Dude Moderator Modder

    May 16, 2005

    Regarding the Navarro issue.

    Please upload/e-mail me a save game so I can see this error for myself. Go to your Fallout2/data/savegame directory and rar/zip the directory corresponding to your save game.
  19. GanymeDes-

    GanymeDes- It Wandered In From the Wastes

    Oct 11, 2007
    I've had many game crashes too but the only one that happened every time and couldn't be avoided was the Navarro one. If I close all other programs that I don't really need when playing I hardly get any other crashes at all.
  20. Sander

    Sander This ghoul has seen it all
    Staff Member Admin Orderite

    Jul 5, 2003
    Someone asked me to post this for him.
    Apparently, he can't find Trader Bill to get the Metal Armour from (this guide says he should be at the Abbey). He has Marcus in his party.

    Now, I loaded i1t (Fallout 2 with all of the Restoration Mod installed) up for myself and had a look around and couldn't locate any Trader Bill either. The only thing that might've been Trader Bill was a Mr Peterson in a shack to the lower right.

    Any hints?
Thread Status:
Not open for further replies.