Fallout 2 Restoration Project 2.1.2b (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Sep 18, 2010.

Thread Status:
Not open for further replies.
  1. SuAside

    SuAside Testament to the ghoul lifespan
    Admin

    May 27, 2004
    I had a week off at work this week, so I used it to run through the Fallout 2 Restoration Project v2.1.2b. It's been a pretty long while since I played the RP patch through. Anyhow, I've wanted to play it for quite a while now and now I finally got around to it.

    Here's my comments. A lot of things are negative, but I loved playing it through, I just highlighted what could be even better. Don't get me wrong, it's already great. :)


    Installer top notch work, easy as pie. Installed "full option". Bonus stuff like the NPC armor mod and so on is really great.

    Klamath:

    Nice mods. Really no comments there.

    The Den:

    Tweaking & enhancing the Locket & gang fight was nicely done.

    The orphans however, I had a problem with. Too upbeat.
    I nearly always play a "good" character, it's in my nature, but even I felt that the orphan issue went way over the top. The owner of a simple bar/restaurant opens up an orphanage in a town full of addicts? There is absolutely no way I can see that she could support that, unless she was somehow a huge landowner and ran a bunch of farms around the town.

    Anyhow, I liked The Den as it was. It was a den of scum and at the best, you could solve some of the issues (slavers, thin out the gangs, etc), but I liked that it remained grim.

    Modoc & the Ghost Farm:

    I had luck 10 on this playthrough. And EVERYONE ended up breaking a limb. Didn't quite expect that... First Cassidy broke a limb after the outhouse blew and then the rest of the bunch broke a limb falling down the trap in the ghost farm.

    That's a little much, wouldn't you agree? :)

    VC, Gecko & Vault Village:

    The addition of the village adds some flavor to both Gecko & VC. No real issues there.

    Adding the vertibird assault was nice, though I lucked out a bit, I think. I was still fairly low level, took out the gauss pistol wielding soldier with 2 shots of the hunting rifle to the eyes, looted it off the soldier and killed the pancor wielding soldiers. Luckily for me, none of them used burst on me... Could've turned out a lot worse. :)

    Raiders:

    Would've been more logical that very high outdoorsman would've been enough to locate the raiders, but I don't mind it much.

    Abbey:

    Very "A Canticle for Leibowitz"-y, but annoyed me a lot that there seemed to be no real protection. I'd have plopped down a retired caravan guard or something in front of the building to at least show some muscle to scare off some raiders & slavers. The whole thing just screams "easy target" to me... A trading post (reasonably well stocked) & a flourishing farm (enought to hand out food to strangers!) to raid and a whole bunch of pussies inside to sell as slaves?

    Didn't engage in combat, so maybe they pulled gatling guns out of their robes, but still, feels odd. If it was a secret place, maybe it'd make sense... But with a bunch of traders and whatnot working on the pump? Skeptical there. :)

    Broken Hills:

    Not much to say, fleshed out a little, it's nice.

    New Reno:

    The barking dude is pulled by the hair, but ok.

    Monte is nice to scam, but by the time I did NR, it didn't matter anymore.

    Nikki makes the Lloyd hunt easier, maybe too easy? I don't know. More logical at least.

    The comedian lines I got sucked. Jokes on Washington in post-apoc? Most junks and gambling addicts in NR don't even know what politicians are, let alone what Washington was/is?

    NCR:

    Tweaking the NC Rangers was nice. Safe houses, wiping out the slaver camp, finding Sulik's sister. Nice.

    Primitive Tribe:

    Hmz, I guess it's ok, but I never liked Tribals as a whole in FO2... But most of the stuff is well implemented, so at least that's ok.

    EPA:

    Couldn't find it, so googled the walkthrough. Didn't want to pick up Myron, but because I couldn't find the traveler chick (or well, I always got the NCR/VC traveler variant) to mark the location, I had to pick up that cunt Myron.
    Of course, as soon as I do that, the traveler shows up and tells me where the EPA is...

    Anyhow, the EPA is fairly nice. Some floor layout decisions feels a bit questionable, but overall pretty nice.
    Had to search a LONG time to find the fan thing. Never walked past that side, so no float... When I got there, I was annoyed I couldn't block it with a crowbar. Nope, had to be some flimsy piece of metal. Odd. ;)

    With the Petting Zoo, I had a kinda weird encounter. I let the "human animals" out and they went all "Oh noez, the evil one is here, run". I was like "WTF?" and didn't kill them (or well, Cassidy wacked one of them). I expected them to attack me & my party for food? This probably has to do with my T-51b? Anyhow, if they seemed intelligent enough to speak in that way, they might as well escape for all I care.
    How the hell did they survive a century in their cage anyhow? Can't imagine enough vermin crawling in & out of their cave to stay alive AND procreate...

    On to the frozen troika:
    I got Kitsune out, and wanted to unfreeze Dex for lulz. Couldn't. The game wouldn't let me after I used up the ESRI. And that while before I got the ESRI there was a choice to do it without? Annoying. Didn't want to risk someone unfreezing Dex later with some ESRI (from god knows where). Wanted him dead...

    On to Kitsune:
    You already read her background from the computer? Why not confront her with the lies she's trying to pass off at first?
    Also, I was annoyed that the supposed spy took you at face value and gave her long explanation if you asked her while still in the freezing room. That stuff should've been saved for after you went topside & she saw you weren't lying.
    What if "I" was an eleborate sham to coax intel out of her? Fake freeze the spy, have some actors "unfreeze" her, tell her some weirdo story about decades passing and the world being destroyed and BLAM! She spills her secrets. Or have I been watching too much spy movies?

    The whole EPA thing is also fairly heavy on the inside jokes and easter eggs. A flaw that already appeared in FO2, and it's really not helped with things like an asian chick with heterochromia, an authoritarian german dir of sec, Red Dwarf spoofs, etc. (also, isn't Dex described as a black man when watching the tank, but the model you see inside the tank is white?)

    Also no explanation I can think of to freeze a sociopath with a soldier & a spy... Other than 'testing' the freezing procedure, I guess.

    Crashed the game once in the EPA btw: when a float was supposed to appear above my head on level violet. Had to start from a save & then worked afterall. Strange.

    Big downside to the EPA thing: I lost Skynet there. He can't climb down, OK I understand. Came back up, don't remember seeing him (could be wrong), didn't think about him & drove off. In San Fran I think "hey, where did Skynet go?". Drive back to the EPA and Skynet isn't there anymore.
    Don't miss him, but he disappeared with a nice Gauss rifle and lots of 2mm EC ammo. :(

    San Fran:

    Not finished that completely yet, but looking forward to see what changed compared to the previous version.

    Kaga:

    Often bugs as he runs for it. Once crippled his ass (or rather, leg), but since I wanted to see him come back, I doctor'ed his leg and he ran off. :)
    Makes no sense whatsoever that he shows up in enclave armor last... It's retarded. T51b, sure. Enclave, fuck no.

    Navarro:

    I rolled in shooting, for once. Everything normal, but had a weird bug during fighting (only noticed it topside, underground they barely shot back ;) ).
    When I got shot at, and did not take damage (not that I noticed anyway) I often got ". " Followed by some text. So things like (paraphrase ". You cup your nuts as you try to shrug off the damage.". Normally, before the rogue ". " you'd have the damage? I think no damage was done, so the whole sentence for listing the damage was an empty string?
     
  2. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Sweet. I was waiting for the day that the NMA old timers get to playing the RP. I was hoping it would be after the next stability update, but we gotta use the free time we get. :)

    Thanks for the feedback. I'll hopefully get around to commenting on these when I get some free time at the end of next week. I appreciate comments that are critical, and from what I read in your post you've got good suggestions.
     
  3. drawnacrol

    drawnacrol It Wandered In From the Wastes

    126
    Dec 5, 2010
    Hey Killap, your doing great work on this restoration project, I've played through fallout 2 about 20 times and managed to beat version 1 without any patches which was a bug ridden nightmare.

    Its great to see all the restored content as well as playing the game start to finish without a single crash. Keep up the good work!
     
  4. Rantalot

    Rantalot First time out of the vault

    8
    Dec 11, 2010
    I am having trouble in the Primitive Tribe with camera not being able move into locations and locking me out. The woodland area is fine the first time i enter it, but when i return to it from the village I cant exit since the camera wont allow me to move towards the exit grid. If I return to the village from the woodland area the village also gets all screwed up and prevents me from moving the camera into numerous locations. I got this mod from MIB88 MegaMod Installer Version 2.42. If i try to download the latest version of your mod and install it over the megamod my save gets all screwed up. Is there a fix for this?
     
  5. .Pixote.

    .Pixote. Antediluvian as Feck
    Modder

    Sep 14, 2009
    I think the orphans also need an evil outcome - such as setting up the orphanage and then forcing them to steal for you, or selling them to Metzger...of course Mom will be pissed and basically hate you. But maybe you can rent the kids back to Flick, Fred and Tubby (high speech skill), then take a cut of the takings once a month (barter skill check)... :twisted:
     
  6. DGT

    DGT It Wandered In From the Wastes

    148
    Apr 7, 2006
    I think he was referring to the difficulty of funding the orphanage, i.e., where the hell is Mom getting the food from? Can't just be from her restaurant, feeding that many orphans would run her out of business.
     
  7. The Master V2

    The Master V2 First time out of the vault

    17
    Sep 24, 2010
    I think that's an awesome idea for an evil character, Pixote. It really should be included in the next release. :clap:
     
  8. Dartagnan1083

    Dartagnan1083 First time out of the vault

    5
    Dec 11, 2010
    First post, pitty it had to be tech support;

    Playing with the restoration mod (most current version I believe).

    But I'm having a few problems that just popped up.

    1. Getting a blank screen whenever I die instead of the CG pics. the dialouge still plays. Have not found anything useful when searching for a fix to this via google as I did for the other startup problems I resolved.

    2. Just finished the Modoc quests, found a hunting rifle and got the assault rifle from the scags. Both do not work.
    They load and unload ammo via the inventory screen, they animate during weapon switch, but they appear in the item/hand box as simple items with no ap cost displayed near. Sold the hunting rifle, in barter, reopened conversation and found 2 hunting rifles in the NPC's inventory.

    What's going on?

    EDIT: apparently cant use anything with the 'rifle' graphic on my character. Also can;t use the sledgehammer despite having used it earlier.
     
  9. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    @Dartagnan1083

    Sounds like a broken installation. How did you install the RP? What OS are you running?

    The tried and true install steps are:

    1. Install original game (humongous install). If you are running Visa/7, be sure to NOT install in the c:\program files directory.
    2, Install the RP from my sig.
    3. Enjoy.

    Nothing else.

    Also, be sure to check that the main menu says 2.1.2b and the rock at the start of the game also says this.
     
  10. WolfWitness

    WolfWitness First time out of the vault

    27
    Jul 20, 2009
    Regarding the funding of the orphanage, Mom did say she has some from friend who can help set it. That doesn't say they won't support it monetarily at least a little bit. Are odds are Rebbecca Dyer is one of those friends.

    As for the viability of the Orphanage quest itself, aside from Pixote's option, I'd say it should be available only after you get rid of Metzger. After all, the Den becomes a "tough but honest town" with him dead and Rebbecca is still around.
     
  11. Dartagnan1083

    Dartagnan1083 First time out of the vault

    5
    Dec 11, 2010
    running Windows 7, installed game to new directory and the RP with the installer from your sig and not the one from the website. Installed FO2 with gog installer.
    also edited scripts to correct graphical and audio problems.

    as an added bonus, the Death slide just popped into view on my most recent death.

    EDIT: reloaded an earlier save and everything seems fine. . .aside from the white/blank screens at death.
     
  12. toneone

    toneone First time out of the vault

    34
    Mar 24, 2009
    Hey folks,

    now i've just tried the new RP but i've ran into an ugly snag.
    When i try to exit via the northwest exit of Klamath main, the game crashes and my desktop is black until the OS has dealt with the termination of the progress.
    I can tab-select several other things but the background stays black till the termination and problem analysis crap from vista is finished.

    The only thing i can gather is "application error/fallout2.exe".
    i've re-installed the game(large instal) and the RP three times now to test different stuff and to rule out some things, but it persists.
    i've also seen some "error" messages instead of dialouge lines, like the rock in the beginning(error as description) or when i fondle the chest of my tribal healer.

    i've come to suspect my base version of FO2 to be at fault.
    Its german for starters, but that could only be the cause of the dialouge errors, IMHO.
    Is there a localization file which governs this?
    My version of the game is 1.01 and it came as a "white label" edition with FO1.
    Maybe the large base install is missing something?
    Or the structure is different for it?

    Rundown
    Crash: Northwest exit of Klamath main
    OS:Vista home premium
    FO2: 1.01 german "white label"
    Instal:
    Followed everything in the readme, tried both methods.
    Installed to a custom directory instead of "program files".
    Checked design stuff in compatibility window and running as admin.

    Savegame:
    http://ul.to/y9lhs9

    I would be very glad if anyone could offer me some help!
    thx
     
  13. SquishyDeadBody

    SquishyDeadBody It Wandered In From the Wastes

    142
    Dec 27, 2006
    Killap if you don't mind can you update your first post with the bolded selection that I have quoted from you? Also put it in the Readme that comes along with RP. I wish I would have known of this issue awhile back but I accidently fixed it on my own when trying to use the mapper.
     
  14. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I actually plan on adding a check in the installer to warn the player that the game is in a directory that might cause problems. I'll still include it in the readme and in the first post of the RP thread.
     
  15. SquishyDeadBody

    SquishyDeadBody It Wandered In From the Wastes

    142
    Dec 27, 2006
    @killap

    Thats an even better idea. Thanks man you're awesome
     
  16. Dravean

    Dravean Where'd That 6th Toe Come From?

    478
    Mar 6, 2005
  17. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Yep, that's exactly it. The German game got some of the gore cut out.
    Since the RP is using the US fallout2.exe the game don't know something is missing and tries to load the stuff anyway.
    You need the Blood patch.
    Also, for the text errors you need to rename your ...\Fallout2\data\Text\English folder to ...\Fallout2\data\Text\German (after you have installed the RP).

    Maybe you could add something about this to the readme too, killap?

    Oh yeah and Dartagnan1083, I'm pretty sure you couldn't use your two handed weapons cause one of your arms where broken.
    Seems to happen a lot in Modoc, I wonder why that is. :whistle:
     
  18. toneone

    toneone First time out of the vault

    34
    Mar 24, 2009
    Hmmm..seems like i fixed it.

    By going into Fallout2/data/text and renaming the "english" folder to "german" i fixed the error messages and i can now use the northwest exit in Klamath.

    Might wanna include this in your OP/instructions in regard to foreign FO versions.
    Although i fail to grasp how this detail can effect map transitions in the game...

    :scratch:

    @Darek:
    replied while i typed.

    Yeah that could also play into it.
    The map in question has the robot and if i remember correctly there were dead enclave soldiers which were removed in the german version?
    Not 100% sure will check now.

    can i just slap the BP on top or do i have to follow a certain order?
     
  19. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I'm pretty sure I mention the text renaming for international versions in the readme. As for the blood patch, I guess I could include that in the installer. Should be easy enough to do.

    EDIT: It's just missing animations that are at fault, right?
    @toneone
    Extract the gore patch (to a tmp directory) and then copy over just the files found in data\art Nothing else.

    @Dravean
    Yeah, I need to update the readme files with that new link as well. Thanks for the reminder.
     
  20. Zaius238

    Zaius238 Art by Phoenix-Private

    177
    Jul 14, 2007
    Hello people, long time no see.

    Mr. killap, I found a bug in The Den, with Lara.
    You can see for yourself, here is the save folder, slot 10:
    http://www.easy-share.com/1913265082/SLOT10.zip

    How I came to the bug? I'll try to explain:
    First I accepted to attack the church with them (Lara's gang). After the fight, she told me to go to the local of the party, to kill the remaining guys. I asked her to wait a minute, and I ran to Tubby's, to buy stimpack. I entered in combat mode to pass the entrance of the store without getting robbed, was then that I saw Lara's gang in the house below. When I talked with she and her gang, they say things like: "Let's go! Everyone follow me!", "I gonna kick some asses!", "They're dead meat!" like if they were going to attack the church. And what these idiots are doing in the left side of The Den, they should be waiting for me in the right side of the city! I hope you correct that.
     
Thread Status:
Not open for further replies.