Fallout 2 Restoration Project Gameplay Thread

Discussion in 'Fallout General Modding' started by killap, Jan 13, 2008.

  1. phantomOmega

    phantomOmega First time out of the vault

    2
    Jul 26, 2009
    I believe I may be encountering a bug when I reach the Enclave. From the entry hall, I proceed south to an elevator. When I step on the elevator, I'm given the options Vertibird Unloading Platform and Entry Hall. I don't see any way to proceed to the detention area.

    Anyone else encounter this?

    I'm running the 1.2 version of the Restoration Project.
     
  2. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Yes, you are not the first :)
    Just next to the elevator you will find the original set of stairs that will take you to the detention area.
     
  3. phantomOmega

    phantomOmega First time out of the vault

    2
    Jul 26, 2009
    It's pretty tough to spot that staircase :oops:

    Thanks for the assistance.
     
  4. rolandoftheeld

    rolandoftheeld First time out of the vault

    5
    Oct 16, 2009
    Accidentally posted this somewhere else, not knowing of this thread. Reposting:

    Running 1.2 US on XP, with the full installer and the three extra fixes, and nothing else.

    In a new game, in Arroyo, Entering my Pipboy Automap screen and selecting any map generates a new option called "Desert", though selecting it shows a blank screen. Entering a new area (and other triggers I haven't been able to determine) creates more "Desert" options, and selecting the third "Desert" causes a fatal crash, presumably because it fills a slot that no Arroyo map exists in.

    Attacking a Golden Gecko with a (Combat) Knife in the Toxic Caves (and possibly elsewhere) causes a fatal crash.

    Fatal crash in Random Encounter Robber Cave. Not sure of cause.

    Saving on a Kaga encounter map and loading causes the encounter to restart, even if finished. Any XP gained (e.g. through dissuading him from killing the player) can be collected repeatedly.

    EDIT: Fatal crash when quicksaving outside a cave encounter. Save corrupted.

    After all this development, is this honestly still so unstable? Does this happen to everyone else, or should I try a reinstall?
     
  5. Lord Danath

    Lord Danath It Wandered In From the Wastes

    130
    Jan 14, 2008
    Are those crashes you mention happening every time you do those actions or are they random?

    If they are random, then it's probably not the fault of the RP but rather of the game itself (which let's say, is a bit unstable sometimes with or without mods)

    Also:

    It's actually quite stable. Certainly more stable than the out-of-the-box game.
     
  6. rolandoftheeld

    rolandoftheeld First time out of the vault

    5
    Oct 16, 2009
    Some of them seem random, some not. The Geckos and the Automap crashes are (for me) reproducible. The others I did not have the opportunity to try, one being a random encounter at which I had not saved, and the other obviously corrupting the save.

    I have since uninstalled RP, and am playing with only the killap patch. I might reinstall again, but for now I think I'll just mess around in what I know is a relatively stable environment.
     
  7. Kanhef

    Kanhef Vault Dweller

    793
    Sep 2, 2007
    Did you remember to delete patch000.dat?
     
  8. rolandoftheeld

    rolandoftheeld First time out of the vault

    5
    Oct 16, 2009
    At which step?

    Also, I probably should have mentioned that I am NOT playing in 95/98 compatibility mode. I don't know if that makes a difference here.

    EDIT: After a bit of research I learned about the patch000.dat problem, but also read that the installer was intended to automatically take care of that. I can't vouch for its (non-) existence when I had the crashes, but if the automatic installer removes it, it wasn't there. After my uninstall and just the patch install (i.e. now), it is not there. I'm still getting similar crashes now and again, but these are infrequent enough that I feel justified in chalking them up to good old fashioned game instability.
     
  9. RoBoBOBR

    RoBoBOBR First time out of the vault

    4
    Jan 12, 2008
    Does quest to find out about Becky's still has any requirements? I did fresh install of f2, then RP+fixes, but when i get to Den i can't even ask Frankie why is it, that Becky's booze is cheaper.
     
  10. Darek

    Darek is currently unavailable

    Jan 7, 2008
    You have to ask Becky for a drink first, so you know how much her's cost. How could you otherwise compare prices?
    Also (I don't think this is mentioned in any guides), if you buy 4-5 drinks from Becky, she will consider you a good costumer and tell you about the still if you ask her, so you wont have to sneak downstairs to find out about it.
     
  11. RoBoBOBR

    RoBoBOBR First time out of the vault

    4
    Jan 12, 2008
    Well, that's the problem - i buy dozen drinks from Becky, ask her about dryer every time and still option to ask Frankie about the price is unavailable.
     
  12. Schierke

    Schierke First time out of the vault

    2
    Nov 7, 2009
    How am i supposed to fix the well in the Primitive Tribe?

    I use the rope and talk to the guy next to the well but i can't use the bucket in any way.

    Am i missing something?, any help would be greatly appreciated.
     
  13. Photeus

    Photeus First time out of the vault

    17
    Oct 25, 2008
    For the well - just did it last night.

    Use rope on the well after I got the quest, talked to the guy, he tells you to use the bucket. Pickup the bucket, and then use it just like the rope you used on the well. Should attach that too.

    I had basic repair skills (<=20%), so shouldn't require more than that (I don't think it requires anything)

    -----------------------

    To avoid a double post - had a question:

    Would it be of interest for people to have a sort of Effciency walkthrough for the Restoration Project? I'm currently working on one for myself which I'd be willing to share once it's complete.

    And when I mean efficiency, I primarily mean:

    -Doing as much/as many quests as possible in the shortest period of time.
    -Maximizing what is done at each location with every visit.
    -Minimizing visits to locations (Most 2 visits, some no more than once)
    -Being told what items to pick up for upcoming quests (to avoid running back and forth when possible)
    -Being told what order to visit which locations.
    -Maximizing what can be done in a single trip (For example, I tend to just go back for the car by going from Gecko to Den with no stops in between - so it's a time-wasting side-trip usually - my guide would give locations to go to WHILE heading back for the car to make the trip more fluid and quest-useful.)
    -Keep Game progression around intended levels; This is an alternate take on a speed game. You move fast, keeping a steady pace, but are still taking advantage of MOST (actually almost ALL) of the game's content.

    I noticed a couple of people expressing interest and so figured this was the best spot to ask if that interest still existed (or if I was waaay beaten to the punch).

    And to stay with the topic - Loving the RP mod, especially roaming the EPA. It was fun trying to figure the whole place out without knowing exactlly what to do and where.
     
  14. +PipManiaC+

    +PipManiaC+ First time out of the vault

    10
    Nov 15, 2009

    did you try to re install it then set all script and protos to read only?
    idk if this can help..but i think it can lol XD..
     
  15. krazzer

    krazzer First time out of the vault

    2
    Dec 21, 2009
    I found a bug, when i got the quest to find out what happened to the hunting party, i accidentally killed serin. When i went back to the head warrior of the tribe, he said it was a great loss (which is correct) but when i spoke to the shaman he said he is gonna be allright...

    Although i know the shaman is a bit crazy :mrgreen: this is a bug
     
  16. virus16bit

    virus16bit First time out of the vault

    1
    Jan 12, 2010
    Having big trouble with Redding Wanamingo Quest!!!

    Sorry to be a pain on here but I think I have found a possible issue, but in case its not I am trying here first.

    I am playing through Redding and I got the Wanamingo Death March Quest. So I went through (after picking up some additional firepower) and killed them all, eggs included. But when I go back up to the Mayor he says I didn't get them all. HELP!!

    I have gone through every section and every exit/entrance on the map. I can rest in every area wioth no problem. But I STILL cannot complete this quest. I even loaded a back save and tried going through it again. Same issue!!! Please help!!!

    I am running Fallout 2 Fully Patched with Killap's RP 1.2 and the Hi Res Patch. I can provide a save if there is someone on here who can look up the problem. I could proceed without finishing the quest, but I'm a little OCD and that would really grind my gears not to be able to finish this quest. Any help would be appreciated. Thanks!
     
  17. McRae

    McRae For sale: clown shoes, never worn Orderite

    Dec 9, 2007
    @ virus16bit :

    You know, once I thought I killed them all, but there's a place where they're well hidden.

    The best thing you can do to be sure that it's not a bug, is to use the motion sensor in every sector of the mine. If one of them is still alive, you'll immediately know it.
     
  18. ufo_hunter

    ufo_hunter First time out of the vault

    59
    Feb 29, 2008
    In my current game Vic always attacks me if try to leave him. What's the problem?? This has never happened to me before?
    I usually get a yellow float by vic saying "that feels good, doesn't it" when he shoots me the first time.

    I did not notice it before because I didn't try to leave him until I came back to Den for the car and went to toxic caves to rescue Smiley. There I tried to leave him so he would not step on goo.I did not pay for Vic when I first got him. I locked the doors and took out metzgers gang one room at a time. During that I told Vic to come along and join me.

    -----------edit-----------
    I tried all my save games back to where I am about to leave den the first time with Vic. Allways the same thing. If I try to leave Vic he attacks me. Funny thing is...if I run of the map and come back I can walk near to him as long as he doesn't see me (ie from behind), talk to him and tell him to join me again!

    I have not hurt his daughter.
    -------------------------

    Not related to above, but Frankie in Den somehow got mad at me and now tries to attack me if I go back inside his bar. So I was not able to get the still-quest.
     
  19. Recon Rover Rick

    Recon Rover Rick It Wandered In From the Wastes

    130
    Aug 21, 2008
    Was Vic ever knocked out, and you clicked on him getting his inventory screen? Kinda sounds like that bug.
     
  20. ufo_hunter

    ufo_hunter First time out of the vault

    59
    Feb 29, 2008
    No, I am pretty sure he was not knocked over. Vic did receive some nasty damage later on, but in Den he was not hit so much and this problem is found in all my saves where I have him.