Fallout 2 mod FO2 Engine Tweaks (Sfall)

Discussion in 'Fallout General Modding' started by Dude101, Jul 30, 2007.

  1. agris

    agris Still Mildly Glowing

    263
    Jul 8, 2004
    @burn see above. it wasn’t my mod causing the crash, it’s generalized behavior. Your test scenario didn’t capture it because, I’m guessing, a series of memory-manipulating actions needs to pile up before this component triggers a crash.
     
    • [Rad] [Rad] x 1
  2. The_Den_Resident

    The_Den_Resident It Wandered In From the Wastes

    152
    Jan 26, 2022
    You've also had these crashes too? Well, I guess I also have to ask where were you pointing that out when a prostitute in New Reno was crashing my game a on Jan. 30th? lol
    Not that I'm throwing dirt at you with that last sentence you could've been busy or missed my post. How long have you been having these issues? It's good to know someone has been having similar crashes. Even when I fixed my bug relating to the prostitute or NPC crashing the game using the wrong item name. I still get this occasional explosive thrown on empty hex bug, sometimes it crashes for me and sometimes it doesn't. =/

    Nonetheless, if @NovaRain or @burn decide to re-read my edited post about the thrown explosive bug. They're more than happy and welcome to try to fix and I would appreciate their time to do so =)

    (I edited my bug report post and this post for more clarity.)
     
    Last edited: Mar 13, 2022
  3. burn

    burn A Smooth-Skin
    Modder

    642
    Apr 22, 2012
    I'll try to reproduce when I have time.
    Anyway, better to report bugs to github, if you don't want them to be forgotten. Forums are harder to keep track of.
     
  4. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    sfall 4.3.4 and 3.8.34 are released on SourceForge, along with their respective modders packs.
    Note: If anyone is interested in how the engine or some code in sfall works, you can download the IDA databases and check them (require IDA Pro 6.8+, comments are in Russian).
     
    Last edited: Apr 7, 2022
    • [Rad] [Rad] x 3
  5. sosna

    sosna First time out of the vault

    4
    Oct 25, 2014
    Hi,
    sfall 4.3.4.7 and rpu v26
    When i activate party control=2 after my companion's turn the picture of my weapon doesn`t change. Only after changing hands does the correct one appear.
    I remember there was no problem with this in the older version Sfall
     
  6. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Try this script.
     

    Attached Files:

  7. sosna

    sosna First time out of the vault

    4
    Oct 25, 2014
    it works - Thank You !!
     
  8. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    sfall 4.3.5 and 3.8.35 are released on SourceForge, along with their respective modders packs.
     
    • [Rad] [Rad] x 1
  9. Helpman

    Helpman First time out of the vault

    2
    Dec 22, 2016
    I found that there is a maximum number of party members I can have join me even though I have fallout2tweaks installed. Under unlimited party, it mentions that "All original game and RP NPCs are already included." How do I fix this?


    Edit: on a different note, trying to use the sfall HRP makes my screen pulse whenever an animation plays, giving it an almost sand feel, like worms are moving beneath my screen.
     
    Last edited: Jun 17, 2022
  10. mrowrpurr

    mrowrpurr First time out of the vault

    3
    Jun 19, 2022
    Hi all, I'm having a problem compiling a script using any fs_* functions

    The compiler that comes with sFall Script Editor 4.1.6 (also tried 4.1.7 RC0) simply tells me expecting ';'

    Here is the code I'm trying to compile:

    #include "../headers/define.h"
    #define NAME "gl_mymod"
    #include "../headers/command.h"

    procedure start;

    procedure start begin
    if game_loaded then begin
    display_msg("Please work?");
    fs_copy("path1", "path2");
    end
    end


    I really wanna get these functions working :cry: Thanks in advance! Loving so much of what sfall adds!

    Edit: it compiles when using a variable but I can't get it to work :(

    file:=fs_copy("color.pal", "color.pal"); <-- compiles

    I set UseFileSystemOverride=1 in my ddraw.ini and it's still not working...

    UseFileSystemOverride=1 is still available in ddraw.ini, so I'm guessing this feature should work / is supported? It's documented in sFall Script Editor and the sfall-team official docs. Anyone know?


    I'm testing by trying to override an animation (of the idle of the ants in the temple, just to test)

    file := fs_copy("art/critters/MYIDLE.frm", "art/critters/MAANTTAA.frm");
     
    Last edited: Jun 25, 2022 at 8:01 PM
    • [Rad] [Rad] x 1
  11. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Use art_change_fid_num() instead. Much easier to change critters like that.

    That said, I'm pretty sure you are missing the /data/ folder?
     
  12. mrowrpurr

    mrowrpurr First time out of the vault

    3
    Jun 19, 2022
    The docs say that it's relative to the data directory. Although, yeah, I tried with data/ and also used \\ slashes per docs and nothing working yet.

    Can I use art_change_fid_num to switch to use an animation that's provided in data\art\critters\ but not defined in a proto?

    I'm trying to make a mod that's compatible with all mods, which means no adding protos, if I understand correctly.

    I want to change a critter to use my animation files for a brief period of time during gameplay. That's why I was going the fs_copy route to start with.

    I basically have a zzzzzzAA.frm idle and would like to assign it to a critter at runtime (without editing any files that contain sequential numbers, to keep it compatible with other mods)
     
  13. mrowrpurr

    mrowrpurr First time out of the vault

    3
    Jun 19, 2022
    Note: it's not critical for me to use a specific critter, I'm happy to spawn whatever critter.

    My backup plan might be to use one of the "Hero * (don't use)" protos because I'm guessing that they're not used? But other mods could use them.

    Thanks!

    Edit: Lexx for it working & helped me get it working (and NovaRain too!)
    example: https://github.com/rotators/Fo1in2/...e/scripts/GlobalScripts/gl_classic_wm.ssl#L66
     
    Last edited: Jun 26, 2022 at 3:14 AM