Megamod 2.44 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Jun 22, 2011.

Thread Status:
Not open for further replies.
  1. zaopatrzeniowiec

    zaopatrzeniowiec First time out of the vault

    41
    Dec 1, 2011
    ScaleFilter set to 1-6 with six tests.
    TextureFilter set to 1.
    GPUBlt set to 1.
    Every time resulted error 'the instruction at 1004d273 referenced memory at 00000000. the memory could not be read from. click on ok to terminate the application.' And the second one instantly after preious 'the instruction at 0x1004d273 referenced memory at 0x00000000. the memory could not be read from.'

    If set GPUBlt to 0 and repeat test following your instruction game will start but there is no cahnge in its speed.
    May be it will helps if I start from beginning.
    I have xp pro sp3, athlon 2,8 three cores, radeon 4950, 4GB ram, newest direct from some game. I never had any problems with oryginal Fallout game - ita always worked perfectly. Even now I canplay it.

    So help me from here, after instaling Fallout 2 1.2
    Im extracting mod (manual or instaler version) following given instructions about removing patch000.dat, checking proto files to read only etc. And this is obviously something wrong in my actions. May be I should download other version of game or what? Please show me the way step by step coz I want to play this mod when I still own computer wich can ahndle such a old game.
     
  2. desmondhun

    desmondhun First time out of the vault

    1
    Jun 27, 2012
  3. spejder

    spejder First time out of the vault

    1
    Jul 12, 2012
    When in combat and hovering the attack icon over a target it displays the wounded information and look information everytime. this is quite annoying and is cluttering up the chat.
    Is there any way to disable this?

     
  4. SPIT

    SPIT First time out of the vault

    21
    Nov 20, 2003
    Game seems stable, but I can't use holodisks and maps - what's wrong with that?

    UPDATE: 2.44 fixes patch solves the problem.
     
  5. Gabby_me

    Gabby_me First time out of the vault

    4
    Aug 10, 2012
    MIB88, I am truly sorry of what I need to tell you. I wanted to contact u earlier. I have a problem with the Megamod. Please, don't take it as an offence, all right? Because you made my dream come true, man, honestly. I always wanted to play Fallout 2 with many locations, and ONLY you made this possible, i think you know it very well. Well, ok, back to my problem - yesterday I downloaded Megamod, version 2,44 from Nirran Fallout 2 downloads. Ok, I extracted the mod into Fallout 2 directory, I ran 'Process Dat2' as it was required, I started the game. When I try to enter the Temple of Trials, I hear an error message and I cannot continue playing... it's the kind of error that it makes the game crash... I played an earlier version of this mode, and this stuff didn't happen. Can you help me? Please, you're the only hope I have.
     
  6. Drobovik

    Drobovik Vault Archivarius Modder

    417
    Jun 20, 2011
    Come yourself, my man.:) Mib88 is on indefinite vacation.

    What you should do is use windows installer instead. It would do the work for you correctly. It is on the same Nirrans site.
     
  7. Gabby_me

    Gabby_me First time out of the vault

    4
    Aug 10, 2012
    Hi Drobovik, I appreciate your intention of help. I already used the windows installer, i renamed "Patch.000" as other guys said. But now I'm facing a different obstacle (damn it!) . I get error message when I try to load saves . Oh God! Will I evermanage to play this mod without problems?
    Hard to say... Anyway, now it gives the same error when I try to quickload . It says something about ... point breach ... I don't remember it exactly, and I didn't found any leads on forums about this.
    Thank you. :cry:
     
  8. Drobovik

    Drobovik Vault Archivarius Modder

    417
    Jun 20, 2011
    Gabby_me,

    Ok, you have something very wrong going on with your installation or computer hardware (software). Let me know what windows version you running, computer specs, and preferably a screenshot of your installed Megamod folder. And maybe a screen of the error that pops up.
     
  9. Gabby_me

    Gabby_me First time out of the vault

    4
    Aug 10, 2012
    I captured a screenshot with the megamod folder. Unfortunately, I got no idea how to attach it . I'm sorry... Anyway, i tried to install megamod in a different folder (not in the game directly as I did before,then I took a screenshot which I wanted to show you). So, I copied the data folder, and then the fallout 2 exe file. Now, I enter the game, and when I try to enter the temple of trials, it shows my newly created character running around in an empty dark screen without to be able to exit the temple, without any ant or something attacking...
    This will never work, I can only dream from now on.... over and over waiting for a miracle which probably - will never happen. :(
     
  10. Gabby_me

    Gabby_me First time out of the vault

    4
    Aug 10, 2012
    Uh... Drobovik, I was thinking... can u give me an email adress or something? Please, I would be easier and faster...
     
  11. RYU

    RYU First time out of the vault

    7
    May 16, 2010
    Hello!

    1. I'm experiencing a freeze from a certain Hairy mole rat death. It happens sometimes when a mole receives a critical hit. I think that it's maybe connected to a certain death animation, because there are several critical deaths I saw without problems.

    2. Also very rarely I experience a strange glitch that can only be explaned as shooting into myself. When I shoot burst of bullets at someone I recieve ~250Dmg myself and die.


    I use Megamod 2.44 (+ fixes) (-weather.ini and weather script.)
    I have Nirran's books mod installed.
    I have sfall 2.17

    Windows 7 SP1 x64



    Btw
    You can answer me in Russian
     
  12. flyingfishfuse

    flyingfishfuse First time out of the vault

    1
    Aug 31, 2012
    I'm using megamod 2.44 on wine 1.4 with a fresh install of fallout 2 and I cant see aanytthing in the temple of trials....it seems to be that i get placed in a blank map
     
  13. zaopatrzeniowiec

    zaopatrzeniowiec First time out of the vault

    41
    Dec 1, 2011
    Can u tell me why i have no music and talking heads are no talking in my game? Also i cant get flint from aunt. No dialog option for that.
     
  14. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Back! Well... mostly. Still a few things to take care of. But, I will be returning to modding again relatively soon. First, to answer a few questions:

    Hmm. Not sure what either of these problems are about. I have experienced neither of them. I will keep my eyes open for these.


    It may just be a bad install. Not seeing a map (blank screen, only the player character can be seen, and many ghost images being made) usually means that there are items on a map that cannot be read... and thus the sign of a bad install, missing files, or trying to add another mod over the Megamod.


    No music? Missing music files or you need to change your Fallout configuration file. You might have the game looking for the music files in one folder when they are located in another. And, how do you know Morlis has the flint? Rather, how does your character know? Don't jump to conclusions. If no other characters told you she has it, then why should you get a dialog option to ask her about it?
    No talking heads? Well, if it is "new" dialog, or a new talking head, there are no voice files. Sorry, but I don't have any connections in Hollywood in order to get those original cast members to read the new lines. If it is old dialog, then the problem is related to the above: You have some missing files in your install.

    So, version 2.45 is underway. This is from the current change log:

    Changes/Fixes made since version 2.44:

    -Addition of a new party NPC
    -Numerous fixes to party NPC, Vault 14, New Reno, and other scripts
    -Removed the weather mod
    -Numerous fixes to the BoS facility scripts
    -Numerous minor dialog corrections
    -Removed scripts from more items, thereby eliminating the dreaded "too many items bug" that results in the missing Skilldex button
    -Added conditions to be able to wear/use power armors. (Take that, cheaters! :P )
    ---Maybe a certain item will allow you to wear power armors
    ---Maybe there is a level requirement
    ---Maybe certain NPCs can help you
    -No longer start with the Idolized reputation in Scraptown


    Please don't freak out about the power armor requirements. They really aren't that difficult to satisfy. The only thing it really prevents is running to Navarro and getting an armor from there right at the beginning of the game. (Well, you can still go there, but it would be a waste of time to go there just for the armor.)

    Also, I would like a little input. As I said above, I have added a feature to keep the player from wearing an armor that he does not know how to wear. I am curious: what else should this apply to? I could make it for weapons, for example. Say, if the player doesn't have a certain skill level in energy weapons, he can't use the Gatling laser. Don't worry, that is just an example. But, I really could add conditions to weapons or other items. Any ideas?
     
  15. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Good to see you're still around, MIB88.

    Keep up the good work!
     
  16. bombic85

    bombic85 First time out of the vault

    19
    May 22, 2010
    Great to hear from you again. It's been so long since your last post that i was wondering if you hadnt perished in the wasteland or even worse... lost interest in Fallout and started living real life :shock: :lol:

    As for the weapons requirements, you could link their availability not with corresponding skill(%) but with overall experience(pts.) For example if you have a thing for bozar, you put all your percents in Heavy weapons, then just drive over to SF or NCR or some other place and quite early in the game you have superiority in firepower in locations, where you are expected to be running around with saw-off shotgun or desert eagle.
    But if you are required to reach certain experience to use it, there is no other way around then to slowly and patiently level up and build your character.

    I dont know, does it make any sense? :)
     
  17. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Yes, I understand what you mean. And I could incorporate something like this for some weapons. But, I want to be careful about messing with weapons. I think it should be something reserved for rare or specialty weapons if I am going to make such limitations.

    But, restrictions can be made for other items other than weapons. And, now that I know how to do it, I can impose all sorts of restrictions (skill levels, perks, experience level, karma, set global variables, traits, etc.).

    @Killap: Thanks.
     
  18. bombic85

    bombic85 First time out of the vault

    19
    May 22, 2010
    You can try and modify restrictions for other items, the question is if it makes any noticable impact in the game and hence worth the effort. Imo Fallout is heavy on weapons/armor and related perks/traits while most others are more or less marginal(drug,chem resillience, sex appeal..) Only things that comes to mind in the spirit of the moment is mild restriction for stimpacks to make the beginnings little more challenging.

    Not trying to discourage you though, just thinking out loud..
     
  19. Matt Drax

    Matt Drax Smart Ass

    103
    Sep 4, 2010
    Nice to hear that MegaMod still goes on.
    I agree on the requirements behalf for selected High Level equipment, but please don't overdo it:
    Fallout lives greatly on the freedom to do as one pleases ^^

    Could you maybe look into the issues with the Version from GoG.com? I think it has to do somethink with a little other master.dat build.
    I even tried to infuse manually the correct files, or to place them in the PROTO Folders, but to no avail. Still black EPA Main Map :\ Sadly I otherwise haven't got a Original US Version to fiddle with, only EU.

    Also the Message Bug "You see a..." if using the Gasmask is still there (at least for me, hadn't memorizes ALL bugfixes, and yes, I gave myself the Gas Mask with F2se. If that's the cause, forget I mentioned it ^^")
    The oddest thing I encountered so far at my various complete new installations is, that sometimes the Temple of Arroyo or the Hunting Ground Maps are either: Corrupted or, in the latter, not updated to the new version. This confuses me more than any other bug. An yes, of course I downloaded multiple times and checked CRCs ^^"

    Well.. maybe it's just me and my "new" HDD :\
    Anyway, Cheerio MegaMod :drunk:
     
  20. Solon

    Solon First time out of the vault

    61
    Dec 8, 2007
    Hot damn, welcome back! Glad to see you made it back safe and sound.
    I'll be checking back for another update. Thanks for the recurring and lengthy work MIB88, I've been getting the Fallout 2 urge again.
     
Thread Status:
Not open for further replies.