Fallout 2 mod Unofficial Fo2 patch thread - problems, reports, suggestions

Discussion in 'Fallout General Modding' started by Per, Aug 15, 2007.

  1. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I don't really have any experience with WINE and Fallout 2, but I know others have gotten it to work just fine. Though these comments are for the Restoration Project, I suppose they also apply to my unofficial patch. Check this.

    Also, there is no need for the official 1.02 patch and definitely don't use the unofficial 1.05 patch (it has numerous problems). Instead, install Fallout 2 and then install the unofficial patch from my signature (1.02.26b at this time).
     
  2. McArcher

    McArcher First time out of the vault

    4
    Apr 28, 2010
    Hello,

    I have installed on US-version of Fallout 2 (v1.00) Killap's patch 1.02.26 and WinXP SP3 started giving following error:

    "This program requires Windows 95 with DirectX 3.0a or later or Windows NT version 4.0 with Service Pack 3 or greater."

    The game doesn't start.

    Please, help.
     
  3. Glovz

    Glovz Vault Dweller
    Modder

    737
    Sep 16, 2005
    Using the Tweak should not have any adverse affects, there are many possible reasons why you could be getting 0 damage critical hits. Any games saves are not affected.

    If after playing the game with the tweak off and on you notice criticals are affected drastically. Then play with it off.

    But definitely for now do not turn on the mod in the ini, that would definitely affect things incorrectly at this point. I will be changing it eventually.
     
  4. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Install this: http://www.microsoft.com/downloads/...38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en
     
  5. G-Flex

    G-Flex First time out of the vault

    59
    Apr 28, 2010
    When you say this, do you mean that the tweak is effectively active for any savegame which was started with the tweak active, even if I shut it off via the config file?
     
  6. Glovz

    Glovz Vault Dweller
    Modder

    737
    Sep 16, 2005
    I mean the setting has nothing to do with how or what is saved.

    So if you played with the Tweak ON and saved a game and then turned the Tweak OFF and loaded the save, nothing will break and the save has no memory of whether the Tweak was ON or OFF.
     
  7. Random Turnip

    Random Turnip First time out of the vault

    66
    May 29, 2009
    I should have mentioned, i have the UK version, will that make a difference?
     
  8. McArcher

    McArcher First time out of the vault

    4
    Apr 28, 2010
    I have done this, but the same error is still shown at game start. By the way, I have updated DirectX before, and it is already the latest for WinXP. What is the reason?
     
  9. Shadenuat

    Shadenuat First time out of the vault

    1
    Apr 29, 2010
    Same problem as McArcher (running on Windows XP). Btw, if you uninstall the game and then install it, that message still pops out - until you manually deinstall patch from windows programs screen - that is confusing, to say the least.
     
  10. Merchant's Skeleton

    Merchant's Skeleton First time out of the vault

    7
    Apr 6, 2010
    Any update on when a new version might be out? I saw somewhere that Killap was wanting to put out a new version of the RP at the end of April. Any news concerning an update to the Unofficial Patch?

    I've held off from starting a new game until the extra 15 karma at the beginning is removed. It makes a real difference in the beginning I think - the people in Klamath regard you more highly, not calling you a dumb tribal, etc, and it must be a positive disadvantage if you're wanting to play evil. No pressure though. I'm starting a new game of Torment at the moment in any case. First replay in quite a few years, can't wait.

    I'd really love to replay FO2 after that however. :wink:
     
  11. .Pixote.

    .Pixote. Antediluvian as Feck
    Modder

    Sep 14, 2009
    The release might be closer to the middle of May; there are a lot of things to fix and possibly a few new things included (fingers crossed).
     
  12. Merchant's Skeleton

    Merchant's Skeleton First time out of the vault

    7
    Apr 6, 2010
    Thanks mate. Sounds intriguing.
     
  13. BigDuke66

    BigDuke66 First time out of the vault

    58
    Feb 8, 2005
    Can we upgrade a running game or do we have to start a new game?
     
  14. SHADOW-XIII

    SHADOW-XIII First time out of the vault

    98
    Nov 19, 2007
    @BigDuke66: it should be compatible however some locations needs to be entered first time to make fixes working therefore you can start but progress slowly :)
    personally I cannot wait to play RP2 but waiting for 2.1 :)
     
  15. McArcher

    McArcher First time out of the vault

    4
    Apr 28, 2010
    Can anyone help me with my problem?
    Is everyone playing 1.02.26 on WinXP-SP3 without such problems?
    Maybe it's the Windows's problem? What OS should I install then? I want to play this fantastic game again, to remember the taste of it...
     
  16. .Pixote.

    .Pixote. Antediluvian as Feck
    Modder

    Sep 14, 2009
    Wait a bit longer, I realize a lot of people feel annoyed with the level of bugs with the first release of RP, but there was always going to major bugs to contend with, it’s difficult to catch everything with a small group of testers, that’s why the fan base are the best bug catchers. :wink:
     
  17. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    People are once again merging RP posts with unofficial patch posts.

    Since a new version of the RP will be out in 2 weeks or so, this does mean that a new unofficial patch will be out. There aren't too many unofficial patch fixes this time around, so it won't be as big of an update as the last one. All unofficial patch saves will be compatible with the next patch.

    The RP update will be a big bug fix one, saves will of course be compatible. However, that is for the RP thread and not here.
     
  18. McArcher

    McArcher First time out of the vault

    4
    Apr 28, 2010
    Ok, thanks for these words. (I was just thinking that nobody was interested in helping, but you made me change my mind =) )
     
  19. lparkh

    lparkh First time out of the vault

    2
    May 9, 2010
    1.2 save file crashes with 2.0

    I thought I read that v2.0 would be backward compatible with 1.2 games (Fallout Restoration). Was I wrong ??
    I installed 2.0 over my 1.2 install. Now my save games (any of them) crash upon load. I also tried a complete vanilla FO2 install..no patching other then FR 2.0 ... and again same problem. Looks like I can start new games fine.
    This is about the 8th FO2 games I've tried to finish over the years and am pretty frustrated at this point.
    Any help would be really appreciated, and thanks for all the labor that 2.0 represents.
    Lin
     
  20. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Re: 1.2 save file crashes with 2.0

    1.2 saves are not compatible with 2.x saves. I even said this before and after the release. You'll have to revert back to 1.2 to continue playing your game.

    Also, this thread for the unofficial patch, not the RP.