Fallout 2 Restoration Project 1.2 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jun 9, 2008.

Thread Status:
Not open for further replies.
  1. Glovz

    Glovz Vault Dweller
    Modder

    736
    Sep 16, 2005
    Timeslip did add my correction for the AP Ammo Mod, but I only realized later that the same bug affected the Damage Calculation Tweak mod as well. So I don't think he has applied my fix to the Tweak yet. :(
     
  2. TwinkieGorilla

    TwinkieGorilla This ghoul has seen it all

    Oct 19, 2007
    i got the compatibility mode error as well, turned it off...game loaded...chose a savegame that i was working on...

    got a big black screen and a "program not responding" up my ass.

    guess who didn't make a back-up? jokes on me i guess. :roll:
     
  3. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Ah, ok, I missed that he is running the tweaked version. I know the ammo mod (option 1) works fine.
     
  4. SSgt Curious

    SSgt Curious First time out of the vault

    25
    Jun 4, 2008
    1.2 is great, i especially like the tweaked party armor, very nice. i do have one problem possibly bug related. i can't find fred or frank or whatever for beckys for quest in the den. Ichecked flicks where he usually seemed to be but nothing so then i proceeded to talk to every oneto no avail. did he skip town? :P
     
  5. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Fred is there. No rly. Just look.
     
  6. Minigun Jim

    Minigun Jim It Wandered In From the Wastes

    157
    May 12, 2008
    Exactly the same as I was before. F2, RP, Weapons Redone Mod. Since you said I could use it with the old saves, I just loaded one of them. The same problem happens on a clean install of F2 and the RP without the NPC armor mod.

    Sure, but it's the same bug whether I use an old save from 1.1 (which was fine) or a new save from 1.2

    Will do the ddraw change later, but it's a single-core processor anyway.

    Here's a more exact description:
    Everything loads and runs slower, starting with the Fallout 2 menu screen itself. The processor usage is around 98%. I had the same sort of speed issues when I tried runnning 1.1 of the RP under win95 compatibility mode. It's not in compatibility mode now, as I got an error when I tried to do that to see if it made any difference.
     
  7. isfet

    isfet First time out of the vault

    74
    Jan 19, 2008
    jesus! I installed 1.1 how dumb am I? well sorry for bothering you :oops:

    EDIT: I'm even dumber! I had 2 copies of F2 installed
     
  8. Wamphyri

    Wamphyri First time out of the vault

    13
    Jun 10, 2008
    hello there again :)


    second day second problem :/
    sorry for that

    anyways ...
    can you somehow tell me if there are language related parts about your project except for the text folder?

    the text problem shows people just talking about "error" all day ... but i can't understand what the language could have to do with the maps i can't enter o_O


    by the way could you try a little thing for me? maybe i'm just stupid but if i try to change the language of my copy by changing the fallout2.cfg .... the game crashes after the fallout loading screen ...
    am i doing that part wrong or is it impossible to change the language just like that?





    you know what... ill try it on my xp partition and have a look at the bugs there .. maybe vista sucks again :)



    Edit:

    Oh my god.... you won't believe it..... it works ... EVERYTHING works just fine on my second partition (windows xp)
    Microsoft Windows = Error x10 :)




    By the way .... i met this other chosen one dude already .. he started talkin and attacked me ... then my first kick set him ko .... he stood up and began talkin the same thing again ... this kinda sucked :) maybe its a bug if you set him ko in a first strike ? i dont know anyways i set him ko a second time ... robbed him and then he was gone telling me that we would see each other again :) kinda cool i was wondering where to get the 350$ to free sulik but now i just robbed 1000 and a super stimpack :P
     
  9. Carib FMJ

    Carib FMJ Nuka-Cola Chaser

    Nov 8, 2003
    I can't wait to play this newest edition. Man, Killap, you are doing great things for Fallout!!!
     
  10. tomten

    tomten It Wandered In From the Wastes

    164
    Jan 6, 2008
    FO2 has always taken ~100% CPU for me (F2RP makes no speed or CPU difference), and I assumed it was because of the way it was programmed (tight loops etc). I didn't understand from your post whether you could get FO2 to take less than ~100% CPU somehow. Can you?
     
  11. Ravager69

    Ravager69 Sonny, I Watched the Vault Bein' Built!

    Dec 21, 2007
    Phew - I had an error while installing the mod (source file corrupt or something), but I re-downloaded it and now it works just fine! Thanks again!
     
  12. Robsoie

    Robsoie First time out of the vault

    7
    Jun 9, 2008
    Is there anyone else that tried to run FO2+RP2 under window 98 or Me and does not get a direct CTD when entering (loading) the Primitive Tribe map ?

    This problem does not seem to affect window XP and 2000.
     
  13. step2ice

    step2ice First time out of the vault

    5
    Jun 11, 2008
    Is there anything I have to keep in mind when usind the restauration mod?
    Do I have to install patches first or something?
    Or can I use this with a clean Fallout 2 install from the Fallout collection?
     
  14. tomten

    tomten It Wandered In From the Wastes

    164
    Jan 6, 2008
    http://falloutmods.wikia.com/wiki/F2RP_Technical_Info
     
  15. Lord Danath

    Lord Danath It Wandered In From the Wastes

    130
    Jan 14, 2008
    Yes thats the version 1.28.2.0.
    Option number 2 in ddraw.ini

    Edit: Sorry, I missed Glovz post before
     
  16. Timeslip

    Timeslip Water Chip? Been There, Done That
    Modder

    921
    Aug 15, 2007
    As a slight addition to that, I have included that fix: It was in 1.29b. You can swap out the old dll with the new one if you really want to use the damage tweak.
     
  17. Omegawolf

    Omegawolf It Wandered In From the Wastes

    126
    Feb 1, 2008
    When you talk about a damage tweak, you're not talking about the AP mod, are you? What exactly is this damage tweak?
     
  18. Skynet

    Skynet Mildly Dipped

    501
    Jun 5, 2003
    This is what is left:

    Bad tiling on multiple walls in warehouse undeground area (you know, the one with cryogenic chambers). Only one part of the same wall tile is used.

    In EPA level blue, the middle suspension tank wall section is longer than the other two.
     
  19. Continuum

    Continuum Vault Fossil

    Nov 8, 2006
    And the WIP 3d renders!!! of hibernators/chambers/whatever are not replaced with the new ones...
     
  20. Slowhand

    Slowhand First time out of the vault

    55
    Apr 23, 2008
    @ killap

    The 'art_cache_size' fix and r/o attribute check of proto folder files are still mentioned in the wiki. IIRC, both issues were rectified in your latest release. I'd like the delete those sub-topics, unless there's a possibility of encountering those problems after manually installing the RP. What's the verdict?
     
Thread Status:
Not open for further replies.