Megamod 2.4 Technical Issues and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Dec 3, 2009.

  1. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    @Junpei: Not sure what is going on with your game, then. The cockroaches have been fixed for the next release. In case you haven't already done so, be sure to delete hs_ondeath.int and gl_ondeath.int from your data/scripts folder. If that doesn't stop the freezing, I don't have any other suggestions, but please list here any files in that folder for me that you have that begin with either 'hs_' or 'gl_'.
     
  2. Junpei

    Junpei First time out of the vault

    13
    Dec 23, 2009
    There was a hs_ondeath.int only, no other files with a hs_ or gl_ prefix in the scripts folder. Got to do some testing after deleting the file.
     
  3. elotrocoso

    elotrocoso First time out of the vault

    24
    Sep 27, 2006
    Klint armor ssue

    Hi, I installed a couple of days ago and everything is running smoothly, but I now realized that klint's specialty change when equiping different types of armor, as well as the health, ap, and carry weight changes are nto happening at all.
    I ve just tried it with the leather jacket and the leather armor for now, but im curious if this is an indication of a faulty megamod install, or if it is intended with the new updates. Another similar problem I'm getting is that my NPCs are not leveling up, i ve had sulik since lvl 5, and cassidy and vic a bit later, but i must have gone 3 or 4 levels and sulik is still lvl 1.

    I am also now getting an unfortunately gamebreaking crash in a fight in the den, whenever I kill one of the slaver thugs..... it happens after the death animation and the message is something like "the instruction at 00417bda referenced memory at 6ac0013c, Thememory could not be read from"

    I followed all the istall indications(protos on read only, 1st install)(this is the 3rd time I unsuccessfully try the megamod :( )

    Any help would be appreciated
     
  4. pewbeng

    pewbeng First time out of the vault

    15
    Sep 23, 2008
    Re: Any ETA on 2.41?

    Any news on this? :)

    Can't wait for my first playthrough with your mod. Good stuff.
     
  5. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Re: Klint armor ssue

    This has already been addressed. However, the cause that I posted earlier is not correct. Further testing showed that the problem actually lies in the later version of sfall being used with the MM. Therefore, until sfall can be modified to correct for this, your options are to either leave Klint out of your party or turn on automatic leveling.

    Also addressed. Read this thread regarding random encounters. Hell, read this page.

    As for the next version/update, I wanted to have it out last week. Just got busy with some real world stuff. Just a few more things to add and check through, then it should be ready.

    Code:
    -Changed many of the encounters in which enemies were using dogs in their
    party to attack the player. Now the dogs attack at the same time as the
    other human enemies. (This was actually done in 2.4, but I forgot to
    mention it.)
    -Updated the way certain dialogs are handled in Bunker 21
    -Corrections to Scraptown
        -The car will no longer disappear if you drive it there
        -Corrections to various NPCs there
    -Attempting to recruit Dogmeat with iguana-on-a-stick no longer crashes
    the game
    -Xarn fixed: player can no longer set him free and get him to join you and
    fight on your team
    -Changes to roaches
        -Spit weapons work better and you will no longer see messages about
        them being out of ammo
        -Sounds work better
        -Eliminated the chance for 'looping', causing the roaches (and the game)
        to freeze
    -New artwork for Metzger (in a certain situation)
    -A number of new inventory items (though not fully implemented yet)
    -Corrections to Klint
    -Corrections to some support files
    -Added files for critters/scenery in Vault 14
    -Changed issues regarding money with the San Francisco merchants
    -Added the NPCs Loot Bodies Mod by pelicano
    -Included a number of missing files for the Primitive Tribe and Slaver Camp
    -Attacking NPCs at the truck location and Bunker 21 will no longer ruin
    your reputation in Arroyo
    -Added a couple of new features for the car
        -Paint Job mod by Nirran included
        -The car will need more than just energy cells to keep running
    -New Armorer perk
    -Change in giving Jet antidote to Fannie Mae
    -Vertibird Assault Team encounter no longer spawns Enclave ptrolmen
    on top of each other
    -Addition to Skynet to give him a little more 'life'
     
  6. Mactab

    Mactab First time out of the vault

    33
    Jun 20, 2008
    I'm having sfall problems too! None of the solutions in this topic worked.

    I installed Megamod 2.35, then the 2.35.2 patch, then the 2.40 patch. Then I tried to run the game, and it told me sfall was out of date. I updated sfall from 2.0b to 2.2b, and ran it. Now I get an error

    This application has failed to start because d3dx9_42.dll was not found. Re-installing the application may fix this problem.

    What now? Deleting ddraw.ini and ddraw.dll fix the problem but I don't want to lose content.

    BTW, this wasn't a problem with MM v 2.35.2
     
  7. Timeslip

    Timeslip Water Chip? Been There, Done That
    Modder

    921
    Aug 15, 2007
    Your direct x installation is out of date. You need to update it.

    You haven't hit that error before because when I was rebuilding everything after my computer died, I installed a newer version of the directx sdk, so sfall links against a newer version of the d3dx dll now than it used to. Whatever old version of directx you have installed, it must already include the d3dx dll that the older sfall versions used.
     
  8. Mactab

    Mactab First time out of the vault

    33
    Jun 20, 2008
    My DirectX is not of date. Your readme says I need 9.0c or or later. I have 11. 11 > 9.0c. So it should work, right? Or do I need to install an older version of directX to get this to work?
     
  9. Timeslip

    Timeslip Water Chip? Been There, Done That
    Modder

    921
    Aug 15, 2007
    No, the readme mentions a specific dated version of 9.0c. (Or, if it doesn't, it should.) Microsoft, rather confusingly, had several years worth of directx releases all labelled 9.0c. :(

    DirectX 11 is a separate set of files, and depending on where you installed it from it's quite possible to get it without having a complete DirectX 9 installation. (i.e. if it was installed as part of a game, or was the version included with windows.) Run the directx web installer; that should ensure that you have everything up to date.
     
  10. Mactab

    Mactab First time out of the vault

    33
    Jun 20, 2008
    Ah, okay. I installed 9.0c, and started fallout 2. This time, new error!

    I'm sorry I'm having so much trouble, but could you please tell me what's wrong with my game? All I did was install the megamod. I'm pretty sure I AM running v1.02, though it might be Killap's patch. But, if I overwrote all of those files with the megamod files, why would it matter what was there before? Unless I changed a file that was supposed to remain unchanged, but I can't think of what it could be. My fallout2.exe was replaced by megamod.

    I also looked at your FAQ:
    Again, I am using the exact fallout2.exe that came with the mod... so how is it not compatible?

    A google search for this problem yielded nothing useful.

    Still can't figure this out. I've tried everything I can think of. There is no mention of this glitch in the older topic.

    I downloaded the US v1.02d patch and tried replacing my fallout2.exe with it, but when I started the game I got an error about it not being able to load cities. I concluded that the fallout2.exe that came with the mod is the correct file I want to be using. So why is this not working?
     
  11. Timeslip

    Timeslip Water Chip? Been There, Done That
    Modder

    921
    Aug 15, 2007
    Why search the older topics without checking this one? Your answer is a mere two pages back. :roll: (Hint: the option you want is ExtraCRC)
     
  12. Mactab

    Mactab First time out of the vault

    33
    Jun 20, 2008
    Oh my goodness, thank you. I missed it in this thread because it didn't match my exact search phrase.

    Sorry, but what's the CRC code that I want to put in? I looked at the properties of the executable but didn't see any "CRC code". I skimmed the wikipedia article on CRC and even googled how to find the CRC code of a file with no answers. I tried setting ExcessCRC equal to the memory addresses that the above error message was giving me, but that apparently isn't right either. Sorry this is all going over my head; I study ME, not CS.

    I downlaoded a program that said it can find the CRC code of a file. So I used it to find the CRC code of my fallout2.exe to be 033973D8. So I put this line into my ddraw.ini:


    ExtraCRC=033973D8

    And ran fallout2.exe but the error did not go away!
     
  13. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    You don't need a CRC checker. sfall has already told you the CRC of Megamod's EXE: "... Expected 0xe1680293 but got 0xe348e17f"
    So the correct line you have to add to ddraw.ini is: ExtraCRC=0xe348e17f
     
  14. Mactab

    Mactab First time out of the vault

    33
    Jun 20, 2008
    Thank you, it finally worked! I thought I had already tried that memory address. Apparently I must have had a typo and failed to verify. I tested the first memory address more (the 168) because I thought sfall was looking for memory address 168 but kept getting returned 348 from fallout2.exe, so if I added 168 it would satisfy it.
     
  15. Mactab

    Mactab First time out of the vault

    33
    Jun 20, 2008
    This one is finally about playing the mod.

    I got Klint at level 2 and Sulik at level 3. When I hit level 5, neither of them had leveled once. I went into the ddraw.ini and turned off the random element in party leveling, hoping that it would fix the problem. Then I leveled to 7, and neither of them have leveled yet! I've verified that I don't have any of those bad files in my critters folder. And I did run the runme.bat file when I installed. Also, I'm not positive, but I think I remember Sulik leveling up with me when I hit level 3, but he still has 85 hp indicating he is level 1. Could this be the problem with NPCs forgetting their levels? I don't know why I would get this bug, since I did run the runme.bat file.
     
  16. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    This isn't a long thread. But the answer is here... on this page, even.
     
  17. Mactab

    Mactab First time out of the vault

    33
    Jun 20, 2008
    that fixed it, thanks. My search criteria wasn't hitting that post.

    Couple other queries:

    1) I assume that when the random element from NPC leveling is removed, NPCs still don't level every time I level, correct? I ask because when I leveled to 8, Sulik and Vic both leveled to 2, but when I leveled to 9, neither of them leveled.

    2) I permanently lost 2 PE. I can verify it occured in the Den as I have two savegames while in the Den and in the later one I have 2 less perception. I had completed pretty much every quest in the Den between these two savegames so I can't narrow down exactly which event did it. I tried resting for several weeks and it never went away. I don't have any radiation sickness so that's not it either. Any ideas?

    Also, I opened up my save.dat, and combed through it until I found a chain of numbers that looked like my stats. I found it on line B919, and the value displayed for my perception is exactly what I began the game with, not counting my bonus from gifted. This means that whatever is giving me -2 PE is a soft modifier not a permanent change to my base stat. I wish I knew how to get rid of it in a hex editor, but until then I'm going to inflate my base value by 2.

    3) Why did you make it so enemies throw their weapons when they die? Is there anyway to turn this off? It gets annoying when the weapons drop inside of walls, rendering them unlootable. Also, implementing the shift key higlighting items on the ground was a great idea.
     
  18. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Yes. Read this thread. Seven pages. It's not like 160+ pages of the RP thread.

    I don't quite know how the automatic leveling feature works as I've never used it. I am pretty sure party NPCs are not supposed to level each time your character levels up, but every 3 or 4 levels, I think.

    Also, one of your messages that you edited once mentioned something about high radiation counts. Radiation for Colly is high. Also, radscorpions can irradiate you if you get too close to them now.
     
  19. Mactab

    Mactab First time out of the vault

    33
    Jun 20, 2008
    Again, sorry for not catching that earlier. I did do a search through this topic trying to find mentions of my problems, but my search criteria doesn't match what other people write. I assume there is no way to fix the permanent perception modifier once it's been incurred?
     
  20. destep

    destep First time out of the vault

    2
    Feb 7, 2010
    perception problems

    Your perception problems are from weather.ini that has already been addressed in the previous posts, and the fix is to use a cheat editor named in the previous post. There are only 7 pages here, and it takes all of 20min or less to read.