Megamod 2.43 technical issues and suggestions

Discussion in 'Fallout General Modding' started by MIB88, Dec 8, 2010.

  1. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    I will look at the program later today,the im you sent does not decompile for me either,but i have a current source code of it in my source folder(assuming you didnt alter it after the fact) and it compiles / decompiles,it has the map enter floats(last thing i added)

    @weapon crash bug : that was an sfall bug,i think it was fixed,try updating sfall,and make Sure that you do NOT copy ddraw.ini into the folder ,manualy copy the file and make sure all settings in the default Megamod file are in the new ddraw.ini before you copy the file,that may be the bug you are experiencing kedimsidomuz


    Nirran
     
  2. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    Well, I was wrong... it has nothing to do with a weapon in my hand.

    I create a char. Save right away. thats ave game is ok... I wait a few seconds and save again in a second slot, that save crashes the game, my first save still loads ok.,

    updated to the new sfall (just dll, no ini) same problem.

    Something very strange...

    Michi
     
  3. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    go to the save folder and delete game slot 2,sometimes fo2 will error when you try to save on a slot that previously errored when saving(took me hours to find that error behavior once,odd)

    Nirran
     
  4. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Sounds like you have just something really weird going on there, Michi. Try these (from the readme):

    5. Install the game and mod to a new location. Do not use the location you usually use. Pick a new folder entirely or, better yet, a different partition of your hard drive.
    6. If you are going to uninstall a Fallout 2 game, you should also
    restart your computer after doing so, before reinstalling the game again and adding the Megamod.
    7. If you have installed the game many times on your computer and removed it, it might be a good idea to also run a registry cleaner.

    Good luck.

    Edit: Nirran beat me. Or just try what he said.
     
  5. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    Michi : any mods installed besides megamod?

    Nirran
     
  6. _Serena

    _Serena First time out of the vault

    1
    Dec 16, 2010
    dwwin.exe error

    Hi, got a problem with megamod. I've already tried everything I found. Reinstalled, changed the install steps, edited ddraw.ini.
    Sometimes, when I load a game, or something happens in the game, it throws this error:
    dwwin.exe application error

    Unknown software exception 0x80000003 in the aplication at address 0x7c90129e

    Tried these install steps:
    Fallout 2-megamod 2.23
    Fallout 2-patch-megamod
    Fallout 2-patch-unofficial patch-megamod
    unpacked everything, that could be unpacked and it still throws these errors.
    My specs: Acer TravelMate 4650
    Intel Pentium 1.5GHz
    504MB RAM
    Intel(R) 915GM/GMS,910GML Express Chipset 128MB
     
  7. Warhameron

    Warhameron First time out of the vault

    9
    Dec 17, 2010
    Hi
    When i load a game(always) ,got ping sound and freeze screen(alt-tab to look what happen and get error message:
    The instruction at00459781 referenced memory at 000000064
    The memory could not be read from

    Click on OK to terminate application

    Work on Windows Vista.
     
  8. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    Yes!

    Exactly the bug Warhameron has.

    I have totally uninstalled F2, cleaned my registry, re-installed in a whole new location, installed megamod, same problem... crash on re-loading even if I have done almost nothing.
     
  9. kedimsidomuz

    kedimsidomuz First time out of the vault

    43
    Nov 17, 2006
    My problem is exactly the same with Warhameron too.
     
  10. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    try using the exe from the official patch,ive seen problems with the exe megamod ships with before

    Nirran
     
  11. Warhameron

    Warhameron First time out of the vault

    9
    Dec 17, 2010
    1.Reinstall. 2.download patch uk.,3.unzip 2 F2 folder, delete patch .dat 4.instal megamod try to run ( input device error, change mouse and keybord to 1) 5.game run,savegame working for few mins. After i stole spear from first npc or take berreta in temple i got the same error and cant load any savegame. (I also change all critters and items 2 read only).

    Sorry for my bad english :D
     
  12. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    if you were trying my suggestion,you should unzip the official patch in a temp folder,install fo2 then megamod,then copy the official patch exe into fo2 folder,then run fo2,installing megamod last will still use megamod shipped exe

    Nirran
     
  13. Rantalot

    Rantalot First time out of the vault

    8
    Dec 11, 2010
    @ kedimsidomuz & Michi

    Can either of you please check if you can get Klint to give up his spear after he equips it?
     
  14. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    I used the official patch exe, as well as trying the exe that comes with the latest RP. Both crash when loading a save.

    Again, it isn't right away... the first save I do works... it is takes a little bit before the save is faulty. But it isn't dependent upon holding a weapon, since I am weaponless, and my inventory is empty.

    I should mention I am using Windows 7 64 bit.

    It could be t hat both War and I are suffering form using later OSs than XP...

    Michi
     
  15. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Ok, let's try something then. Can you remove ddraw.ini and ddraw.dll temporarily? Just place them in a different folder. That is my first guess regarding what to check.

    Just out of curiosity: did any of you have a previous version of the MM?

    The next thing might be to check those global scripts that are always running in the background (those "gl_" scripts). I can't imagine what might be causing this, but it would be easy to test it through a process of elimination.
     
  16. bonczyk

    bonczyk First time out of the vault

    13
    Jul 27, 2007
     
  17. ullmannfe

    ullmannfe First time out of the vault

    1
    Dec 18, 2010
    I also have the same problem as Michi and Warhammeron and i did the same steps as warhammeron, too.

    removing the "ddraw.dll" and the "ddraw.ini" to another folder (translations folder in my case) results in a "wmArealnit::Error loading Cities" error-message.

    I have Windows XP Professional SP3 and latest DirectX installed..
     
  18. Rantalot

    Rantalot First time out of the vault

    8
    Dec 11, 2010
    Hey i just found a weird bug, but this might help some people w/their save problems (I hope).

    I reinstalled the game and megamod, but decided to start with the shortcut that megamod puts in the start menu instead. Doing so caused all sorts of weird glitches and crashes, at first I thought I did something wrong but then i started using the fallout.exe file, like I always do and the game worked, still had the companion issues i mentioned earlier but no random color shows and weird crashes. I also noticed that the shortcut that megamod installs says 2.42 not 2.43. So for those encountering varies oddities, try going to the folder that contains the fallout.exe and start the game using that file.
     
  19. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    Before we go ahead and say that fallout2.exe or sfall's ddraw.dll doesn't work with Win 7, I would like to mention that I successfully played through 90% of RP 2.1.2b on this same computer, using sfall and the Hi-res patch

    That said, bonczyk's excellent testing does seem to imply that something in the MM doesn't like Win7/Vista

    EDIT:

    Inspired by bonczyk, I installed in two separate directories MM242 and MM243 on my Win7 machine.

    242 plays fine, saves and restores
    243 has the aforementioned crash

    Hope that helps narrow it down.
     
  20. bonczyk

    bonczyk First time out of the vault

    13
    Jul 27, 2007
    May this be the question, that the version of sfall that comes with mm 243 seems to be out of date?

    on my starting screen of f2, in the bottom-right corner, it shows the following:

    "Fallout II megamod 2.43
    sfall 2.8c"

    But in the top part of the screen ther's a text that says "a newer version of sfall is available 2.11.1" and there's a link to sourceforge...